Sie sind nicht angemeldet.

Beiträge: 2

Registrierungsdatum: 12.06.2012

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

21

12.06.2012, 21:13

Hallo,

meine Mitbewohnerin hat das selbe Problem, nachdem Sie gestern Ubuntu geupdatet hat.
Als Technischer Verantwortlicher unserer WG habe ich die genannten Vorschläge mal getestet, leider ohne Erfolg.
BS: 32Bit 12.04LTS
Rechner: Lenovo B570

Hier mal die Ausgaben der Befehle:

iwconfig

Quellcode

1
2
lo        no wireless extensions.
eth0      no wireless extensions.



lsmod

Zitat

Module Size Used by
snd_hda_codec_hdmi 31775 1
snd_hda_codec_realtek 174055 1
joydev 17393 0
rfcomm 38139 0
parport_pc 32114 0
ppdev 12849 0
bnep 17830 2
bluetooth 158438 10 rfcomm,bnep
binfmt_misc 17292 1
snd_hda_intel 32765 3
snd_hda_codec 109562 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 13276 1 snd_hda_codec
snd_pcm 80845 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi 13132 0
snd_rawmidi 25424 1 snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event
rts5139 279622 0
snd_timer 28931 2 snd_pcm,snd_seq
snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
snd 62064 16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
uvcvideo 67203 0
videodev 86588 1 uvcvideo
psmouse 72919 0
serio_raw 13027 0
ideapad_laptop 17890 0
sparse_keymap 13658 1 ideapad_laptop
soundcore 14635 1 snd
snd_page_alloc 14108 2 snd_hda_intel,snd_pcm
i915 414672 3
drm_kms_helper 45466 1 i915
drm 197692 4 i915,drm_kms_helper
mei 36570 0
i2c_algo_bit 13199 1 i915
video 19068 1 i915
mac_hid 13077 0
lp 17455 0
parport 40930 3 parport_pc,ppdev,lp
r8169 56321 0

lspci -nnk | grep -iA net

Zitat

02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
Subsystem: Broadcom Corporation Device [14e4:051b]
Kernel modules: bcma, brcmsmac
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
Subsystem: Lenovo Device [17aa:3975]
Kernel driver in use: r8169


rfkill list

Quellcode

1
0: ideapad_wlan: Wireless LAN	Soft blocked: no	Hard blocked: no



uname -a

Quellcode

1
Linux xxxx 3.2.0-24-generic-pae #39-Ubuntu SMP Mon May 21 18:54:21 UTC 2012 i686 i686 i386 GNU/Linux



Irgendwelche Ideen?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »FreeYourMind« (12.06.2012, 21:21)


bsn

User

  • »bsn« ist männlich

Beiträge: 505

Registrierungsdatum: 11.08.2006

Wohnort: Baden-Württemberg

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

22

14.06.2012, 15:56

Hallo,
du musst den STA unter Hardware-Treiber aktivieren, lege die falschen in die blacklist:

Quellcode

1
2
echo "blacklist brcmsmac" | sudo tee -a /etc/modprobe.d/blacklist.conf
echo "blacklist bcma" | sudo tee -a /etc/modprobe.d/blacklist.conf

Treiber entladen:

Quellcode

1
sudo modprobe -rf bcma brcmsmac wl

Treiber neu laden:

Quellcode

1
2
3
sudo modprobe -v wl
sudo depmod -a
sudo update-initramfs -u

Den STA unter Hardware-Treiber de- und wieder aktivieren. Beachte auch, dass der Treiber nur auf den Kanäle 1-12 läuft!

Gruß

bsn

Beiträge: 2

Registrierungsdatum: 12.06.2012

Architektur: 32-Bit PC

Desktop: Unity

  • Nachricht senden

23

19.06.2012, 15:49

Danke für die Antwort,

Habe mal die Befehle ausgeführt. Das entladen/neu laden klappt leider nicht weil "wl" unbekannt ist.
Fehlt hier ein Treiber!?

Gruß

EDIT: Das Problem hat sich erstmal erledigt. Neuinstallation auf Grund von ungeduldiger Mitbewohnerin hat es behoben.
Danke trotzdem!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »FreeYourMind« (19.06.2012, 21:03) aus folgendem Grund: Erledigt!


Beiträge: 5

Registrierungsdatum: 08.02.2013

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

24

08.02.2013, 10:27

Hi, ich besitze ein Lenovo T60 und mein "wireless is disabled by hardware switch".


Der Code:

Quellcode

1
2
3
iwconfigsudo iwlist scan
sudo rfkill unblock all
rfkill list dmesg | egrep 'wmi|wl'



Gibt folgendes aus:
iwconfig:

Quellcode

1
2
3
4
lo no wireless extensions.
wlan0 IEEE 802.11abg ESSID:off/anyMode:Managed Access Point: Not-Associated Tx-Power=offRetry long limit:7 RTS thr:off Fragment thr:offPower Management:on
irda0 no wireless extensions.
eth0 no wireless extensions.




sudo iwlist scan:

Quellcode

1
2
3
4
lo Interface doesn't support scanning.
wlan0 Interface doesn't support scanning : Network is down
irda0 Interface doesn't support scanning.
eth0 Interface doesn't support scanning.



rfkill list:

Quellcode

1
0: phy0: Wireless LANSoft blocked: noHard blocked: yes1: tpacpi_bluetooth_sw: BluetoothSoft blocked: yesHard blocked: yes



dmesg | egrep 'wmi|wl'

Quellcode

1
[   22.074299] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s[   22.074304] iwl3945: Copyright(c) 2003-2011 Intel Corporation[   22.074380] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17[   22.074396] iwl3945 0000:03:00.0: setting latency timer to 64[   22.131573] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels[   22.131578] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG[   22.131738] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X[   22.139973] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'[   23.200745] ADDRCONF(NETDEV_UP): wlan0: link is not ready



Hilft euch das vllt weiter?
Könnt ihr mir sagen, was das Problem ist?

Gibt es eine Möglichkeit, die FN-Taste und deren Kombination-Möglichkeiten zu aktivieren?

Gruß



PS: Irgendwie will er die Zeilenumbrüche leider nicht übernehmen, verzeiht!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »pandayo« (08.02.2013, 14:18)


bsn

User

  • »bsn« ist männlich

Beiträge: 505

Registrierungsdatum: 11.08.2006

Wohnort: Baden-Württemberg

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

25

08.02.2013, 11:16

Hallo,
man hängt sich nicht an einen Thread, mache das nächste mal einen neuen Thread auf, da du eine andere Hardware hast! Um in Codeblöcke Darzustellen musst du oben auf (#) Code einfügen anklicken. Zeige diese Ausgaben:

Quellcode

1
2
3
4
lsmod | grep iwl                      	
dmesg | grep iwl                          	
iwconfig            	
cat /etc/NetworkManager/NetworkManager.conf

Gruß

bsn

Beiträge: 5

Registrierungsdatum: 08.02.2013

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

26

08.02.2013, 11:27

Hallo,
man hängt sich nicht an einen Thread, mache das nächste mal einen neuen Thread auf, da du eine andere Hardware hast! Um in Codeblöcke Darzustellen musst du oben auf (#) Code einfügen anklicken. Zeige diese Ausgaben:

Quellcode

1
2
3
4
lsmod | grep iwl                      	
dmesg | grep iwl                          	
iwconfig            	
cat /etc/NetworkManager/NetworkManager.conf

Gruß

bsn

Andere Hardware, aber das selbe Probleme, daher der selbe Thread, aber okay, beim nächsten Mal mache ich es besser :)
(#) hatte ich genutzt, weiß auch nicht, warum er da rumspießt. Vor allem, da er es teilweise korrekt macht.

Deine Codes ergeben:

Quellcode

1
2
3
4
5
6
7
lsmod | grep iwliwl3945                73186  0 iwl_legacy             71187  1 iwl3945mac80211              436493  2 iwl3945,iwl_legacycfg80211              178877  3 iwl3945,iwl_legacy,mac80211
dmesg | grep iwl[   21.887647] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s[   21.887652] iwl3945: Copyright(c) 2003-2011 Intel Corporation[   21.887726] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17[   21.887742] iwl3945 0000:03:00.0: setting latency timer to 64[   21.952524] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels[   21.952530] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG[   21.952692] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X[   21.985250] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
iwconfiglo        no wireless extensions.
wlan0     IEEE 802.11abg  ESSID:off/any            Mode:Managed  Access Point: Not-Associated   Tx-Power=off             Retry  long limit:7   RTS thr:off   Fragment thr:off          Power Management:on          irda0     no wireless extensions.
eth0      no wireless extensions.
cat /etc/NetworkManager/NetworkManager.conf[main]plugins=ifupdown,keyfiledns=dnsmasq
[ifupdown]managed=false


Zitat

lsmod | grep iwl
iwl3945 73186 0
iwl_legacy 71187 1 iwl3945
mac80211 436493 2 iwl3945,iwl_legacy
cfg80211 178877 3 iwl3945,iwl_legacy,mac80211

dmesg | grep iwl
[ 21.887647] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[ 21.887652] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 21.887726] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 21.887742] iwl3945 0000:03:00.0: setting latency timer to 64
[ 21.952524] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 21.952530] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 21.952692] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X
[ 21.985250] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'

iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11abg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on

irda0 no wireless extensions.

eth0 no wireless extensions.

cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=false


Danke schonmal :)

PS: Wieder keine Zeilenumbrüche. Liegt das an Chrome, mir oder dem Forum?
Wahrscheinlich bin ich einfach nur zu doof -.-

27

08.02.2013, 11:32

weiß auch nicht, warum er da rumspießt.

Benutzt du Opera als Browser ?
Von dem ist es bekannt, da es da Probleme gibt, mit der Forensoftware.
                          Linux is like a tepee. It has no Gates, no Windows, and an Apache inside. :D

Beiträge: 5

Registrierungsdatum: 08.02.2013

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

28

08.02.2013, 11:33

weiß auch nicht, warum er da rumspießt.

Benutzt du Opera als Browser ?
Von dem ist es bekannt, da es da Probleme gibt, mit der Forensoftware.
Nein, Chrome

bsn

User

  • »bsn« ist männlich

Beiträge: 505

Registrierungsdatum: 11.08.2006

Wohnort: Baden-Württemberg

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

29

08.02.2013, 11:39

Hallo,
die Ausgaben sind nicht richtig! Du musst die Ausgaben markieren und dann Code einfügen! Führe folgendes im Terminal aus:

Quellcode

1
2
sudo modprobe -rf iwl3945                                  	
sudo modprobe iwl3945 disable=0

Gruß
bsn

Beiträge: 5

Registrierungsdatum: 08.02.2013

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

30

08.02.2013, 11:47

Hallo,
die Ausgaben sind nicht richtig! Du musst die Ausgaben markieren und dann Code einfügen! Führe folgendes im Terminal aus:

Quellcode

1
2
sudo modprobe -rf iwl3945                                  	
sudo modprobe iwl3945 disable=0

Gruß
bsn
Wie meinst du das?
Ich kopiere, was mir das Terminal ausspuckt in eine Text-Datei, diese kommt auf den USB-Stick, an diesen Rechner hier und dann in das Forum.
Jetzt glaube ich verstanden zu haben, was du meinst. Hoffentlich klappt es jetzt.


Quellcode

1
2
sudo modprobe -rf iwl3945[sudo] password for panda: 
sudo modprobe iwl3945 disable=0FATAL: Error inserting iwl3945 (/lib/modules/3.2.0-36-generic-pae/kernel/drivers/net/wireless/iwlegacy/iwl3945.ko): Unknown symbol in module, or unknown parameter (see dmesg)



Eingefügt, markiert und auf (#) geklickt.

Gruß

bsn

User

  • »bsn« ist männlich

Beiträge: 505

Registrierungsdatum: 11.08.2006

Wohnort: Baden-Württemberg

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

31

08.02.2013, 12:23

Hallo,
warum so umständlich! Du markierst die Ausgabe im Terminal kopierst sie und fügst sie in Forum ein! Da das oben nicht funktioniert zeige diese Ausgabe:

Quellcode

1
lsmod 

Gruß
bsn

32

08.02.2013, 12:26

warum so umständlich! Du markierst die Ausgabe im Terminal kopierst sie und fügst sie in Forum ein

Schwer ohne Internet, ich vermute, er arbeitet mit 2 Rechneren oder einem anderen System (Win).
                          Linux is like a tepee. It has no Gates, no Windows, and an Apache inside. :D

bsn

User

  • »bsn« ist männlich

Beiträge: 505

Registrierungsdatum: 11.08.2006

Wohnort: Baden-Württemberg

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

33

08.02.2013, 13:30

Hallo,
dann muss er es in eine Text-Datei umleiten !
Gruß
bsn

Beiträge: 5

Registrierungsdatum: 08.02.2013

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

34

08.02.2013, 14:20

Vielen Dank, werde das machen, sobald ich zuhause bin. Soll ich dann alle Befehle erneut ausführen?
Und was meinst du damit, das man das an der Ausgabe lsmod sehe?

Quellcode

1
2
iwl_legacy             71187  0 mac80211              436493  1 iwl_legacycfg80211              178877  2 iwl_legacy,mac80211[   21.967271] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s[   21.967276] iwl3945: Copyright(c) 2003-2011 Intel Corporation[   21.967354] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17[   21.967370] iwl3945 0000:03:00.0: setting latency timer to 64[   22.022710] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels[   22.022715] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG[   22.022912] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X[   22.050811] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'[  177.660431] iwl3945 0000:03:00.0: PCI INT A disabled[  193.361253] iwl3945: Unknown parameter `disable'[main]plugins=ifupdown,keyfiledns=dnsmasq
[ifupdown]managed=false



Zitat


iwl_legacy 71187 0
mac80211 436493 1 iwl_legacy
cfg80211 178877 2 iwl_legacy,mac80211
[ 21.967271] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[ 21.967276] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 21.967354] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 21.967370] iwl3945 0000:03:00.0: setting latency timer to 64
[ 22.022710] iwl3945 0000:03:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 22.022715] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 22.022912] iwl3945 0000:03:00.0: irq 45 for MSI/MSI-X
[ 22.050811] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[ 177.660431] iwl3945 0000:03:00.0: PCI INT A disabled
[ 193.361253] iwl3945: Unknown parameter `disable'
[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=false

Hatte es in einen Textfile schreiben lassen :(

Die beiden sudo-Befehle habe ich eigentlich auch hineinschreiben lassen, aber beim zweiten kam wieder der selbe Fehler.

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »pandayo« (08.02.2013, 15:19)


bsn

User

  • »bsn« ist männlich

Beiträge: 505

Registrierungsdatum: 11.08.2006

Wohnort: Baden-Württemberg

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

35

08.02.2013, 16:36

Hallo,
das scheint wohl ein Bug der Treiber Software zu sein! Ich würde es mit ndiswrapperund dem Windowstreiber versuchen! Oder Tante Google fragen.
Gruß
bsn

Beiträge: 47

Registrierungsdatum: 11.12.2010

Architektur: 64-Bit PC

Desktop: GNOME 3.0

  • Nachricht senden

36

18.02.2013, 18:51

WLAN funzt nicht mehr

Ich habe gestern ein Update durchgeführt. Ubuntu 12.04.

Nun kann ich keine Verbindung per DHCP zur Easybox 803 herstellen.

Verwende ich eine feste IP klappt die WLAN-Verbindung.

Läuft der Laptop mit fester WLAN-IP kann ich im Netzwerk die einzelen Geräte untereinander nicht mehr anpingen.

Die Hotline von Vodafone konnte mir nicht weiterhelfen. Angeblich ist die Easybox i.O.

Nun habe ich Ubuntu 12.04 von der Live-CD gebootet. Verbindung per DHCP klappt sofort. Die einzelen
internen Geräte können wieder angepingt werden.

Also hat das aktuelle Update das Problem verursacht.

Das WLAN selbst wird gefunden, aber die Anmeldung klappt nicht.

Jemand eine Idee was da vor sich geht ?

Grüsse
UbuBubi


23.02.2013
Es scheint, als ob das WLAN via DHCP wieder funktioniert.

In /etc/modprobe.d/ hat sich die Datei blacklist-bcm43.conf Datum
15.01.2013 18:40 eingeschlichen.

Durch Update ?


VORHER

Quellcode

1
2
3
4
5
6
7
8
: # lspci -nnk | grep -i net -A2
03:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8131 Gigabit Ethernet [1969:1063] (rev c0)
   Subsystem: Lenovo Device [17aa:3956]
   Kernel driver in use: atl1c
--
04:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
   Subsystem: Broadcom Corporation Device [14e4:0510]
   Kernel driver in use: wl



Nach entfernen von /etc/modprobe.d/blacklist-bcm43.conf funktioniert das WLAN wieder.

NACHHER

Quellcode

1
2
3
4
5
6
7
8
# lspci -nnk | grep -i net -A2
03:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8131 Gigabit Ethernet [1969:1063] (rev c0)
   Subsystem: Lenovo Device [17aa:3956]
   Kernel driver in use: atl1c
--
04:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
   Subsystem: Broadcom Corporation Device [14e4:0510]
   Kernel driver in use: brcmsmac

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »UbuBubi« (23.02.2013, 17:36)