Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Robi

User

  • »Robi« ist männlich
  • »Robi« ist der Autor dieses Themas

Beiträge: 222

Registrierungsdatum: 07.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

1

22.12.2010, 21:44

interner kartenleser

Hi,
mein Notebook hat einen Katenleser.

egal ob ich da eine Karte drin ist oder nicht, ich finde die Karte nicht.

Wie kann ich
a) feststellen ob mein Ubuntu 10.10 den Kartenleser überhaupt kennt
b) die Bilder auf der Karte ansehen ?
Danke
Robert

2

22.12.2010, 22:03

Nabend Robi,

schau dir nach einstecken einer SD-/XD/etc...-Karte einmal die Logdatei: /var/log/messages an.

Quellcode

1
less -n 5 /var/log/messages


Sollte hier eine Meldung auftauchen, wie z.B. :

Quellcode

1
Dec 22 21:52:00 ape kernel: [  867.203764] mmc0: new high speed SD card at address 1234


sieht das ganze schonmal gut aus ;) Eventuell findest du hier auch eine Fehlermeldung, oder im "worst-case"-Fall
garkeine Nachricht. Zusätzlich kannst du einmal sudo fdisk -l ausführen.

Quellcode

1
2
3
4
5
6
Disk /dev/mmcblk0: 1973 MB, 1973420032 bytes
4 heads, 16 sectors/track, 60224 cylinders
Units = cylinders of 64 * 512 = 32768 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Solltest du nicht sowas ähnliches lesen können, dann wird es kniffelig. Poste die Ausgaben bitte einmal hier.

Gruß

apensiv

Robi

User

  • »Robi« ist männlich
  • »Robi« ist der Autor dieses Themas

Beiträge: 222

Registrierungsdatum: 07.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

3

22.12.2010, 22:27

Hi, danke für die Hilfe
ich habe den less gemacht
- er meckert erst über die 5, dann zeigt er die datei
- 1 mal mit Karte drin, danach Karte raus, wieder rein und nochmal less. Keine Änderung der letzten Einträge

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
robert@robert-MI-Dell:~$ sudo fdisk -l

Platte /dev/sda: 320.1 GByte, 320072933376 Byte
255 Köpfe, 63 Sektoren/Spur, 38913 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0faa21d8

   Gerät  boot. 	Anfang    	Ende 	Blöcke   Id  System
/dev/sda1           	1       	5   	40131   de  Dell Utility
/dev/sda2   *       	6    	1232 	9848832	7  HPFS/NTFS
/dev/sda3        	1232   	20393   153911823+   7  HPFS/NTFS
/dev/sda4       	20393   	38914   148768769	5  Erweiterte
/dev/sda5       	20393   	38157   142687232   83  Linux
/dev/sda6       	38157   	38914 	6080512   82  Linux Swap / Solaris
robert@robert-MI-Dell:~$


Robi

DocHifi

unregistriert

4

22.12.2010, 22:34

Hi,
was sagt denn

Quellcode

1
lsusb
wird der Kartenleser überhaupt erkannt?
Gruß DH

Robi

User

  • »Robi« ist männlich
  • »Robi« ist der Autor dieses Themas

Beiträge: 222

Registrierungsdatum: 07.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

5

22.12.2010, 22:38

Hi DocHifi


robert@robert-MI-Dell:~$ lsusb
Bus 002 Device 004: ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor
Bus 002 Device 003: ID 413c:8187 Dell Computer Corp. DW375 Bluetooth Module
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 05ca:1814 Ricoh Co., Ltd HD Webcam
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
robert@robert-MI-Dell:~$

ich seh da keine sdcard oder ?

DocHifi

unregistriert

6

22.12.2010, 22:43

Hi,
ich seh da keine sdcard oder ?
ich auch nicht, gib noch mal die Ausgabe von

Quellcode

1
lspci
aber diesmal in Codetags.(Weiße Raute über Textfeld).
Gruß DH

7

22.12.2010, 22:45

Erstmal entschuldigung, meinte nicht less sondern tail ^^
Noch eine kleine Anmerkung, mein internes Kartenlesegerät ist nicht über USB sondern über PCI angeschlossen, deswegen poste nochmal die Ausgabe von:

Quellcode

1
lspci


Bei mir kommt (unter anderem) folgendes heraus:

Quellcode

1
03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)


Gruß

apensiv

Edit: Ah Vorposter war schneller ... *grml* 8o

Robi

User

  • »Robi« ist männlich
  • »Robi« ist der Autor dieses Themas

Beiträge: 222

Registrierungsdatum: 07.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

8

22.12.2010, 22:47

sorry, ok

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
robert@robert-MI-Dell:~$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 05)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
03:00.0 CardBus bridge: Ricoh Co Ltd Device e476 (rev 02)
03:00.1 SD Host controller: Ricoh Co Ltd Device e822 (rev 03)
03:00.4 FireWire (IEEE 1394): Ricoh Co Ltd Device e832 (rev 03)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
robert@robert-MI-Dell:~$


ist das der SD Host controller ?

DocHifi

unregistriert

9

22.12.2010, 22:48

@apensiv
Edit: Ah Vorposter war schneller ... *grml* 8o
Der Gedanke zählt. :D
Gruß DH

10

22.12.2010, 22:56

Hallo,

das Problem mit dem Host-Controller ist wohl bekannt, die Lösung dazu findest du hier:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/603445

Der Patch und die dazugehörige Anleitung findest du hier:
https://bugzilla.redhat.com/show_bug.cgi?id=596475

Falls du fragen hast, nur zu xD

Viel Erfolg

apensiv

Edit:

Kleines Update. Bin noch auf folgenden etwas besser passenden Bugbericht gestoßen:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/660088

Ich würde da am besten einmal die vorgeschlagenen Lösungsansätze probieren ;)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »apensiv« (22.12.2010, 23:04)


Robi

User

  • »Robi« ist männlich
  • »Robi« ist der Autor dieses Themas

Beiträge: 222

Registrierungsdatum: 07.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

11

22.12.2010, 23:13

Ok danke.
aber wenn ich ehrlich bin, reicht dazu wahrscheinlich weder mein englisch noch mein linux.

Zitat

das Problem mit dem Host-Controller ist wohl bekannt, die Lösung dazu findest du hier:
und

Zitat

Der Patch und die dazugehörige Anleitung findest du hier
Steht bei launchpad wirklich auch die Lösung oder "nur" der Weg der Fehlerfeststellung ?

Im 2. Link lese ich (auf die schnelle) Fedora und open Suse

na ja, werde es morgen mal in ruhe versuchen.
ggf melde ich mich nochmal

vielen Dank
Robert

12

22.12.2010, 23:24

Das ganze ist ein Problem, mit dem im Kernel integrierten Treiber und ist deswegen Distributions-Unabhhängig.
Mit uname -a findest du heraus was für ein Kernel bei dir läuft ;)

Viel Spaß bei der Frickelei

apensiv

PS: Vielleicht hilft auch ein einfaches Upgrade, da der Patch in neusten Kernel von Ubuntu 10.10 vielleicht schon integriert ist, wer weiß.
Ist auf jeden Fall ein Versuch wert.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »apensiv« (22.12.2010, 23:28)


Robi

User

  • »Robi« ist männlich
  • »Robi« ist der Autor dieses Themas

Beiträge: 222

Registrierungsdatum: 07.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

13

23.12.2010, 20:23

nach update heute, Kernel 2.6.35-24-generic und es geht nicht !!!

Also, ich lass das.

Das ist mir zu heiss.

(auch wenn das hier etwas unpopulär ist ... mein Win 7 auf dem selben Rechner kann das. Und es hat auch keine Probleme mit der Grafikkarte (was immer ich habe, bei Ubuntu geht es nur mit der bootoption -- xforcevesa nomodeset).
Und unter Win 7 kann ich mit der Dockingstation auch problemlos 2 Monitore OHNE Informatik Studium ansprechen. Irgendwie hat Win also auch Vorteile. Nicht falsch verstehen, ich bleibe bei Ubuntu.
Aber wenn es mich behindert statt mich zu unterstützen ist Win eine willkommene Hilfe. Von meinem Auto weiss ich auch nicht, wer der Hersteller der Vergasernadel ist (bzw ob ich einen habe) und es fährt trotzdem)

Danke an die unermüdlichen Helfer, die mir immer wieder (mehr oder weniger) gut helfen oder es zumindest versuchen.

Allen ein schönes Weihnachtswochenende und ein gutes Jahr 2011

lieben Gruß
Robi

14

24.12.2010, 01:35

Wenn das Problem damit gelöst bzw. erledigt ist, markiere bitte noch den Thread entsprechend:
Deinen ersten Beitrag "bearbeiten" -> "Präfix setzen". Danke!

PS: Bei der Gelegenheit wären auch noch ein paar andere Themen zu markieren...
mir is wurscht

Beiträge: 6

Registrierungsdatum: 01.01.2011

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

15

03.01.2011, 21:24

Hallo,
habe das gleiche Problem.
Mein Rechner :
Dell Latitude E6510 mit i5 Prozessor.
Habe bisher keine Ahnung von Ubuntu oder win 7 ( nur Xp)
Aber auch bei mir geht der Kartenlesen nur unter Win.

Aber ich glaube, das ich, wie der Eigentümer dieses Posts mich nicht traue etwas am Kernel zu probieren.
Gibt es zu den Thema allg. Infos. was man wie macht.
Mein englisch ist zwar brauchbar aber ob es für Computer reicht bezweifle ich im momment noch.

Allerdings kann ich nicht verstehen das Fredl eine nicht gelöstes Problem als erledigt betrachten möchte.
Davon ausgehend, das 'alles' irgendwie machbar ist ... aber egal. Will ja keinen Stress machen.

Gruß und bitte um weitere Informationen zum Kartenleser Problem,
Max

16

03.01.2011, 23:25

das Fredl eine nicht gelöstes Problem als erledigt betrachten möchte.
Da es nicht gelöst wurde, der Themenstarter es aber nach eigener Aussage nicht weiter verfolgen möchte, ist es nach den Gepflogenheiten dieses Forums als "erledigt" zu betrachten.
Weiteres dazu kann man in unseren diversen Einsteiger-Hilfen und den Regeln nachlesen. Deren Lektüre ist in vielerlei Hinsicht empfehlenswert.
mir is wurscht