Sie sind nicht angemeldet.

poker

User

  • »poker« ist männlich
  • »poker« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 27.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

1

16.10.2010, 12:05

Es konnte nicht ermittelt werden, welche Systemaktualisierungen verfügbar sind.

hi,

versuche mein System von 10.04 auf 10.10 hochzuspielen.

Leider taucht da eine Meldung auf:
Es konnte nicht ermittelt werden, welche Systemaktualisierungen verfügbar sind

An unresolvable problem occurred while calculating the upgrade:
E:Fehler: Unterbrechungen hervorgerufen durch pkgProblemResolver::Resolve; dies könnte durch gehaltene Pakete hervorgerufen worden sein.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

Falls nichts davon zutrifft, melden Sie dies bitte als Fehler im Paket »update-manager« und fügen Sie die Dateien aus dem Verzeichnis /var/log/dist-upgrade/ Ihrem Fehlerbericht hinzu.
--------------------

Nach dieser Meldung wird das Upgrade abgebrochen :-(

Bei Software-Packetquelle ->Andere Packetquellen habe ich alle Einträge entfernt. Es kommt trotzdem die Meldung.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »poker« (16.10.2010, 12:07)


  • »floogy« ist männlich

Beiträge: 3 071

Registrierungsdatum: 10.03.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: debian

  • Nachricht senden

2

16.10.2010, 12:31

Schaue bitte mal unter /var/log/dist-upgrade/ ob Du einen Hinweis auf die Ursache erhältst.

[gelöst] Upgrade 9.10 > 10.04 bricht ab

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »floogy« (16.10.2010, 12:39)


poker

User

  • »poker« ist männlich
  • »poker« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 27.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

3

16.10.2010, 16:55

das hier steht in der main.log:

#44-Ubuntu SMP Fri Sep 17 20:05:27 UTC 2010 x86_64'
2010-10-16 16:48:43,323 INFO creating state file with '['tar', '-z', '-c', '-f', '/var/log/dist-upgrade/system_state.tar.gz', '/etc/apt/preferences.d/', '/etc/apt/sources.list', '/etc/apt/sources.list.d/', '/var/lib/dpkg/status']'
2010-10-16 16:48:43,434 INFO release-upgrader version '0.142.20' started
2010-10-16 16:48:43,648 DEBUG svg pixbuf loader failed (Error displaying image)
2010-10-16 16:48:43,742 DEBUG Using 'DistUpgradeViewGtk' view
2010-10-16 16:48:43,782 DEBUG aufsOptionsAndEnvironmentSetup()
2010-10-16 16:48:43,783 DEBUG using '/tmp/upgrade-rw-KY8MUF' as aufs_rw_dir
2010-10-16 16:48:43,783 DEBUG using '/tmp/upgrade-chroot-bXmVos' as aufs chroot dir
2010-10-16 16:48:43,783 DEBUG enable dpkg --force-overwrite
2010-10-16 16:48:43,833 DEBUG lsb-release: 'lucid'
2010-10-16 16:48:43,838 DEBUG who -m --ips: ''
2010-10-16 16:48:43,838 DEBUG _pythonSymlinkCheck run
2010-10-16 16:48:43,839 DEBUG openCache()
2010-10-16 16:48:44,250 DEBUG /openCache(), new cache size 32174
2010-10-16 16:48:44,251 DEBUG needServerMode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
2010-10-16 16:48:44,251 DEBUG checkViewDepends()
2010-10-16 16:48:44,252 DEBUG running doUpdate() (showErrors=False)
2010-10-16 16:48:47,056 DEBUG openCache()
2010-10-16 16:48:47,379 DEBUG /openCache(), new cache size 32174
2010-10-16 16:48:47,380 DEBUG doPostInitialUpdate
2010-10-16 16:48:47,380 DEBUG Plugin modules in ./plugins: kdelibs4to5_plugin.py deb_plugin.py dpkg_status_plugin.py remove_lilo_plugin.py langpack_manual_plugin.py
2010-10-16 16:48:47,380 DEBUG Loading module ./plugins/kdelibs4to5_plugin.py
2010-10-16 16:48:47,382 DEBUG Plugins in <module 'kdelibs4to5_plugin' from './plugins/kdelibs4to5_plugin.py'>: <class 'kdelibs4to5_plugin.Kdelibs4devToKdelibs5devPlugin'>
2010-10-16 16:48:47,383 DEBUG Loading module ./plugins/deb_plugin.py
2010-10-16 16:48:47,384 DEBUG Plugins in <module 'deb_plugin' from './plugins/deb_plugin.py'>: <class 'deb_plugin.DebPlugin'>

  • »floogy« ist männlich

Beiträge: 3 071

Registrierungsdatum: 10.03.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: debian

  • Nachricht senden

4

16.10.2010, 17:00

Ist das alles?

Was gibt denn folgendes aus?

Quellcode

1
grep -C5 ERROR main.log

poker

User

  • »poker« ist männlich
  • »poker« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 27.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

5

16.10.2010, 17:04

2010-10-16 16:48:49,920 DEBUG running doUpdate() (showErrors=True)
2010-10-16 16:48:50,823 DEBUG openCache()
2010-10-16 16:48:50,823 DEBUG failed to SystemUnLock() (E:Nicht gesperrt)
2010-10-16 16:48:51,167 DEBUG /openCache(), new cache size 32174
2010-10-16 16:48:51,167 DEBUG needServerMode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
2010-10-16 16:50:35,895 ERROR Dist-upgrade failed: 'E:Fehler: Unterbrechungen hervorgerufen durch pkgProblemResolver::Resolve; dies könnte durch gehaltene Pakete hervorgerufen worden sein.'
2010-10-16 16:50:35,990 DEBUG abort called
2010-10-16 16:50:35,993 DEBUG openCache()
2010-10-16 16:50:35,993 DEBUG failed to SystemUnLock() (E:Nicht gesperrt)
2010-10-16 16:50:36,407 DEBUG /openCache(), new cache size 32174
2010-10-16 16:50:36,408 DEBUG enabling apt cron job

das erhalte ich nach der eingabe

  • »floogy« ist männlich

Beiträge: 3 071

Registrierungsdatum: 10.03.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: debian

  • Nachricht senden

6

16.10.2010, 17:27

Wie hast Du do-release-upgrade ausgeführt? Was sagt lsb-release -a?

poker

User

  • »poker« ist männlich
  • »poker« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 27.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

7

16.10.2010, 17:46

das spuckt er mir raus:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.1 LTS
Release: 10.04
Codename: lucid

  • »floogy« ist männlich

Beiträge: 3 071

Registrierungsdatum: 10.03.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: debian

  • Nachricht senden

8

16.10.2010, 17:56

Und wie führst Du das do-release-upgrade aus, mit welchen Optionen?

Hast Du auch mal nach gehaltenen Paketen gesucht?

Quellcode

1
2
3
 aptitude search "?false"
aptitude search "~ahold" | grep "^.h"
dpkg --get-selections | grep hold

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »floogy« (16.10.2010, 17:57)


poker

User

  • »poker« ist männlich
  • »poker« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 27.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

9

16.10.2010, 18:01

wie ich upgrade ausgeführt habe -> system-systmeinstellungen->Aktualisierungsverwaltung

nach gehaltenen Packeten gesucht???

also habe den code

aptitude search "?false"
aptitude search "~ahold" | grep "^.h"
dpkg --get-selections | grep hold

ausgeführt. es kam nichts zurück

  • »floogy« ist männlich

Beiträge: 3 071

Registrierungsdatum: 10.03.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: debian

  • Nachricht senden

10

16.10.2010, 18:10

Jetzt kann ich nur weiter raten:

Quellcode

1
sudo apt-get remove ubuntu-desktop


Das ist ein metapaket, das Du danach ja wieder installieren kannst.

poker

User

  • »poker« ist männlich
  • »poker« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 27.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

11

16.10.2010, 18:21

habe den code ausgeführt.

wenn ich nun wieder unter System-systemsteuereung-aktulisieren gehe und dann auf 10.10 upgraden möchten, taucht ein neues fester auf und schliesst sich wieder.

eine meldung erhalte ich nicht mehr

  • »floogy« ist männlich

Beiträge: 3 071

Registrierungsdatum: 10.03.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: debian

  • Nachricht senden

12

16.10.2010, 18:46

Versuch es bitte mal wie hier beschrieben:
https://help.ubuntu.com/community/MaverickUpgrades

poker

User

  • »poker« ist männlich
  • »poker« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 27.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

13

16.10.2010, 19:18

vielleicht kann das dir weiter helfen:

laptop:~$ update-manager
extracting 'maverick.tar.gz'
authenticate 'maverick.tar.gz' against 'maverick.tar.gz.gpg'
WARNING: Failed to read mirror file
File "/tmp/tmpluYD0m/maverick", line 7, in <module>
sys.exit(main())
File "/tmp/tmpluYD0m/DistUpgradeMain.py", line 158, in main
if app.run():
File "/tmp/tmpluYD0m/DistUpgradeController.py", line 1616, in run
return self.fullUpgrade()
File "/tmp/tmpluYD0m/DistUpgradeController.py", line 1534, in fullUpgrade
if not self.updateSourcesList():
File "/tmp/tmpluYD0m/DistUpgradeController.py", line 664, in updateSourcesList
if not self.rewriteSourcesList(mirror_check=True):
File "/tmp/tmpluYD0m/DistUpgradeController.py", line 486, in rewriteSourcesList
distro.get_sources(self.sources)
File "/tmp/tmpluYD0m/distro.py", line 103, in get_sources
source.template.official == True and
AttributeError: 'Template' object has no attribute 'official'

noch was:

laptop:~$ sudo do-release-upgrade
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
extracting 'maverick.tar.gz'
authenticate 'maverick.tar.gz' against 'maverick.tar.gz.gpg'
tar: Entferne führende „/“ von Elementnamen

Zwischenspeicher wird gelesen

Paketverwaltung wird überprüft
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Informationen zu Paketquellen werden aktualisiert
WARNING: Failed to read mirror file


Ein schwerwiegender Fehler ist aufgetreten

Bitte erstellen Sie einen Fehlerbericht und fügen Sie die Dateien
/var/log/dist-upgrade/main.log und /var/log/dist-upgrade/apt.log
hinzu. Die Systemaktualisierung wurde abgebrochen.
Ihre ursprüngliche sources.list wurde in
/etc/apt/sources.list.distUpgrade gesichert.

Traceback (most recent call last):

File "/tmp/tmpXf76bn/maverick", line 7, in <module>
sys.exit(main())

File "/tmp/tmpXf76bn/DistUpgradeMain.py", line 158, in main
if app.run():

File "/tmp/tmpXf76bn/DistUpgradeController.py", line 1616, in run
return self.fullUpgrade()

File "/tmp/tmpXf76bn/DistUpgradeController.py", line 1534, in
fullUpgrade
if not self.updateSourcesList():

File "/tmp/tmpXf76bn/DistUpgradeController.py", line 664, in
updateSourcesList
if not self.rewriteSourcesList(mirror_check=True):

File "/tmp/tmpXf76bn/DistUpgradeController.py", line 486, in
rewriteSourcesList
distro.get_sources(self.sources)

File "/tmp/tmpXf76bn/distro.py", line 103, in get_sources
source.template.official == True and

AttributeError: 'Template' object has no attribute 'official'
------------

an firefox 4 kann es nicht liegen oder??

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »poker« (16.10.2010, 19:32)


  • »floogy« ist männlich

Beiträge: 3 071

Registrierungsdatum: 10.03.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: debian

  • Nachricht senden

14

16.10.2010, 19:42

Ich bin da etwas überfragt. Aber wenigstens sieht man nun die Fehler. Weshalb er das mirrorfile nicht laden kann weiß ich nicht. Hast Du das System denn vorher auf den neuesten Stand gebracht?

Quellcode

1
2
sudo apt-get update
sudo apt-get dist-upgrade


http://www.google.com/search?q=WARNING%3…+file"+maverick

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »floogy« (16.10.2010, 20:08)


poker

User

  • »poker« ist männlich
  • »poker« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 27.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

15

16.10.2010, 20:08

ja ist auf den neusten stand.

  • »floogy« ist männlich

Beiträge: 3 071

Registrierungsdatum: 10.03.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: debian

  • Nachricht senden

16

16.10.2010, 20:11

Versuche mal das hier:

Quellcode

1
2
sudo apt-get install apt-show-versions
apt-show-versions|egrep "No\ available"

poker

User

  • »poker« ist männlich
  • »poker« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 27.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

17

16.10.2010, 22:23

das ergebniss:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
adium-theme-ubuntu 0.1-0ubuntu1 installed: No available version in archive
adobeair 2.0.3.13070 installed: No available version in archive
aisleriot 1:2.30.0-0ubuntu6 installed: No available version in archive
apport-symptoms 0.9 installed: No available version in archive
apturl-common 0.4.1ubuntu4 installed: No available version in archive
awn-settings 0.4.0-0ubuntu1 installed: No available version in archive
bcmwl-kernel-source 5.60.48.36+bdcom-0ubuntu3 installed: No available version in archive
bcmwl-modaliases 5.60.48.36+bdcom-0ubuntu3 installed: No available version in archive
branding-ubuntu 0.4-0ubuntu1 installed: No available version in archive
brasero-common 2.30.2-0ubuntu1 installed: No available version in archive
byobu 2.68-0ubuntu1.1 installed: No available version in archive
clipgrab 3.0.7.2-0lucid1~patched1 installed: No available version in archive
cnijfilter-common 3.20-1 installed: No available version in archive
cnijfilter-mp270series 3.20-1 installed: No available version in archive
com.babbel.babbelrefresh.3741a3fce1d3eb805f84223a94de5a5cfdaa610d.1 0.6.17176 installed: No available version in archive
couchdb-bin 0.10.0-1ubuntu2 installed: No available version in archive
cpp-4.4 4.4.3-4ubuntu5 installed: No available version in archive
cpu-checker 0.1-0ubuntu2 installed: No available version in archive
desktopcouch 0.6.4-0ubuntu3.1 installed: No available version in archive
diffutils 1:2.8.1-18 installed: No available version in archive
elementary-theme 1.2.1~ppa106~10.04 installed: No available version in archive
empathy-common 2.30.3-0ubuntu1 installed: No available version in archive
erlang-crypto 1:13.b.3-dfsg-2ubuntu2.1 installed: No available version in archive
erlang-inets 1:13.b.3-dfsg-2ubuntu2.1 installed: No available version in archive
erlang-mnesia 1:13.b.3-dfsg-2ubuntu2.1 installed: No available version in archive
erlang-public-key 1:13.b.3-dfsg-2ubuntu2.1 installed: No available version in archive
erlang-runtime-tools 1:13.b.3-dfsg-2ubuntu2.1 installed: No available version in archive
erlang-ssl 1:13.b.3-dfsg-2ubuntu2.1 installed: No available version in archive
erlang-syntax-tools 1:13.b.3-dfsg-2ubuntu2.1 installed: No available version in archive
erlang-xmerl 1:13.b.3-dfsg-2ubuntu2.1 installed: No available version in archive
fancontrol 1:3.1.2-2 installed: No available version in archive
firefox-4.0 4.0~b8~hg20101016r55929+nobinonly-0ubuntu1~umd1~lucid installed: No available version in archive
firefox-4.0-core 4.0~b8~hg20101016r55929+nobinonly-0ubuntu1~umd1~lucid installed: No available version in archive
gcc-4.4 4.4.3-4ubuntu5 installed: No available version in archive
gcc-4.4-base 4.4.3-4ubuntu5 installed: No available version in archive
gconf-defaults-service 2.28.1-0ubuntu1 installed: No available version in archive
geoip-database 1.4.6.dfsg-17 installed: No available version in archive
ghostscript-cups 8.71.dfsg.1-0ubuntu5.3 installed: No available version in archive
gnome-disk-utility 2.30.1-1 installed: No available version in archive
gnome-games-common 1:2.30.0-0ubuntu6 installed: No available version in archive
gnome-mahjongg 1:2.30.0-0ubuntu6 installed: No available version in archive
gnome-session-bin 2.30.0-0ubuntu1 installed: No available version in archive
gnome-sudoku 1:2.30.0-0ubuntu6 installed: No available version in archive
gnomine 1:2.30.0-0ubuntu6 installed: No available version in archive
gnupg-curl 1.4.10-2ubuntu1 installed: No available version in archive
gtk2-engines-aurora 1.5.1-1 installed: No available version in archive
gtk2-engines-equinox 1.20 installed: No available version in archive
gwibber-service 2.33.0~bzr875-0ubuntu1~daily1~lucid installed: No available version in archive
humanity-icon-theme 0.5.2.1 installed: No available version in archive
hunspell-en-ca 1:3.2.0-3ubuntu3.1 installed: No available version in archive
indicator-applet-session 0.3.7-0ubuntu1 installed: No available version in archive
indicator-application 0.0.19-0ubuntu4 installed: No available version in archive
indicator-me 0.2.6-0ubuntu1 installed: No available version in archive
indicator-session 0.2.8-0ubuntu2 installed: No available version in archive
indicator-sound 0.2.5-0ubuntu1 installed: No available version in archive
initramfs-tools-bin 0.92bubuntu78 installed: No available version in archive
install-info 4.13a.dfsg.1-5ubuntu1 installed: No available version in archive
intel-gpu-tools 1.0.2+git20100830+c935c60-0ubuntu0sarvatt~lucid installed: No available version in archive
kdepim-runtime 4:4.4.2-0ubuntu1 installed: No available version in archive
kerneloops-daemon 0.12+git20090217-1ubuntu7 installed: No available version in archive
kubuntu-debug-installer 10.04ubuntu4 installed: No available version in archive
libappindicator0 0.0.19-0ubuntu4 installed: No available version in archive
libart2.0-cil 2.24.1-6ubuntu1 installed: No available version in archive
libass4 0.9.9-0ubuntu1 installed: No available version in archive
libatasmart4 0.17+git20100219-1git2 installed: No available version in archive
libattica0 0.1.3-0ubuntu1 installed: No available version in archive
libavahi-core6 0.6.25-1ubuntu6.1 installed: No available version in archive
libavcodec-extra-52 4:0.5.1-1ubuntu1 installed: No available version in archive
libavutil-extra-49 4:0.5.1-1ubuntu1 installed: No available version in archive
libawn1 0.4.0-0ubuntu1 installed: No available version in archive
libbind9-60 1:9.7.0.dfsg.P1-1 installed: No available version in archive
libboost-program-options1.40.0 1.40.0-4ubuntu4 installed: No available version in archive
libc-bin 2.11.1-0ubuntu7.4 installed: No available version in archive
libc-dev-bin 2.11.1-0ubuntu7.4 installed: No available version in archive
libcanberra-pulse 0.22-1ubuntu2 installed: No available version in archive
libcap-ng0 0.6.2-4 installed: No available version in archive
libcdio10 0.81-4 installed: No available version in archive
libcelt0-0 0.7.1-1 installed: No available version in archive
libclutter-1.0-0 1.2.4-0ubuntu1 installed: No available version in archive
libclutter-gtk-0.10-0 0.10.4-0ubuntu1 installed: No available version in archive
libcolamd2.7.1 1:3.4.0-1ubuntu3 installed: No available version in archive
libcouchdb-glib-1.0-2 0.6.3-0ubuntu2 installed: No available version in archive
libcupscgi1 1.4.3-1ubuntu1.2 installed: No available version in archive
libcupsdriver1 1.4.3-1ubuntu1.2 installed: No available version in archive
libcupsmime1 1.4.3-1ubuntu1.2 installed: No available version in archive
libcupsppdc1 1.4.3-1ubuntu1.2 installed: No available version in archive
libdatrie1 0.2.2-3 installed: No available version in archive
libdb4.8 4.8.24-1ubuntu1 installed: No available version in archive
libdbusmenu-glib1 0.2.9-0ubuntu3.1 installed: No available version in archive
libdbusmenu-gtk1 0.2.9-0ubuntu3.1 installed: No available version in archive
libdbusmenu-qt2 0.3.2-0ubuntu1 installed: No available version in archive
libdesktop-agnostic-cfg-gconf 0.3.90-0ubuntu1 installed: No available version in archive
libdesktop-agnostic-fdo-glib 0.3.90-0ubuntu1 installed: No available version in archive
libdesktop-agnostic-vfs-gio 0.3.90-0ubuntu1 installed: No available version in archive
libdesktop-agnostic0 0.3.90-0ubuntu1 installed: No available version in archive
libdesktopcouch-glib-1.0-2 0.6.3-0ubuntu2 installed: No available version in archive
libdevkit-power-gobject1 1:0.9.1-1 installed: No available version in archive
libdirac-encoder0 1.0.2-2 installed: No available version in archive
libdirectfb-1.2-0 1.2.8-5ubuntu2 installed: No available version in archive
libdns64 1:9.7.0.dfsg.P1-1 installed: No available version in archive
libdrm-radeon1 2.4.18-1ubuntu3 installed: No available version in archive
libeggdbus-1-0 0.6-1 installed: No available version in archive
libevdocument2 2.30.3-0ubuntu1.1 installed: No available version in archive
libevent-1.4-2 1.4.13-stable-1 installed: No available version in archive
libevview2 2.30.3-0ubuntu1.1 installed: No available version in archive
libexiv2-6 0.19-1 installed: No available version in archive
libfaad2 2.7-4 installed: No available version in archive
libflickrnet2.2-cil 1:2.2.0-3 installed: No available version in archive
libgconf2.0-cil 2.24.1-6ubuntu1 installed: No available version in archive
libgdata-common 0.5.2-0ubuntu1 installed: No available version in archive
libgdata6 0.5.2-0ubuntu1 installed: No available version in archive
libgdu-gtk0 2.30.1-1 installed: No available version in archive
libgdu0 2.30.1-1 installed: No available version in archive
libgme0 0.5.5-1 installed: No available version in archive
libgmime-2.4-2 2.4.14-1+nmu1 installed: No available version in archive
libgmime2.4-cil 2.4.14-1+nmu1 installed: No available version in archive
libgnome-bluetooth7 2.30.0-0ubuntu3 installed: No available version in archive
libgnome-desktop-2-17 1:2.30.2-0ubuntu1 installed: No available version in archive
libgnome-vfs2.0-cil 2.24.1-6ubuntu1 installed: No available version in archive
libgnomekbd4 2.30.2-0ubuntu0.1 installed: No available version in archive
libgssapi-krb5-2 1.8.1+dfsg-2ubuntu0.3 installed: No available version in archive
libgssdp-1.0-2 0.7.1-1 installed: No available version in archive
libgudev-1.0-0 1:151-12.1 installed: No available version in archive
libgupnp-1.0-3 0.13.2-1ubuntu1 installed: No available version in archive
libgupnp-igd-1.0-2 0.1.3-4ubuntu1 installed: No available version in archive
libhpmud0 3.10.2-2ubuntu2.1 installed: No available version in archive
libibus1 1.2.0.20091215-1ubuntu4 installed: No available version in archive
libicu42 4.2.1-3 installed: No available version in archive
libido-0.1-0 0.1.6-0ubuntu1 installed: No available version in archive
libimobiledevice0 0.9.7-1ubuntu1 installed: No available version in archive
libindicate-gtk2 0.3.6-0ubuntu1 installed: No available version in archive
libindicate-qt0 0.2.5-0ubuntu1 installed: No available version in archive
libindicate4 0.3.6-0ubuntu1 installed: No available version in archive
libindicator0 0.3.8-0ubuntu1 installed: No available version in archive
libisc60 1:9.7.0.dfsg.P1-1 installed: No available version in archive
libisccc60 1:9.7.0.dfsg.P1-1 installed: No available version in archive
libisccfg60 1:9.7.0.dfsg.P1-1 installed: No available version in archive
libiw30 30~pre9-3ubuntu4 installed: No available version in archive
libk5crypto3 1.8.1+dfsg-2ubuntu0.3 installed: No available version in archive
libkate1 0.3.7-3 installed: No available version in archive
libkpathsea5 2009-5ubuntu0.2 installed: No available version in archive
libkrb5-3 1.8.1+dfsg-2ubuntu0.3 installed: No available version in archive
libkrb5support0 1.8.1+dfsg-2ubuntu0.3 installed: No available version in archive
liblaunchpad-integration1.0-cil 0.1.35 installed: No available version in archive
liblouis-data 1.7.0-2 installed: No available version in archive
liblouis0 1.7.0-2 installed: No available version in archive
liblwres60 1:9.7.0.dfsg.P1-1 installed: No available version in archive
liblzma1 4.999.9beta+20091116-1 installed: No available version in archive
libmagickcore2 7:6.5.7.8-1ubuntu1 installed: No available version in archive
libmagickcore2-extra 7:6.5.7.8-1ubuntu1 installed: No available version in archive
libmagickwand2 7:6.5.7.8-1ubuntu1 installed: No available version in archive
libmetacity-private0 1:2.30.1-0ubuntu1 installed: No available version in archive
libmimic0 1.0.4-2build1 installed: No available version in archive
libmono-i18n-west2.0-cil 2.4.4~svn151842-1ubuntu4 installed: No available version in archive
libnih-dbus1 1.0.1-1 installed: No available version in archive
libnih1 1.0.1-1 installed: No available version in archive
libnm-glib2 0.8-0ubuntu3 installed: No available version in archive
libntfs-3g75 1:2010.3.6-1ubuntu1 installed: No available version in archive
liborc-0.4-0 0.4.3-5 installed: No available version in archive
libpackagekit-glib11 0.3.14-0ubuntu4 installed: No available version in archive
libpango-perl 1.221-2 installed: No available version in archive
libparted0debian1 2.2-5ubuntu5.1 installed: No available version in archive
libplist1 1.1-1ubuntu1 installed: No available version in archive
libplymouth2 0.8.2-2ubuntu2 installed: No available version in archive
libpolkit-agent-1-0 0.96-2 installed: No available version in archive
libpolkit-backend-1-0 0.96-2 installed: No available version in archive
libpolkit-gobject-1-0 0.96-2 installed: No available version in archive
libpolkit-gtk-1-0 0.96-2ubuntu2 installed: No available version in archive
libpolkit-qt-1-0 0.95.1-1fakesync1 installed: No available version in archive
libpoppler5 0.12.4-0ubuntu5 installed: No available version in archive
libprotobuf5 2.2.0a-0.1ubuntu1 installed: No available version in archive
libprotoc5 2.2.0a-0.1ubuntu1 installed: No available version in archive
libpst4 0.6.41-0ubuntu4 installed: No available version in archive
librasqal2 0.9.17-1 installed: No available version in archive
libraw1394-11 2.0.4-1ubuntu2 installed: No available version in archive
libreadline6 6.1-1 installed: No available version in archive
libsgutils2-2 1.28-2 installed: No available version in archive
libsilcclient-1.1-3 1.1.10-2build1 installed: No available version in archive
libssh-4 0.4.2-1ubuntu1 installed: No available version in archive
libtag1-vanilla 1.6.3-0ubuntu1 installed: No available version in archive
libtalloc2 2.0.1-1 installed: No available version in archive
libtotem-plparser17 2.30.0git201000413-0ubuntu1 installed: No available version in archive
libubuntuone-1.0-1 0.3.1-0ubuntu1 installed: No available version in archive
libupower-glib1 0.9.1-1 installed: No available version in archive
libusbmuxd1 1.0.2-1ubuntu2 installed: No available version in archive
libwebkit-1.0-2 1.2.5-0ubuntu0.10.04.1 installed: No available version in archive
libwebkit-1.0-common 1.2.5-0ubuntu0.10.04.1 installed: No available version in archive
libx264-85 2:0.85.1448+git1a6d32-4 installed: No available version in archive
libxcb-atom1 0.3.6-1build1 installed: No available version in archive
libxcb-dri2-0 1.5-2 installed: No available version in archive
libxcb-event1 0.3.6-1build1 installed: No available version in archive
libxklavier16 5.0-0ubuntu1 installed: No available version in archive
libzephyr4 3.0-1 installed: No available version in archive
light-themes 0.1.6.6 installed: No available version in archive
linux-headers-2.6.32-24 2.6.32-24.43 installed: No available version in archive
linux-headers-2.6.32-24-generic 2.6.32-24.43 installed: No available version in archive
linux-headers-2.6.32-25 2.6.32-25.44 installed: No available version in archive
linux-headers-2.6.32-25-generic 2.6.32-25.44 installed: No available version in archive
linux-image-2.6.32-24-generic 2.6.32-24.43 installed: No available version in archive
linux-image-2.6.32-25-generic 2.6.32-25.44 installed: No available version in archive
media-player-info 6-1 installed: No available version in archive
modemmanager 0.3-0ubuntu2 installed: No available version in archive
mountall 2.15.3 installed: No available version in archive
mysql-client-core-5.1 5.1.41-3ubuntu12.6 installed: No available version in archive
mysql-server-core-5.1 5.1.41-3ubuntu12.6 installed: No available version in archive
nautilus-sendto-empathy 2.30.3-0ubuntu1 installed: No available version in archive
network-manager-pptp-gnome 0.8-0ubuntu3 installed: No available version in archive
notify-osd-icons 0.6 installed: No available version in archive
nvidia-current 260.19.12-0ubuntu1~xup1~lucid installed: No available version in archive
nvidia-current-modaliases 260.19.12-0ubuntu1~xup1~lucid installed: No available version in archive
obexd-client 0.22-0ubuntu2 installed: No available version in archive
oxygen-icon-theme 4:4.4.2-0ubuntu2 installed: No available version in archive
packagekit 0.3.14-0ubuntu4 installed: No available version in archive
plasma-scriptengine-javascript 4:4.4.2-0ubuntu4.1 installed: No available version in archive
plymouth 0.8.2-2ubuntu2 installed: No available version in archive
plymouth-label 0.8.2-2ubuntu2 installed: No available version in archive
plymouth-theme-ubuntu-logo 0.8.2-2ubuntu2 installed: No available version in archive
plymouth-theme-ubuntu-text 0.8.2-2ubuntu2 installed: No available version in archive
plymouth-x11 0.8.2-2ubuntu2 installed: No available version in archive
pm-utils-powersave-policy 0.3.1 installed: No available version in archive
policykit-1 0.96-2 installed: No available version in archive
policykit-1-gnome 0.96-2ubuntu2 installed: No available version in archive
policykit-desktop-privileges 0.1 installed: No available version in archive
pulseaudio-module-bluetooth 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14 installed: No available version in archive
python-appindicator 0.0.19-0ubuntu4 installed: No available version in archive
python-bugbuddy 2.30.0-0ubuntu1 installed: No available version in archive
python-configglue 0.2dev-0ubuntu2 installed: No available version in archive
python-desktop-agnostic 0.3.90-0ubuntu1 installed: No available version in archive
python-desktopcouch 0.6.4-0ubuntu3.1 installed: No available version in archive
python-desktopcouch-records 0.6.4-0ubuntu3.1 installed: No available version in archive
python-evince 2.30.0-0ubuntu1 installed: No available version in archive
python-evolution 2.30.0-0ubuntu1 installed: No available version in archive
python-gnomeapplet 2.30.0-0ubuntu1 installed: No available version in archive
python-gnomedesktop 2.30.0-0ubuntu1 installed: No available version in archive
python-gnomekeyring 2.30.0-0ubuntu1 installed: No available version in archive
python-gnomeprint 2.30.0-0ubuntu1 installed: No available version in archive
python-gtkmozembed 2.25.3-4.1ubuntu4 installed: No available version in archive
python-gtkspell 2.25.3-4.1ubuntu4 installed: No available version in archive
python-gtop 2.30.0-0ubuntu1 installed: No available version in archive
python-gweather 2.30.0-0ubuntu1 installed: No available version in archive
python-lazr.restfulclient 0.9.11-1ubuntu1.1 installed: No available version in archive
python-lazr.uri 1.0.2-1 installed: No available version in archive
python-louis 1.7.0-2 installed: No available version in archive
python-mediaprofiles 2.30.0-0ubuntu1 installed: No available version in archive
python-metacity 2.30.0-0ubuntu1 installed: No available version in archive
python-oauth 1.0a~svn1124-0ubuntu2 installed: No available version in archive
python-papyon 0.4.8-0ubuntu1 installed: No available version in archive
python-rsvg 2.30.0-0ubuntu1 installed: No available version in archive
python-sip 4.10.1-0ubuntu1 installed: No available version in archive
python-totem-plparser 2.30.0-0ubuntu1 installed: No available version in archive
python-ubuntuone 0.3.1-0ubuntu1 installed: No available version in archive
python-ubuntuone-client 1.2.2-0ubuntu2 installed: No available version in archive
python-ubuntuone-storageprotocol 1.2.0-0ubuntu1 installed: No available version in archive
python-wnck 2.30.0-0ubuntu1 installed: No available version in archive
python-zope.interface 3.5.3-1ubuntu2 installed: No available version in archive
quadrapassel 1:2.30.0-0ubuntu6 installed: No available version in archive
rhythmbox-plugin-cdrecorder 0.12.8-0ubuntu7 installed: No available version in archive
rhythmbox-plugins 0.12.8-0ubuntu7 installed: No available version in archive
rtkit 0.6-0ubuntu1 installed: No available version in archive
samba-common-bin 2:3.4.7~dfsg-1ubuntu3.2 installed: No available version in archive
sensible-utils 0.0.1ubuntu3 installed: No available version in archive
shared-desktop-ontologies 0.3-1 installed: No available version in archive
simple-scan 1.0.3-0ubuntu1 installed: No available version in archive
system-config-printer-udev 1.2.0+20100408-0ubuntu5.2 installed: No available version in archive
telepathy-mission-control-5 5.3.2-3 installed: No available version in archive
tsconf 1.0-7build1 installed: No available version in archive
ttf-kacst-one 3.0-1ubuntu2 installed: No available version in archive
ttf-khmeros-core 5.0-3ubuntu1 installed: No available version in archive
ttf-symbol-replacement-wine1.3 1.3.4-0ubuntu1~lucidppa1 installed: No available version in archive
ttf-takao-pgothic 003.02.01-2ubuntu1 installed: No available version in archive
ttf-wqy-microhei 0.2.0-beta-1 installed: No available version in archive
turboprint 2.16-2 installed: No available version in archive
ubuntu-mono 0.0.18 installed: No available version in archive
ubuntuone-client 1.2.2-0ubuntu2 installed: No available version in archive
ubuntuone-client-gnome 1.2.2-0ubuntu2 installed: No available version in archive
udisks 1.0.1-1ubuntu1 installed: No available version in archive
upower 0.9.1-1 installed: No available version in archive
ureadahead 0.100.0-4.1.3 installed: No available version in archive
usb-creator-common 0.2.22.1 installed: No available version in archive
usb-creator-gtk 0.2.22.1 installed: No available version in archive
usbmuxd 1.0.2-1ubuntu2 installed: No available version in archive
virtuoso-nepomuk 6.1.0-0ubuntu3 installed: No available version in archive
wine1.3 1.3.4-0ubuntu1~lucidppa1 installed: No available version in archive
wine1.3-gecko 1.1.0-0ubuntu1~lucidppa1 installed: No available version in archive
winetricks 0.0+20100917-0ubuntu1~lucidppa1 installed: No available version in archive
wisotool 0.0+20100731 installed: No available version in archive
xorg-docs-core 1:1.5-1 installed: No available version in archive

  • »floogy« ist männlich

Beiträge: 3 071

Registrierungsdatum: 10.03.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: GNOME 3.0

Andere Betriebssysteme: debian

  • Nachricht senden

18

17.10.2010, 12:09

Vielleicht hilft es etwas diese Pakete vorher zu entfernen. Diese Pakete stammen aus den entfernten Fremdquellen.

Quellcode

1
2
apt-show-versions|egrep "No\ available"|awk '{print $1}'|sed ':;s/\n/ /;N;T'  > fremdquelle_pkg_lst.txt
apt-get remove $(cat fremdquelle_pkg_lst.txt)


Später kannst Du dann die Pakete aus der Datei fremdquelle_pkg_lst.txt wieder installieren. Einige Pakete, die sich so nicht installieren lassen kannst Du versuchen zu installieren, nachdem Du passende Fremdquellen für maverick freigeschaltet hast.

EDIT: Ich sehe gerade, dass Du auch Pakete wie libc-bin aus unbekannter Herkunft hast. Besser wäre die alten Fremdquellen wieder freizuschalten und mit apt-show-versions diese nochmals zu filtern und dann auf die lucid Standardquellen downzugraden. Die die nicht downzugraden sind kann man dann immer noch entfernen.
Ich hatte dazu mal ein Skript gesehen, kann es aber nicht mehr finden.

Hier ein Link zum Downgraden: http://hydra.geht.net/tino/english/faq/debian/apt/downgrade/

Du könntest auch mit dpkg --apt-get-selection und --apt-set-selection arbeiten um die selben Pakete in einer Neuinstallation einzubringen. Dann müssen auch /home /etc und mache Dinge aus /var/lib, /usr/local usw. für die Neuinstallation gesichert werden.

Vielleicht finde ich das Skript ja noch...

http://wiki.ubuntuusers.de/Fremdquellen#…sion-verhindern

EDIT: Du hast Glück. Ich habe das Skript gefunden.

Zitat

Name: ppa-purge

Description:

Disables a PPA and reverts to official packages
This package provides a script capable of automatically downgrading all
packages from a given PPA back to the official Ubuntu versions.

Invoke it with ppa-purge -h for complete details.

http://bigbrovar.aoizora.org/index.php/2…ry-from-ubuntu/
https://launchpad.net/ppa-purge
http://www.ubuntuupdates.org/packages/show/199854
https://bugs.launchpad.net/ppa-purge/+bug/572512
http://www.youtube.com/watch?v=my0kqbro6og&feature=related

Falls Du die backports aktiviert hast, ist es sogar per apt-get oder synaptic zu installieren.

Quellcode

1
2
3
4
5
6
7
$ apt-cache policy ppa-purge
ppa-purge:
  Installiert: (keine)
  Kandidat: 0+bzr46.1~lucid1
  Versions-Tabelle:
     0+bzr46.1~lucid1 0
        500 http://de.archive.ubuntu.com/ubuntu/ lucid-backports/universe Packages


So weit ich weiß benötigt auch ppa-purge die Fremdquellenangaben in der sources.list um die Pakete auf die normalen versionen downzugraden.

Dieser Beitrag wurde bereits 7 mal editiert, zuletzt von »floogy« (17.10.2010, 13:20)