Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

ds2k5

User

  • »ds2k5« ist der Autor dieses Themas

Beiträge: 55

Registrierungsdatum: 05.03.2008

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

11.10.2010, 14:43

nTop 4.0.3 initscript - erstellt kein PID file mit dem namen den ich haben moechte!

Hallo,
ich nutze ein selbst kompilierte Version von nTop auf Ubuntu Server 10.04 (64bit).
Da ich mehrer nTop Processe laufen lassen will habe ich einfach symbolische Links auf die /usr/local/bin/ntop gemacht.
Nun moechte ich fuer jeden dieser symbolik Links ein eigenes init-script haben.
(So das ich z.B. fuer jede Niederlassung einen eigenen NTOP Process habe der entsprechende Netzwerkparameter hat)
Leider erhalte ich aber immer nur das PID-File: /var/run/ntop.pid und nicht /var/run/ntop_nl1.pid


PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin
. /lib/lsb/init-functions


DAEMON=/usr/local/bin/ntop_nl1
PIDFILE=/var/run/ntop_nl1.pid
CONFIG=/etc/ntop/ntop_nl1.conf
PROTOCOLFILE=/etc/ntop/protocol.list

...
...

start-stop-daemon --start -m --quiet --pidfile $PIDFILE --exec $DAEMON @$CONFIG -p $PROTOCOLFILE


Was mach ich denn da falsch ?

Danke
Gruss