Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »j.w.v.goethe« ist der Autor dieses Themas

Beiträge: 33

Registrierungsdatum: 17.01.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

1

01.08.2010, 14:49

Monkey Island 4 in Wine und VirtualBox Xp

Hallo allerseits.

Ich habe mir kürzlich MI 4 gekauft und versuche es seit gestern unter Ubuntu 10.04 32bit zum laufen zu bekommen. Zunächt habe ich es mi WINE versucht. Die Installation scheiterte zunächst am CD-Wechsel, da CD2, nachdem sie eingelegt wurde, nicht erkannt wurde. Ich habe dann kurzerhand einfach ihren Inhalt ins Zielverzeichnis kopiert.
Die Monkey.exe, also das Setup-Programm, was unter Win beim Einlegen der CD erscheint, ließ sich nicht öffnen, wohl aber die Monkey4.exe, also das Spiel direkt. Sound funktioniert auch, nur Guybrushs Gesicht ist blau, was etwas stört. Im Netz las ich, dass man, um das zu verhindern, von DirectX zu OpenGL umstellen soll im Setup-Menü. Da komme ich aber leider nicht hin, da ich ja die Monkey.exe nicht öffnen kann.

Mein zweiter Versuch war die Installation von Win XP in VirtualBox. Ich hab dem Gastsystem 1 GB Ram, 64 MB Grafik und 1 Prozessorkern (AMD 64 x2) zugeteilt. Unter XP habe ich Vollinstallation des Spieles gemacht, klappte auch. Nur beim Versuch des Startens kommt "Hardware konnte nicht initialisiert werden". Und wenn ich den Test auf Systemkompatibilität mache, der auch im Setup-Menü der CD angeboten wird, steht bei Prozessor "erforderlich 200MHz, vorhanden 0MHz", "Grafik erf. 32MB, vorh. 0MB". Was soll man davon halten?
Gasterweiterungen sind installiert.

Ich hoffe, ihr könnt mir helfen. Denn als letzte Chance müsste ich XP "in echt" installieren, worauf ich nur wenig Lust habe.

Gruß Fabian

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »j.w.v.goethe« (05.08.2010, 16:47)


Beiträge: 407

Registrierungsdatum: 22.02.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: XFCE

Andere Distribution: Trisquel 4.1

  • Nachricht senden

2

02.08.2010, 17:50

Nabend,

Zitat

Im Netz las ich, dass man, um das zu verhindern, von DirectX zu OpenGL umstellen soll im Setup-Menü. Da komme ich aber leider nicht hin, da ich ja die Monkey.exe nicht öffnen kann.
Hast du es schon über wine regedit versucht?

Quellcode

1
wine regedit


HKEY_Current_User -> Software -> Wine -> Direct3D darin die Zeichenfolge "DirectDrawRenderer" auf opengl setzen.
Der Kopf dröhnt, wenn er gegen die Wand schlägt.

  • »j.w.v.goethe« ist der Autor dieses Themas

Beiträge: 33

Registrierungsdatum: 17.01.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

3

02.08.2010, 23:26

Hallo

Danke schonmal für den Hinweis. Hatte ich noch nicht probiert.
Unter HKEY_Current_User -> Software -> Wine -> Direct3D steht bei mir leider nur "(Standard)" "REG_SZ" "Wert nicht gesetzt" und "PixelShaderMode" "REG_SZ" "enabled".

Gruß

Beiträge: 407

Registrierungsdatum: 22.02.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: XFCE

Andere Distribution: Trisquel 4.1

  • Nachricht senden

4

03.08.2010, 00:01

Dann kannst du das einfügen.

Rechtsklick auf eine freie Stelle im rechten Fenster, dann Neu-> Zeichenfolge. Darin eintragen > DirectDrawRenderer < . Danach dürfte es dort stehen. Wiederum mit Rechtsklick darauf, dann ändern und > opengl < unter Daten: eingeben.

Zudem solltest du dies auch noch mit > VideoMemorySize < als Zeichenfolge und je nachdem wie viel Ram deine Grafikkarte hat - bspw. 512 MBRam - unter Daten: 512 eintragen.
Der Kopf dröhnt, wenn er gegen die Wand schlägt.

  • »j.w.v.goethe« ist der Autor dieses Themas

Beiträge: 33

Registrierungsdatum: 17.01.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

5

03.08.2010, 00:44

Ok, habe ich so gemacht. Nur leider hat Guybrush immer noch ein blaues Gesicht. Es hat dann scheinbar doch nichts mit opengl/directx zu tun. Zumindest nicht zwangsläufig. Oder hat er von LukasArts aus dieses blaue Gesicht und ich mach mich hier verrückt ;-)

Trotzdem danke

Beiträge: 407

Registrierungsdatum: 22.02.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: XFCE

Andere Distribution: Trisquel 4.1

  • Nachricht senden

6

03.08.2010, 16:39

Hm schade.

Hast du schon auf die Version 1.1 gepatcht?

Versuch zu dem in

Quellcode

1
winecfg


die Windowsversion auf 98 zu stellen.

Danach solltest du nochmal versuchen den Launcher zu starten.
Falls es wie erwartet nicht gehen sollte, starte den Launcher per Terminal.

Quellcode

1
wine /Pfad/zur/exe/monkey4.exe
Der Kopf dröhnt, wenn er gegen die Wand schlägt.

  • »j.w.v.goethe« ist der Autor dieses Themas

Beiträge: 33

Registrierungsdatum: 17.01.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

7

04.08.2010, 09:51

Hi

Also gepatcht war das Spiel von Anfang an, das hatte ich auf der Homepage vom WINEHQ gelesen.

Die Windows Version habe ich auch schon auf auf 98 gestellt, vorher startete das Spiel überhauptnicht.

Wenn ich in der Konsole im Installationsverzeichnis

Quellcode

1
wine ./Monkey.exe


eingebe, passiert einfach garnichts. Keine Fehlermeldung, nichts, es steht einfach die nächste Zeile da, als hätte ich bloß Enter gedrückt. (Monkey.exe ist der Launcher)

Vielleicht muss ich es einfach nochmal neu installieren. Bei der Installation wollte das Setup die CD2 nicht haben, da hab ich einfacj deren Inhalt manuel ins Installationsverzeichnis kopiert. Das Problem lag aber glaube ich nicht an der CD2, sondern war ein prinzipielles. Wenn ich bei der Aufforderung, CD2 einzulegen, auf "Abbrechen" gedrückt habe, wollte er wieder CD1, welche er, nachdem sie eingelegt war, auch nicht erkannte. Erst nachdem ich WINE abgewürgt hatte, lief die CD an und wurde gemountet. Ich werde bei der Neuinstallation versuchen, Images der CDs zu ziehen und zu mounten, habe gelesen, dass das funktioniert.

Weiß jemand zufällig, warum MI4 in meinem XP aus der VirtualBox nicht läuft? Das Adventure Jack Keane übrigens auch nicht. Die numerische Mathematiksoftware Matlab und Simulink hingegen schon. Wie freudenfeindlich...

Gruß Fabian

Beiträge: 407

Registrierungsdatum: 22.02.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: XFCE

Andere Distribution: Trisquel 4.1

  • Nachricht senden

8

04.08.2010, 10:28

Dein Pfad müsste eigentlich so aussehen:

Quellcode

1
wine /home/DEINNAME/.wine/drive_c/Lucasarts/MonkeyIsland/Monkey.exe


ggf. müsstest du natürlich die jeweiligen Ordner noch anpassen.
Der Kopf dröhnt, wenn er gegen die Wand schlägt.

  • »j.w.v.goethe« ist der Autor dieses Themas

Beiträge: 33

Registrierungsdatum: 17.01.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

9

04.08.2010, 10:34

Der absolute Pfad müsste schon so aussehen, wie du sagst.

Quellcode

1
wine ./Monkey.exe


ist ja der relative Pfad, ich bin ja schon zu /home/fabian/.wine/drive_c/Programme/LucasArts/Monkey4 navigiert.

Der ganze Befehl sieht so aus:

Quellcode

1
fabian@fabian-laptop:~/.wine/drive_c/Programme/LucasArts/Monkey4$ wine ./Monkey.exe


Die Monkey.exe ist auch schon als ausführbar gekennzeichnet.

Gruß

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »j.w.v.goethe« (04.08.2010, 10:35)


Beiträge: 407

Registrierungsdatum: 22.02.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: XFCE

Andere Distribution: Trisquel 4.1

  • Nachricht senden

10

04.08.2010, 21:34

Oh ok, hatte ich nicht gewusst.

Ich hab grad folgendes gefunden, dass man Monkey Island so starten soll.

Quellcode

1
2
3
wine "c:\Monkey4\Monkey.exe" --dll 
commdlg,comdlg32,commctrl,comctl32,shell,shell32=n,shfolder=n,shlwapi 
--desktop 640x480 -- -gl


Eig. dürfte man das Spiel auch per Terminal als OpenGl starten, in dem man hinter der exe

Quellcode

1
 --opengl


einfügt.(ggf. mit einem -).

Edit: Falls die CD-Erkennung nciht funktioniert, kannst du auch die Datein auf die Festplatte kopieren und von dort aus starten.
Oder auch die CD so mounten:

Quellcode

1
mount -o loop /dev/cdrom /mnt/cdrom/


ggf. root Rechte benutzen und per

Quellcode

1
mkdir /mnt/cdrom/

den Mountpunkt erstellen
Der Kopf dröhnt, wenn er gegen die Wand schlägt.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »tuxian« (04.08.2010, 21:38)


  • »j.w.v.goethe« ist der Autor dieses Themas

Beiträge: 33

Registrierungsdatum: 17.01.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

11

05.08.2010, 16:11

Hi!

Danke erstmal für die Anregungen!

Also ich habe zunächst die ganze MI4 Installation gelöscht. Da WINE sich anschließend weigerte, es erneut zu installieren (beim Öffnen der Monkey.exe auf CD1, wo nomalerweise der Installationsdialog kommt, brach es wieder ohne Fehlermeldung ab), habe ich WINE deinstalliert, das .WINE Verzeichnis gelöscht und reinen Tisch gemacht (wenn man sonst nix mit WINE installiert hat geht das schonmal ;) ). Dann WINE istalliert, MI4 installiert indem ich Images der CD's gezogen habe und diese, wie du beschrieben hast, nacheinander auf /mnt/cdrom gemountet (erst die erste, dann Monkey.exe gestartet, was wieder ging, und bei der Frage nach CD2 einfach deren Image in /mnt/cdrom gemountet und bestätigt). Die Installation wäre geschafft. Dann den neuesten Patch installiert. Im der WINE Konfiguration habe ich dann die WIN Version auf 98 gestellt und bei Grafik die ersten drei Häkchen weggemacht, und eins hin bei "Emuliere einen virtuellen Bildschirm" und dort "640x480" eingetragen. Dann habe ich in meinem Istallationsordner die Monkey.exe gestartet (ging bei der ersten Installation ja nicht), in dem sich öffnenden Menü ganz normal auf openGl und 16bit gestellt und gestartet. Und siehe da, perfekt! :D
Guybrush so wie er aussehen soll!!

Die ganze Geschichte läuft bei mir auf nem Notebook mit 16:10 Bildschirm, daher fehlt wieder unten am Rand ein Stück. Das habe ich aber sowohl bei ScummVM (nur in Verbindung mit MI3) und bei der DosBox (generell im Vollbildmodus). Nachzulesen hier : [gelöst] Problem mit DosBox im Vollbildmodus
Abhilfe schafft es dabei, die Bildschirmauflösung, wie in dem verlinkten Artikel beschrieben, auf 640x480 zu stellen und die Monkey.exe, also die mit dem Menü, übers Terminal zu starten. Dann passt es. Startet man sie aus dem Dateimanager, wird der virtuelle Bildschirm nicht emuliert. Und startet man die Monkey4.exe direkt, dann hat man wieder kein openGl, stattdessen ein blaues Gesicht. Das könnte man aber vielleicht, wie von tuxian beschrieben, durch einen entsprechenden Eintag in der WINE-Registry beheben. Da aber bei mir die Monkey.exe wieder geht, gehe ich einfach den Weg des geringsten Widerstandes

tuxian, vielen Dank an dich für die tiefgründige und unermüdliche Hilfe! :thumbsup:

Gruß Fabian

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »j.w.v.goethe« (05.08.2010, 16:42)