Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Peter1231« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 11.07.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

28.04.2010, 16:06

WinXP nach Ubuntu installation findet Festplatte nicht

Hi,

Also ich habe folgendes Problem.

Ich hatte WinXP und anschließend Ubuntu installiert auf einer Festplatte auf unterschieldichen Partitionen. Partitioniert hatte ich glaube ich mit der Ubuntu Installation.
So jetzt habe ich mir mein Win XP irgendwie so zerschossen, dass es nicht mehr hochlädt und wollte es neu installieren. Ubuntu lädt nach wie vor problemlos und erkennt auch die WinXP-partition.

Das Problem ist, dass XP-installer meine Festplatte nicht mehr findet.
Ich vermute, dass es an Ubuntu bzw. der Partitionierung durch Ubuntu liegt, das Windows zu engstirnig ist um so was zu erkennen. Hat jmd ne Idee wie ich das wieder hinkriege?

Ich hab schon die Suche bemüht aber nix gefunden, würde mich auch freuen wenn mit jmd das benötigte Schlagwort nennt.
Und tut mir leid falls ich im falschen Unterforum gelandet bin, da es ja nicht direkt ein Ubuntu-Installationsproblem ist.

So dann dankeschön schonmal für eure Hilfe und vg,
Peter

Beiträge: 637

Registrierungsdatum: 04.11.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

Andere Betriebssysteme: diverse

  • Nachricht senden

2

28.04.2010, 16:37

Du hast also ein Dualboot-System installiert.

Zitat

Ich hatte WinXP und anschließend Ubuntu installiert ...
wenn du ubuntu nach xp installiert hast, installiert sich GRUB als MBR.
d.h. Grub sollte dann dein ubuntu und auch dein xp erkennen.

Zitat

...dass XP-installer meine Festplatte nicht mehr findet.
ubuntu ist, wenn du richtig installiert hast, jetzt erst mal der "Chef".

d.h. wenn der pc startet, solltest du die im Bootmenü die Auswahl zw.
.-ubuntu und
-windows xp haben
primär bootet ubuntu hoch.

bist du nach dieser Anleitung vorgegangen?
-
- Gruß - Gambler - ... .....Avatare

3

28.04.2010, 16:38

Am besten wäre es, wenn du die Windows-Partition mithilfe von GParted noch einmal neu Partitionierst und den für
die Windows-Partition eingeplanten Speicherplatz zu freien unformatierten Speicherplatz umwandelst. (Partition entfernen)
Wenn du dann Windows neu installieren möchtest, sollte Windows den freien Speicherplatz entdecken und du
kannst die Partition neu mit NTFS formatieren.

Mit freundlichen Gruß

PS and den Vorredner: Soweit ich das beurteilen kann wird das nichts mit dem Bootloader zu tun haben, es scheint
das die Windows-Partition vom Threadersteller korrupt ist und einer Reperatur oder einer Neupartitionierung oder Formatierung bedarf.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »apensiv« (28.04.2010, 16:40)


  • »Peter1231« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 11.07.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

4

28.04.2010, 17:07

Hi, erstmal danke für die Antworten.

@Systemsys

Ja ich bin nach der Anleitung vorgegangen und ja Linux ist jetzt Chef ;-)
Grub erkennt auch weiterhin sowohl XP als auch Ubuntu. Bei Ubuntu auswahl kein Problem, allerdings XP startet nicht mehr, nicht mal im abgesicherten Modus.

Aber mit Grub sollte das nicht zusammenhängen, da ich ja von der XP-CD boote und somit Grub garnicht erst gefragt wird :) .

@apensiv Ich habe insgesamt sogar 3 Partitionen, eine Win XP, eine NTFS Multimedia Partition, und eine mit Ubuntu.
Ich werde das mit gparted gleich mal ausprobieren, wobei mir nicht ganz klar ist warum Windows den unformatierten Teil erkennen soll, wenn er bis jetzt die ganze Festplatte nicht findet. Selbst wenn die XP Partition kaputt ist, müsste er mir doch zumindest die Multimedia Partition anbieten. Oder nich?

Vllt. ist es ja von Bedeutung; ich habe Windows mit nem Virus/Trojaner zerschossen.
Das ging verdammt fix. Programm entpackt, Antivir meckert über Trojaner,-> Peter hat Wlan ausgeschaltet, gefühlte 10k Antivir Warnungen, Rechner reagiert nicht mehr, neugestartet und Windows startet nicht mehr. :cursing: Vorsicht vor dem OTR-Homeloader

So ich probier mal gparted und melde mich wieder. Bis gleich, dankeschön, vg
Peter

Da ich nicht berechtigt bin noch nen Beitrag abzugeben sagt EDITH:
So ich hab das jetzt mit gparted probiert.

Erst hab ich die Windows partition gelöscht und den Speicher frei gelassen, im zweiten Versuch den freien Teil NTFS-formatiert.
Beide Male konnte der XP-Installer die Festplatte nicht finden.

Habt ihr vllt. noch ne Idee? Mir würde als nächstes einfallen die komplette Festplatte neu zu formatieren und wieder alles neu draufzuspielen. Meine Lust dazu hält sich allerdings in Grenzen, da ich Ubuntu ungern neu installieren möchte. Ist grad alles so schön eingerichtet.

Vg
Peter

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Peter1231« (28.04.2010, 18:01)


DocHifi

unregistriert

5

28.04.2010, 18:51

@Peter1231

2 Fragen:
1. hast Du Windows zuvor selber installiert, oder war es schon drauf.
2. Hast Du evtl.eine S-ATA Festplatte?
Gruß DH

  • »Peter1231« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 11.07.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

6

28.04.2010, 19:10

Hi DocHifi,

1. Ja. Vorinstalliert war Vista, anschließend habe ich Win XP Prof. SP3 installiert. Also wurde die Platte schon mal vom Installer erkannt.

2. Musste ich extra nochmal nachschauen. Ja ist eine SATA.

Es handelt sich übrigens um ein Notebook. (Dell XPS M1530)

ds & vg
Peter

DocHifi

unregistriert

7

28.04.2010, 19:15

Ok.
Wenn es schon mal funktioniert hat, fällt meine Idee aus.
Ich hatte S-ATA in Verdacht, gab schon öfter Probleme.
Gruß DH

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 136

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

8

28.04.2010, 21:54

Hi Peter1231,

poste mal die Ausgabe von

Quellcode

1
sudo fdisk -l
im Terminal.

Greetz
wowi

  • »Peter1231« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 11.07.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

9

28.04.2010, 22:31

Hi,
nachdem ich ne gefühlte Stunde gebraucht habe um zu checken dass -l nich -Eins ist. 8o Hier bitteschön.

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 1 16 128488+ de Dell Utility
/dev/sda2 17 1322 10485760 7 HPFS/NTFS
/dev/sda3 1323 22036 166385205 7 HPFS/NTFS
/dev/sda4 22037 38914 135565655+ f W95 Erw. (LBA)
/dev/sda5 26014 38914 103618560 7 HPFS/NTFS
/dev/sda6 22037 25844 30587728+ 83 Linux
/dev/sda7 25845 26013 1357461 82 Linux Swap / Solaris

Hoffe das sagt dir mehr als mir.

Dankeschön für die Mühe vg Peter

Beiträge: 38

Registrierungsdatum: 10.04.2010

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

10

30.04.2010, 18:11

wegen XP-Installer... hast du ggf eine alte Platte, die du dazu hängen kannst? So zum Ausprobieren, wie weit Du mit XP kommst.

Oder Du steckst die Partitionen in eine VM und probierst mal, XP dort zu installieren...

was bin ich froh, das ich jedes System auf einer eigenen Platte habe :whistling:

11

01.05.2010, 11:27

Das Problem ist, dass XP-installer meine Festplatte nicht mehr findet.
Was sagt er denn dazu genau? "Dieser Computer hat keine Festplatte" oder so?
Mach bitte einmal das:

Quellcode

1
dd if=/dev/sda of=/tmp/mbr.txt bs=512 count=1
und hänge /tmp/mbr.txt hier als Datei an (nicht in den Beitrag kopieren, ist Binärdatei)
me is all sausage
but don't call me Ferdl