Sie sind nicht angemeldet.

[erledigt] Parley-Fehler

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »einreb« ist männlich
  • »einreb« ist der Autor dieses Themas

Beiträge: 301

Registrierungsdatum: 16.02.2007

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

1

02.02.2010, 16:05

Parley-Fehler

ich habe parley installiert; parley ist ein kde4-Programm
bisher lief es ohne Probleme
seit zwei Tagen kommt eine Fehlerfenster mit der Meldung:
/usr/share/kde4/apps/parley/plugins/leo-dict.py

hat jemand eine Idee, woran das liegen könnte?

gruss
einreb

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »einreb« (03.02.2010, 19:54)


DocHifi

unregistriert

2

02.02.2010, 16:13

Hi einreb,
/usr/share/kde4/apps/parley/plugins/leo-dict.py
eigentlich ist das ja keine Fehlermeldung, sondern der Pfad zu dem Phyton Script "leo-dict.py".
Hast Du mal probiert das Prog. über die Konsole zu starten, ob da eine Fehlermeldung kommt?
Ist das Script auch da wo es sein soll?
Gruß DocHifi

fkf

Account auf eigenen Wunsch gelöscht

  • »fkf« wurde gesperrt
  • Nachricht senden

3

02.02.2010, 19:50

Wird denn in diesem "Fehlerfenster" moniert, dass die Datei fehlen würde oder wo genau liegt das Problem?

Ist das Paket parley-data installiert?

Quellcode

1
dpkg -l parley-data


Wenn ein ii davor steht, ist es installiert.

  • »einreb« ist männlich
  • »einreb« ist der Autor dieses Themas

Beiträge: 301

Registrierungsdatum: 16.02.2007

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

4

02.02.2010, 19:51

zum ersten hast du natürlich Recht:
die Fehlermeldung heißt:
"das folgende script kann nicht geladen werden, es enthält Fehler" und danach kommt der oben genannte link; die Datei ist auch vorhanden; ob was darin falsch ist, kann ich nicht beurteilen

beim Start über das Terminal kommen folgende Zeilen

Quellcode

1
2
3
4
5
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
Object::connect: No such slot VocabularyModel::setLeitnerBox(KEduVocLeitnerBox*)
Object::connect: No such slot LeitnerView::setTranslation(KEduVocExpression*, int)
Kross: "Error error=Der Interpreter für die Skript-Datei „/usr/share/kde4/apps/parley/plugins/leo-dict.py“ kann nicht bestimmt werden. lineno=-1 trace=
"


Ich habs auch schon mal mit neu installieren versucht, aber danach kommt der gleiche Fehler

danke und gruss
einreb

fkf

Account auf eigenen Wunsch gelöscht

  • »fkf« wurde gesperrt
  • Nachricht senden

5

02.02.2010, 20:00


Kross: "Error error=Der Interpreter für die Skript-Datei „/usr/share/kde4/apps/parley/plugins/leo-dict.py“ kann nicht bestimmt werden. lineno=-1 trace=


Stand eine Zeile tiefer noch sowas wie?:

Zitat


and many more on other plugins
installing krosspython fixes it
maybe add krosspython as dependency


Dann könnte man versuchen "krosspython" nachzuinstallieren, welches es aber erst in den Lucid Quellen gibt.

Eventuell reicht Dir schon das Paket "libkrosspython0".

  • »einreb« ist männlich
  • »einreb« ist der Autor dieses Themas

Beiträge: 301

Registrierungsdatum: 16.02.2007

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

6

02.02.2010, 20:16

Zitat

Stand eine Zeile tiefer noch sowas wie?:
nein, das war der ganze Text

ich habe die libkrosspython0 installiert; jetzt wird die Liste etwas länger

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
Object::connect: No such slot VocabularyModel::setLeitnerBox(KEduVocLeitnerBox*)
Object::connect: No such slot LeitnerView::setTranslation(KEduVocExpression*, int)
Kross: "Loading the interpreter library for python" 
Kross: "Successfully loaded Interpreter instance from library." 
Kross: "PythonScript::Constructor." 
Kross: "PythonScript::execute" 
Kross: "PythonInterpreter::extractException:
  File "/usr/share/kde4/apps/parley/plugins/leo-dict.py", line 5, in <module>
import urllib2

  File "<string>", line 18, in _import

  File "/usr/lib/python2.6/urllib2.py", line 92, in <module>
import httplib

  File "<string>", line 18, in _import

  File "/usr/lib/python2.6/httplib.py", line 1054, in <module>
import ssl

  File "<string>", line 18, in _import

  File "/usr/lib/python2.6/ssl.py", line 81, in <module>
class SSLSocket (socket):
" 
Kross: "Error error=Error when calling the metaclass bases
module.__init__() takes at most 2 arguments (3 given) lineno=81 trace=
  File "/usr/share/kde4/apps/parley/plugins/leo-dict.py", line 5, in <module>
import urllib2

  File "<string>", line 18, in _import

  File "/usr/lib/python2.6/urllib2.py", line 92, in <module>
import httplib

  File "<string>", line 18, in _import

  File "/usr/lib/python2.6/httplib.py", line 1054, in <module>
import ssl

  File "<string>", line 18, in _import

  File "/usr/lib/python2.6/ssl.py", line 81, in <module>
class SSLSocket (socket):
" 
TypeError: Error when calling the metaclass bases
module.__init__() takes at most 2 arguments (3 given)
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/apport_python_hook.py", line 38, in apport_excepthook
from apport.packaging_impl import impl as packaging
  File "<string>", line 18, in _import
  File "/usr/lib/python2.6/dist-packages/apport/__init__.py", line 1, in <module>
from apport.report import Report
  File "<string>", line 18, in _import
  File "/usr/lib/python2.6/dist-packages/apport/report.py", line 21, in <module>
import fileutils
  File "<string>", line 18, in _import
  File "/usr/lib/python2.6/dist-packages/apport/fileutils.py", line 16, in <module>
from packaging_impl import impl as packaging
  File "<string>", line 18, in _import
  File "/usr/lib/python2.6/dist-packages/apport/packaging_impl.py", line 18, in <module>
import apt
  File "<string>", line 18, in _import
  File "/usr/lib/python2.6/dist-packages/apt/__init__.py", line 7, in <module>
from apt.package import Package
  File "<string>", line 18, in _import
  File "/usr/lib/python2.6/dist-packages/apt/package.py", line 23, in <module>
import httplib
  File "<string>", line 18, in _import
  File "/usr/lib/python2.6/httplib.py", line 1054, in <module>
import ssl
  File "<string>", line 18, in _import
  File "/usr/lib/python2.6/ssl.py", line 81, in <module>
class SSLSocket (socket):
TypeError: Error when calling the metaclass bases
module.__init__() takes at most 2 arguments (3 given)

Original exception was:
TypeError: Error when calling the metaclass bases
module.__init__() takes at most 2 arguments (3 given)
Kross: "PythonScript::Destructor." 
Object::disconnect: Unexpected null parameter

fkf

Account auf eigenen Wunsch gelöscht

  • »fkf« wurde gesperrt
  • Nachricht senden

7

02.02.2010, 20:28

Hmm, sagt mir jetzt so nichts. Ich hab aber auch kein KDE4 unter Jaunty, bzw. Teile davon auf Grund von Gnome Nutzung.

Ich würde mal im Lauchpad nach Bugreports zu parley schauen, vllt. wirst Du dort fündig.

  • »einreb« ist männlich
  • »einreb« ist der Autor dieses Themas

Beiträge: 301

Registrierungsdatum: 16.02.2007

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: Unity

  • Nachricht senden

8

02.02.2010, 21:16

nicht nur, dass ich den Fehler bekomme, jetzt sind meine Dateien auch noch leer (4500 Wörter in 4 Sprachen)
die backup-Dateien haben 1,6 MB, die aktuellen 1,7 kB

das Problem habe ich auch unter http://forum.ubuntuusers.de/topic/parley…i/#post-2040484 gefunden; ein Lösung hatte der aber auch nicht



ich habe eine neue Datei angelegt, dann das File im Texteditor geöffnet und nur die Wortliste aus einem backup hineinkopiert; so habe ich zumindest wieder eine funktionierende Datei, auch wenn der Fehler noch nicht weg ist;
ich werde nach jeder Benutzung eine Kopie anlegen

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »einreb« (03.02.2010, 19:54)