Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »turricum« ist der Autor dieses Themas

Beiträge: 1

Registrierungsdatum: 15.09.2009

Andere Betriebssysteme: Debian, CentOS, Ubuntu, SuSE

  • Nachricht senden

1

15.09.2009, 13:50

event.d Bootreihenfolge

Hallo zusammen

Ich habe ein Ubuntu 9.04. Ich habe eine Programm das seine Startscripte in /etc/event.d ablegt. Das script
sieht etwa so aus

start on runlevel 2
stop on shutdown
respawn
exec befehl

Mein Standardrunlevel ist 2. Laut daemon.log wird aber mein Script immer ausgeführt *bevor* das Netzwerk gestartet wird.
Ich versuche daher krampfhaft rauszufinden das er das Script ausführt *nachdem* die Scripte im rc.2 abgearbeitet wird.
Ist das irgendwie möglich? Das Script benötigt eine konfigurierte Netzwerkschnittstelle.

Ich arbeite zum ersten mal mit Upstart. Aber ich bin noch nicht dahinter gekommen wie ich die Abhängigkeiten sauer definieren kann. Ich weiss das ich es abhängig machen kann von anderen Prozessen im Upstart. Aber ich habe nur TTYx und Sachen wie Logd drin. Und die werden ja ganz am Anfang gestartet :-(

Kann mir jemand einen Tip geben?

vielen Dank! :-)
T.Urricum

PS: ich benutze eine Fremdsoftware die die Scripte in /etc/event.d auch für ihre Jobcontrolle benötigt. Also ein selbstgeschriebenes Script in /etc/init.d löst das ganze, dafür läuft aber die Software welche die Prozesse verwaltet nicht mehr richtig :-(

***************************************************************************************
Ich habe gemogelt. Im Script folgendes eingefügt:

pre-start script
sleep 10
end script

10 Sekunden warten, dann ist in der Zwischenzeit das Netzwerk oben und es funktioniert :)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »turricum« (15.09.2009, 13:50)


2

17.09.2009, 00:26

Hi,
Ich habe zwar auch keine besondere Erfahrung mit upstart, aber:
Das Script benötigt eine konfigurierte Netzwerkschnittstelle
..da müsste dein event eben vom entsprechenden Netzwerk-event abhängig gemacht werden -> Link
mir is wurscht