Sie sind nicht angemeldet.

9.04 Standardinstallation - Installiert, aber geht trotzdem nicht

  • »maxpower« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 04.09.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

04.09.2009, 21:38

Installiert, aber geht trotzdem nicht

Hallo liebe Leute,
ich habe mir euere aktuellste Version aus dem Internet gezogen von euer Seite und sie auf eine CD gebrannt, diese untersuchen lassen nach dem ersten start von ihr und dann mich durch den neuen (der ist wirklich gut) installer gehangelt um eine reines ubuntu-System aufzubauen.
So weit alles ganz gut und keine Fehler.

Allerdings immer wenn ich nach der Installation den Rechner Neustarten möchte von der Platte kommt der Fehler:
"No boot partion aktive" :thumbdown:

Was ich schon alles probiert habe:

1. Image auf md5 untersucht vor dem Brennen
2. CD Laufwerk ausgetauscht
3. eine andere Festplatte verwendet (ide)
4. diese auch nur noch einzelnt am primären ide
5. cd/dvd Laufwerk am sekundären ide
6. andere Disturbition (Linux Mint) => selber fehler nach der installation :cursing:
7. mehr als einmal Neuintstalliert, und zwar jede Version
...
7. ... was sollte ich als siebtes Versuchen tun, ohne mir gleich einen neuen PC kaufen zu müssen...bzw. ich meine das es eine Einstellungsache ist und kein Software Fehler der nur immer wieder bei mir hier auftritt...glaube ich...

ich bin für jeden guten Tipp dankbar!

Achja,
in der Live-fassung habe ich weder mit der einen noch mit der andern distrubition ein Problem...

Liebe grüsse
MaxPower

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maxpower« (04.09.2009, 21:38)


2

04.09.2009, 22:11

Vllt. änderst du einfach mal die Bootreihenfolge im Bios deines PCs!

Ciao Frosti

3

04.09.2009, 22:24

Vllt. änderst du einfach mal die Bootreihenfolge im Bios deines PCs!


Wie kommst du darauf ?
Ich denke mal eher , das maxpower grub falsch installiert .

HarzG

User

Beiträge: 131

Registrierungsdatum: 22.08.2009

Derivat: Xubuntu

Architektur: 64-Bit PC

Andere Betriebssysteme: Mint 9 Xfce 64bit

  • Nachricht senden

4

04.09.2009, 22:26

wo hast du Ubuntu installiert?

Es gibt mehrere Optionen um Ubuntu zu installieren.
Wo hast du es installiert? sda1, sda6?

trono

User

  • »trono« ist männlich

Beiträge: 1 559

Registrierungsdatum: 05.08.2005

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

5

05.09.2009, 10:46

Hallo,

sieht fast danach aus, als wenn bei der Partitionierung kein Boot-Flag gesetz wurde. Anscheinend fehlt die Bootpartition. Mal mit gparted anzeigen lassen. Oder gleich bei der Partitionierung (wird angezeigt) in der Regel im Wurzel(Root)verzeichnis Boot Flag setzen, dann sollte funktionieren. Als Tipp noch, getrennt davon auf einer anderen Partition das Homeverzeichnis einrichten lassen.

gruß trono
+++Älter werden ist wie Berg steigen. Je höher man kommt, umso weiter sieht man+++

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »trono« (05.09.2009, 10:46)


  • »maxpower« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 04.09.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

6

06.09.2009, 00:15

alles durchprobiert

:thumbsup: Danke fuer die vielen Antwroten:

@Frosti
Bootreihenfolge wurde angepasst und leider wurde kein ergebniss erziehlt, habe ich aber auch schon bei jedem Versuch gemacht.

@tata
Ich wuesste nicht was man falsch machen koennt bei der Instaltion von gurb? Denn die wird ja bei Instaltionswunsch direkt von ubuntu mitgebracht, also kann es daran anscheind auch nicht liegen oder?
Bzw. ich habe es mit grub und ohne gurb entzwischen Versucht mit ein und dem selben Ergebniss, das er halt die active Partion nicht finden konnte.

@HarzG
So bei dir bin ich mir nicht ganz sicher, nach dem ich im Installer gefunden habe wo man an die bez. ran kommt die du mir danennt ist mir aufgefallen das er meine IDE WD am primaeren Master als SDB1 und SDB5 als swap Einstellt. Die yeite Palate am SATA kontroller wird als eine SDA1 bezeichnet und ist noch als eine NTFS aufgeliestet und soll vorzeitig meine Daten behalten.
Nun stellt sich mir die Frage ob er immer versucht von der SDA zu Booten oder nicht?

@trono

Bei dir Sage ich mal das BOOTFLAG ganz gut klingt. aber wo kann ich sie setzen?(
Leider kann die ubuntu deine empfolens Tool gparted (Die Tab/completion kennt es) nicht von der Live cd starten auf die ich noch immer angewiesen bin, bzw. ich weiss nicht wie es geht, zumindest kommt in der Konsole dirket eine Fehlermeldung.
Wenn ich nun weit genug nach oben gehe mit cd ../ usw. wuesst ich nun auch nicht woran ich nach einem, ich nehme mal an ls befehl, ich die Boot Flag ausmachen sollte, bzw. wie ich sie dort setzen kann.
Wie man das Home verzeichnis woanders hin setzen kann ist mir auch noch ein raetsel aber da komme ich mit sicherheit noch hinter bzw. wuerde mich das eh noch fuer zukueftige instlationen intressieren.

gruesse
maxpower

7

06.09.2009, 00:18

Ich wuesste nicht was man falsch machen koennt bei der Instaltion von gurb? Denn die wird ja bei Instaltionswunsch direkt von ubuntu mitgebracht, also kann es daran anscheind auch nicht liegen oder?
Bzw. ich habe es mit grub und ohne gurb entzwischen Versucht mit ein und dem selben Ergebniss, das er halt die active Partion nicht finden konnte.


Kann man schon . Zum Beispiel wenn man GRUB nicht in den MBR schreibt .

  • »maxpower« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 04.09.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

8

06.09.2009, 00:50

@ trono
ja man kommt doch ran mit sudo und das sieht bei mir so aus:

und


Also was kann man daraus ablesen, ich habe mal beide Installieren Palten dagestellt.

@tata
das ging aber schnell danke!
aber was meinst du mit dem GBR? Bzw. wo kann man das einrichten.

LG
maxpower

9

06.09.2009, 00:57

aber was meinst du mit dem GBR? Bzw. wo kann man das einrichten.


Ist deine Tastatur defekt ?
MBR ist der Master Boot Record . Dort wird normalerweise der Bootmanager rein installiert . GRUB für Linux und NT-Loader für Windows .
Bei der Installation von der Ubuntu-Live-CD wird dir das eigentlich vorgeschlagen . Aber man kann das auch leicht übersehen (ist mir selber schon passiert ) .

  • »maxpower« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 04.09.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

10

06.09.2009, 01:22

nein defekt ist sie nicht da sitzt wohl das problem zwischen dem bildschirm und dem noch amerkianischen tastaturlayout der Live cd...aber das habe ich nun auch im griff, jetzt bleibt noch meine Chronische Rechtschreibschwäche.... 8)

Also ich meinte das GRUB ist mit installiert, aber wird dennoch nicht gefunden.

Also ist er evt. nicht im MBR mit drinne, wie auch immer das passieren solte, oder mein rechner schaut lustig auf die falsche Partion. Also werde ich nun noch mal die letzte Platte entfernen und dann mal schauen was er mir dann biete...

Nun stellt sich mir die Frage wie ich an den MBR ran komme bzw. hinter komme was da drinne ist und wie ich damit umgehen soll, bzw. es kontrolieren kann das es korrekt ist???


Dann kann ich dir deine Frage korrekt beantworten ob es so ist oder nicht.

LG
maxpower

trono

User

  • »trono« ist männlich

Beiträge: 1 559

Registrierungsdatum: 05.08.2005

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: GNOME 2.x

  • Nachricht senden

11

06.09.2009, 12:51

Hallo

ich weis nicht, welches Installations-Image du heruntergeladen hast. In der Regel ist die Alternate-Version die sicherste. Die Setzung des Bootflag wird bei Bestimmung der Partitionierung abgefragt mit ja/nein. Gleich am Anfang vor der eigentlichen Installation der Daten. Also wenn du die Partition abgefragt wird, wo du installieren willst und auf welcher Partition du das Systemverzeichnis (Wurzelverzeichnis) einrichten willst. Daneben empfehle eine Partition für Home-Verzeichnis neben der Swap. Je nach Version musst du am ensprechenden Ort durch Bejahung eine Patition zum booten einstellen (Bootflag setzen). Wenn du das versäumst, kann Ubuntu nicht booten, weil die Bootpartition fehlt, also wie deine Fehlermeldung auch schon lautet. Ich bin mir nicht sicher, ob man das mit gparted nachholen kann, weil Grub entsprechend konfiguriert werden muss, was der Installer von sich aus tut. Ansonten gibt es gparted auch als Liveversion. Wie schon andere geschrieben haben musst du zudem nach Abschluss der Installation das Schreiben im MBR zulassen.

Um sicher zu gehen, würde ich an deiner Stelle die Installation wiederholen und auf die Setzung des Booflag im SystemVerzeichnis, welches mit / gekenzeichnet wird, achten. Um weitere Fehler zu vermeiden sollten die für Ubuntu ausgewählten Partitionen (System und Home) mit dem Dateisystem deiner Wahl formatiert werden, also keine Daten übernehmen. Ich habe beste Erfahrungen mit JFS gemacht. Muss aber jeder selbst wissen. Dann sollte alles laufen :)

gruß trono
+++Älter werden ist wie Berg steigen. Je höher man kommt, umso weiter sieht man+++

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »trono« (06.09.2009, 12:51)


  • »maxpower« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 04.09.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

12

07.09.2009, 00:33

Moin Leute,
danke fuer die vielen Tipps und ich bin ne ganze ecke weiter. :D

Ich habe nun tasaechlich Gurb gesehen...Allerdings verabschiedet der sich immer mit Error 17. Can not mount selected partion. Habe mich schlaugelesen und herausgefunden das es mit meiner Festplatten konfiguration, diese hier ist/

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
mint@mint ~ $ sudo fdisk -l

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xbfc1ca0c

   Device Boot  Start     End  Blocks   Id  System
/dev/sda1           1   38913   3125686416  FAT16

Disk /dev/sdb: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0003a36a

   Device Boot  Start     End  Blocks   Id  System
/dev/sdb1   *       1    182414651248+  83  Linux
/dev/sdb2        1825   20060   1464806705  Extended
/dev/sdb3       20061   2346427342630b  W95 FAT32
/dev/sdb4       23465   24321 6883852+  82  Linux swap / Solaris
/dev/sdb5        1825   20060   146480638+  83  Linux


Habe nach vielem rumlesen herrausgelesen das das so eine sinvolle aufteilung sein soll.

Und meiner menue.Ist zusammen haengt, dieser hier:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
# menu.lst - See: grub(8), info grub, update-grub(8)
#        grub-install(8), grub-floppy(8),
#        grub-md5-crypt, /usr/share/doc/grub
#        and /usr/share/doc/grub-legacy-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default0

## Graphical boot menu location
gfxmenu=/boot/gfxmenu/linuxmint.message

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout10

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#  password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# titleWindows 95/98/NT/2000
# root(hd0,0)
# makeactive
# chainloader+1
#
# titleLinux
# root(hd0,1)
# kernel/vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##  kopt_2_6_8=root=/dev/hdc1 ro
##  kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/sdb1 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##  alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##  lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
##  lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##  altoptions=(single-user) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##  howmany=7
# howmany=all

## specify if running in Xen domU or have grub detect automatically
## update-grub will ignore non-xen kernels when running in domU and vice versa
## e.g. indomU=detect
##  indomU=true
##  indomU=false
# indomU=detect

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##  memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

titleLinux Mint 7 Gloria, kernel 2.6.28-11-generic
root(hd1,0)
kernel/boot/vmlinuz-2.6.28-11-generic root=/dev/sdb1 ro quiet splash 
initrd/boot/initrd.img-2.6.28-11-generic
quiet

titleLinux Mint 7 Gloria, kernel 2.6.28-11-generic (recovery mode)
root(hd1,0)
kernel/boot/vmlinuz-2.6.28-11-generic root=/dev/sdb1 ro single
initrd/boot/initrd.img-2.6.28-11-generic

titleLinux Mint 7 Gloria, memtest86+
root(hd1,0)
kernel/boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
titleOther operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
titleMicrosoft Windows XP Professional
rootnoverify(hd0,0)
savedefault
chainloader+1


Nun weiss ich das ich dort was anpassen soll:

http://wiki.ubuntuusers.de/menu.lst#Eint…-Liste-optional

Aber so wie ich das sehe muesste es doch korrekt sein, oder nicht?

Aber wenn dann mus wohl der Fehler in der Yeile 133 liegen oder nicht? Aber er greift doch auf die
root(hd1,0)
und bei mir ist die System Partion mit Ubuntu: Die aus Zeile 17 aus dem oberen Befehl, oder nicht? Mit dem Minus 1... ?(

Bin um weiter Hilfe dankbar.

LG
michi

13

07.09.2009, 01:46

Hi,
An und für sich stimmt das alles. Dein Problem dürfte genau hier liegen:
meine IDE WD am primaeren Master als SDB1 und SDB5 als swap Einstellt. Die yeite Palate am SATA kontroller wird als eine SDA1 bezeichnet

Du hast eine SATA und eine PATA Platte. Beim Booten und Installieren von CD wird die SATA als erste Platte eingeteilt (sda) und die Konfigurationsdateien entsprechend erstellt.
Wenn Du dann von Platte bootest, nimmt das BIOS scheinbar die IDE-Platte als erste her - und findet dort weder ein System, noch würden die Konfigurationen jetzt dazu passen.

Das könnte man jetzt über Einstellungen im BIOS lösen oder über entsprechende Änderungen an den Konfigurationsdateien (menu.lst und fstab), dann müsste man den Grub mit diesen Daten erneuern. BIOS-Änderung könnte einfacher sein - wenn es eine entsprechende Option gibt. Bei mir zum Beispiel kann ich angeben, daß der SATA-Controler den ersten IDE-Bus ersetzen soll. Meine IDE Platten laufen dann nur am zweiten Bus. Dann würde auch bei dir alles stimmen. Oder auch die Bootreihenfolge so ändern, daß eben vom SATA-Controler gebootet wird. Je nachdem, welche Möglichkeiten dein BIOS eben bietet...
Die Änderungen über die Systemdateien sind etwas haariger, da man sie nur aus dem Live-System machen kann und sich aber schon überlegen muß, wie das später laufende System die Platten sehen wird. Beim Umstecken der Platten würde dann aber auch sofort alles wieder nicht stimmen.
me is all sausage
but don't call me Ferdl

  • »maxpower« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 04.09.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

14

07.09.2009, 04:37

Du hast eine SATA und eine PATA Platte. Beim Booten und Installieren von CD wird die SATA als erste Platte eingeteilt (sda) und die Konfigurationsdateien entsprechend erstellt.
Wenn Du dann von Platte bootest, nimmt das BIOS scheinbar die IDE-Platte als erste her - und findet dort weder ein System, noch würden die Konfigurationen jetzt dazu passen.

Ja das hast du Richtig erfasst! :thumbup:
Das die SATA als erste Platte erfasst wird sehe ich auch so, ist fruerer Windows nutzer etwas ungewohnt.

Grundsaetzlich ist alles auf der IDE Platte Installiert, also die PATA WD Platte. Die sdb1 ist nachwievor NTFS und hat meine alten Windows Daten, die ich noch brauche.
Alle Infos die ich aus dem System bisher herrausgeholt habe sind die die ich immer dann hatte wenn ich das System mit einer Live CD gebootet habe, daher schliest es meiner Kenntnis aus wie die Einstellungen sind wenn ich das ganze mal ohne einer LIVE am laufen habe.

Die ROOT Partion mit Live CD befindet sich aus dem Beitrag zuvor in der Zeile: 17
Zumindest sollte das das Veryeichnis sein welches sich bei der Einrichtung von ubuntu mit / bezeichnet und auch das sein sollte von dem dann das System gestartet werden sollte.

Quellcode

1
/dev/sdb1   *       1    182414651248+  83  Linux


Allerdings wird diese auch doppelt angezeigt in Zeile 21, warum?:

Quellcode

1
/dev/sdb5        1825   20060   146480638+  83  Linux


Also fast... nur das halt das System nicht auf der SDA1 sondern doch von der PATA aus laufen soll.

Wegen BIOS?
Nein das Board kann nur von Laufwerk und von einer belibigen Festplatte oder gesondert vom SATA bzw. hier auch RAID starten. momentan ist es auf die PATA WD Platte eingestellt, wo ich meine das das so korrekt ist, worauf auch das ubuntu installiert sein muesste.

LG
maxpower

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maxpower« (07.09.2009, 04:37)


  • »LePatron« ist männlich

Beiträge: 173

Registrierungsdatum: 07.09.2009

Derivat: Ubuntu

Architektur: 64-Bit PC

Andere Betriebssysteme: Debian Squeeze 64 Bit, Debian Lenny PowerPC

  • Nachricht senden

15

07.09.2009, 13:52

Ich glaube, die einfachste Methode wäre es für Dich als Linuxneuling, wenn Du vor der Installation die SATA Platte abziehst. Wenn Du dann noch darauf achtest, dass Du während der Installation GRUB in den MBR schreibst, kann eigentlich nichts mehr schief gehen.

Bevor Du nach erfolgreicher Installation die SATA Platte wieder ansteckst, solltest Du nochmal sicher stellen, dass im BIOS wirklich die IDE Platte als erstes Startlaufwerk gesetzt ist.

  • »maxpower« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 04.09.2009

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

16

07.09.2009, 14:10

thx LePatron

@LePatron
auf einen weitern versuch kommt es eh nicht mehr drauf an.
Werde es machen.

mfg
maxpower