Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »polytom« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 27.06.2009

Architektur: 64-Bit PC

  • Nachricht senden

1

27.06.2009, 09:32

Festplatten automatisch einhängen (evtl. mit fstab)

Hallo zusammen,

ich möchte eine Partition automatisch einhängen, welche unter Windows eigentlich läuft, da dort meine Musik gespeichert ist, welche ich auch unter Ubuntu mit Amarok hören möchte.

Beim Lesen anderer Beiträge bin ich auf Informationen gestossen, die schonmal weiterhelfen könnten. Im Terminal erhielt ich folgende Infos:

root@tom-desktop:~# fdisk -l

Platte /dev/sda: 300.0 GByte, 300069052416 Byte
255 Köpfe, 63 Sektoren/Spuren, 36481 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0xe5b5819e

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 5294 42524023+ 7 HPFS/NTFS
/dev/sda2 36350 36481 1060290 82 Linux Swap / Solaris
/dev/sda3 5295 36349 249449287+ f W95 Erw. (LBA)
/dev/sda5 5295 16132 87056203+ 7 HPFS/NTFS
/dev/sda6 16133 36349 162393021 7 HPFS/NTFS

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

Platte /dev/sdb: 160.0 GByte, 160041885696 Byte
255 Köpfe, 63 Sektoren/Spuren, 19457 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0xff98ff98

Gerät boot. Anfang Ende Blöcke Id System
/dev/sdb1 1 6 48163+ 83 Linux
/dev/sdb2 7 1791 14338012+ 83 Linux
/dev/sdb3 19326 19457 1060290 82 Linux Swap / Solaris
/dev/sdb4 1792 19325 140841855 f W95 Erw. (LBA)
/dev/sdb5 1792 18050 130600386 7 HPFS/NTFS
/dev/sdb6 18051 19325 10241406 7 HPFS/NTFS

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

Platte /dev/sdc: 4127 MByte, 4127195136 Byte
16 Köpfe, 32 Sektoren/Spuren, 15744 Zylinder
Einheiten = Zylinder von 512 × 512 = 262144 Bytes
Disk identifier: 0x8cf99f31

Gerät boot. Anfang Ende Blöcke Id System
/dev/sdc1 1 15744 4030448 b W95 FAT32

Wobei Sdc1 mein USB-Stick ist.

Die automatisch einzuhängende Partition ist dev/sda5. Ich habe schon versucht die fstab zu ändern. Aber wohl die falschen Einstellungen, hat danach garnicht mehr funktioniert, konnte auch nicht mehr manuell einhängen, weswegen ich die letzte Zeile auf kommentar gesetzt habe:

# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sdb2 during installation
UUID=212764b1-8bc6-4def-8a28-f7810f81516e / ext3 relatime,errors=remount-ro 0 1
# swap was on /dev/sda2 during installation
UUID=140882cb-b202-4719-82c8-8285bdc4b159 none swap sw 0 0
# swap was on /dev/sdb3 during installation
UUID=cbf4feab-b965-472a-98b5-044a901f13e5 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

#/dev/sda5 /media/daten fuseblk user



SO, vielen dank vorab. Freue mich über eure Hilfe.

LG Tom

# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sdb2 during installation
UUID=212764b1-8bc6-4def-8a28-f7810f81516e / ext3 relatime,errors=remount-ro 0 1
# swap was on /dev/sda2 during installation
UUID=140882cb-b202-4719-82c8-8285bdc4b159 none swap sw 0 0
# swap was on /dev/sdb3 during installation
UUID=cbf4feab-b965-472a-98b5-044a901f13e5 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

#/dev/sda5 /media/daten fuseblk user

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »polytom« (04.07.2009, 11:33)


seju

User

  • »seju« ist männlich

Beiträge: 109

Registrierungsdatum: 22.12.2007

Wohnort: /dev/saarland

Architektur: 32-Bit PC

Andere Distribution: Server 8.04

  • Nachricht senden

2

27.06.2009, 10:53

Die fstab sollte so aussehen, bzw der Eintrag von sda5

Quellcode

1
/dev/sda5		/media/daten	ntfs	auto,defaults	0	0


Sollte so eigentlich stimmen.

Auch noch sicher gehen das der Ordner "daten" unter "/media/" erstellt ist.


Gruß

Seju
Server: CPU: Intel Atom 330 RAM: 2,0 GB DDR2 GPU: onboard HDD: 1,75 TB OS: Ubuntu Server 8.04 LTS 32bit
Mein Blog | Server Sponsoring

  • »Megaleecher« ist männlich

Beiträge: 238

Registrierungsdatum: 25.05.2009

Wohnort: Wien

Architektur: 32-Bit PC

Andere Distribution: Linux Mint Isadora, Debian Lenny Server, Debian Squeeze Server, Ubuntu Server 10.04, Kubuntu 10.04

  • Nachricht senden

3

27.06.2009, 10:54

schreib in die Datei fstab folgende Zeile:

Zitat

/dev/sda5 /media/daten/ ntfs default 0 0

danach schreibst du noch

Zitat

mount -a

Und schon sollte die Partition gemountet sein.
MfG Megaleecher
Höre nie auf besser zu werden, weil dann hast du aufgehört gut zu sein!!!

Beiträge: 6 734

Registrierungsdatum: 04.06.2005

Wohnort: -

Derivat: Kein Ubuntu-Derivat

Version: keine Ubuntu-Version

Architektur: 64-Bit PC

Desktop: anderer

Andere Distribution: Manjaro Linux - OpenBox - KDE

  • Nachricht senden

4

27.06.2009, 17:25

Hallo,

warum erstellst du eigentlich 2 Treads zu dem gleichen Thema?

Kann ich den anderen Eintrag löschen?

m.f.g.
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

  • »polytom« ist der Autor dieses Themas

Beiträge: 7

Registrierungsdatum: 27.06.2009

Architektur: 64-Bit PC

  • Nachricht senden

5

04.07.2009, 11:32

Fertig !! Danke

Kannst du gerne löschen, ich probiere es auch zu löschen.

WIe kann ich den Thread den als gelöst markieren. Ich probiere das mal aus.

Leider finde ich im ersten Beitrag nirgends die Option Präfix und kann es nicht auf gelöst setzen.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »polytom« (04.07.2009, 11:32)


  • »Megaleecher« ist männlich

Beiträge: 238

Registrierungsdatum: 25.05.2009

Wohnort: Wien

Architektur: 32-Bit PC

Andere Distribution: Linux Mint Isadora, Debian Lenny Server, Debian Squeeze Server, Ubuntu Server 10.04, Kubuntu 10.04

  • Nachricht senden

6

04.07.2009, 12:11

Du gehst auf den ersten Beitrag -> Bearbeiten.
Dann neben der Überschrift ist eien Auswahlbox und dort kannst du den Prefix auswählen.
MfG Megaleecher
Höre nie auf besser zu werden, weil dann hast du aufgehört gut zu sein!!!