Sie sind nicht angemeldet.

  • »Alcudra« ist der Autor dieses Themas

Beiträge: 5

Registrierungsdatum: 15.12.2008

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

29.12.2008, 16:14

Networkmanager zeigt bestehende Verbindung nicht an.

Hallo,

ich wollte unlängst eine VPN-Verbindung über den Networkmanager einrichten, als ich feststellte, dass ich laut dem Manager keine Verbindung zum Internet besäße. Der Befehl ifconfig

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
ifconfig
eth0      Link encap:Ethernet  Hardware Adresse 00:19:db:5d:ea:e2  
          inet Adresse:192.168.XXX.XX  Bcast:192.168.XXX.XXX  Maske:255.255.255.0
          inet6-Adresse: fe80::219:dbff:fe5d:eae2/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:33861 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25066 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:40274906 (40.2 MB)  TX bytes:3493259 (3.4 MB)
          Interrupt:18 

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1
          RX packets:87 errors:0 dropped:0 overruns:0 frame:0
          TX packets:87 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:6852 (6.8 KB)  TX bytes:6852 (6.8 KB)

(Ziffern meiner IP-Adresse habe ich teilweise durch X ersetzt.)

und meine Möglichkeit über Firefox im Internet zu surfen zeigen mir jedoch das Gegenteil. Im Anhang ist die Fehlermeldung des Networkmanagers.
Mit dem Internet bin ich über einen DSL-Router, und wenn ich es richtig verstanden habe ohne DHCP, aber mit einer festen IP-Adresse verbunden.

Meine mit X "zensierte" /etc/network/interfaces:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.XXX.XX
netmask 255.255.255.0
gateway 192.168.XXX.X

auto eth1
#iface eth1 inet dhcp

Woran könnte es liegen, dass der Networkmanager eine bestehende Verbindung nicht anzeigt.

Gruß
Alcudra




So,

ich habe es geschafft, das Problem selber zu beheben. Es lag an meiner /etc/network/interfaces. Diese schaut jetzt so aus:

Quellcode

1
2
auto lo
iface lo inet loopback

Ich hatte früher mal diese Datei manuell geändert um mir so eine statische IP zu verpassen. Mittlerweile weiß ich, dass dies auch a) anders geht und b) der Networkmanager durch den manuellen Eintrage diese Schnittstelle nicht mehr verwaltet.

Alcudra

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Alcudra« (29.12.2008, 16:14)


2

29.12.2008, 18:21

b) der Networkmanager durch den manuellen Eintrage diese Schnittstelle nicht mehr verwaltet.
Witzig. Für die meisten ist genau das die einzig brauchbare Lösung, besonders wenn dieser Manager ihr WLAN nach Gutdünken "vergewaltet".
mir is wurscht