Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

22.12.2008, 11:14

Rosengarden

Hi zusammen

Da ich viel Musik, schreibe, arrangiere und transponiere war ich seit langem auf der suche für einen guten ersatzt für mein altbewährtes Forte.
Dazu habe ich bis jetzt relativ mühsam Lilypnd benutzt.
Nun bin ich aber auf Rosengarden gestossen, das auch auf Lilypond bassiert aber GUI hat.
Ich finde es ein sehr gutes Programm doch habe ich noch ein kleines Problem. Wenn ich Rosengarden starte kommt ein Fehler das der Jack Server nicht läuft und der ist nötig das ich die Stücke abspielen kann.
Wenn ich den Jack sServer dann Starte kommt ein Fenster bei welchem ich zwischen vielen "Dingern" verbinden kann.

Kann mir nun jemand sagen was ich da verbinden muss das die Audio wiedergabe funktioniert?

Zitat

"Nur Weicheier benutzen Datensicherungen auf Band: Richtige Männer laden ihren wichtigen Kram einfach auf einen FTP und lassen diesen vom Rest der Welt spiegeln." Usenet 1996

Beiträge: 73

Registrierungsdatum: 28.07.2008

Architektur: 32-Bit PC

  • Nachricht senden

2

22.12.2008, 18:30

also, Jack ist auf den ersten Blick etwas unübersichtlich, aber wenn man erstmal damit gearbeitet hat, will man's nicht mehr missen.
Bei Jack musst du erstmal deine Einstellungen vernünftig hinbekommen, vor allem die richtige Soundkarte in den Einstellungen auswählen und passende Werte für Frames/s, etc. angeben, um möglichst geringe Latenz zu erzielen, wobei das auch eigentlich erst wichtig wird, wenn du viel über Midi einspielst. Dann Jack starten, also Play drücken.
Danach schaust du dir das Fenster unter "Connections" an und bei genauem hinsehen wirst du bemerken, dass auf der einen Seite nur Ausgänge und auf der anderen Seite nur Eingänge stehen.
benutzt du zB ein Midi-Keyboard und Rosegarden verbindest du unter "Midi" den Keyboard-Ausgang mit Midi-in bei Rosegarden und unter Audio den Rosegarden Master Out mit dem Eingang deiner Soundkarte.
Wenn du dann bei Rosegarden auch jeder Spur ein Instrument (Synth, etc) zugeordnet hast, sollte es eigentlich funktionieren.
Viel Erfolg!
Ansonsten gibt's im Netz auch recht viel an Tutorials, etc. zu Jack-Einstellungen.
MfG, Johannes
--
Edit: Orthographie

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »haudraufjupp« (22.12.2008, 18:30)


3

23.12.2008, 22:02

okee, ich habe jetzt heraus gefunden das ich noch einen synth brauche, dazu habe ich QSynth installiert.
Doch finde ich nirgends heraus wie ich Jack einstellen muss.

Was mit bis jetzt logisch erscheint ist folgendes: (QSynth und Jack laufen)
Bei Jack unter Audio sind folgende verbunden

Quellcode

1
2
3
qsynth                                 system
left                                      playback 1
right                                    playback 2

Doch was ich unter ALSA meiteinander Verbinden muss weiss ich nicht. Ich habe folgende möglichkeiten zu auswahl
(Jack, QSynt und rosegarden laufen)
Links Readable Clients / Output Ports

Quellcode

1
2
3
4
5
6
14: Midi Throug
        0:Midi Throug Port-0
128:rosegarden
        1: sync out
        2: external controller
        3: out Gerneal MIDI Device (*)


Rechts Writable Clients / Input Ports

Quellcode

1
2
3
4
5
6
7
14: MIDI Through
         0: MIDI Through Port-0
128: rosegarden
         0: record in
         2: external Controler
130: FLUID Synth (6432)
          0: Synth input port (6432:0) (*)


Wobei diese mt (*) schon verbunden sind

Zitat

"Nur Weicheier benutzen Datensicherungen auf Band: Richtige Männer laden ihren wichtigen Kram einfach auf einen FTP und lassen diesen vom Rest der Welt spiegeln." Usenet 1996

Beiträge: 73

Registrierungsdatum: 28.07.2008

Architektur: 32-Bit PC

  • Nachricht senden

4

24.12.2008, 14:15

hmm.. Ehrlich gesagt hab ich immer qJackctl benutzt, also die graphische Oberfläche zu Jack, das macht das ganze vielleicht etwas übersichtlicher.
Ansonsten kannst du unter Rosegarden auch interne Synths benutzen, die vereinfachen den Aufwand bei Jack auch erstmal, ist bis zum ersten ton vielleicht nicht schlecht.
wenn du dann alles verbunden hast was zusammen passt, was dann ja nur 2 Ports sein sollten und das aber immer noch nicht funktioniert wirds wohl an den Einstellungen liegen...
mfG, Johannes

5

24.12.2008, 15:59

Also ich verwende auch die GUI von Jack
Was ich da aufgelistet habe sin die möglichkeiten die mir zurverfügung stehen in den verschiedenen Reiter

UN leider habe ich keine Ahnung was zusammen passt, da ich von Midi und so auch nicht viel ahnung habe, weil ich Rosegarden vorallem als Notensatz Programm und nicht als Sequenzer benutzen werde. Die Abspiel funktion brauche ich nur um kontrollieren zu können ob die Akkorde usw. Stimmen

Zitat

"Nur Weicheier benutzen Datensicherungen auf Band: Richtige Männer laden ihren wichtigen Kram einfach auf einen FTP und lassen diesen vom Rest der Welt spiegeln." Usenet 1996

Beiträge: 73

Registrierungsdatum: 28.07.2008

Architektur: 32-Bit PC

  • Nachricht senden

6

24.12.2008, 17:39

OK, also wirklich Ahnung von Midi braucht man auch zum Glück nicht haben, ansonsten würd's bei mir auch nicht laufen :)

So wie's aussieht hast du schon alles korrekt verbunden..Wie sehen deine Jack-Einstellungen aus? hast du immer noch die Fehlermeldung? und funktioniert sonst immer dein Ton?
Ich war auch schonmal kurz vor der Verzweiflung, bis ich gemerkt habe, dass einfach keine Boxen angeschlossen waren...

Wenn ich mich recht erinnere hat mir damals diese (http://www.linux-user.de/ausgabe/2006/07/058-rosegarden/) Anleitung weitergeholfen.
Die haben da auch schöne Bildchen, die ich schlecht beschreiben kann, versuch's einfach mal.
Das könnte auch hilfreich sein.. http://wiki.ubuntuusers.de/JACK_Audio_Connection_Kit
Nur zum Notenschreiben reicht das dann auch wahrscheinlich wenn du einfach Jack und Rosegarden installierst. Solltest du doch mal Bock auf ein paar Heimstudiotechnische Spielereien bekommen würde ich dir aber zur Installation von Ubuntu-Studio raten, das hat einen Latenzoptimierenden Kernel eingebaut.
MfG, Johannes

7

24.12.2008, 23:33

dS mit Ubuntu Studio habe ich schon mal probiert war aber nicht so gut, machte nur zicken.

Danke für den Link habe begonnen das auszuprogbieren da bin ich auf etwas gestossen was die urschae sein könnte.
Ich habe für einmal Jack nicht GUI sondern von der KOnsole gestartet da kam ein fehler das er das alsa modul nicht geladen hat:

Quellcode

1
2
3
4
5
6
7
JACK compiled with System V SHM support.
loading driver ..
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
the playback device "hw:0" is already in use. Please stop the application using it and run JACK again
cannot load driver module alsa
no message buffer overruns


Jetzt wie finde ich heraus was das für ein device hw:0 ist??

//EDIT
Dies trit nur auf wenn ich vorher irgend eine Andere Sound anwendung offen hatte, wenn ich den PC aufstate und gleich den Befehl eintippe kommt kein Fehler,
Leider funzt die Ton ausgabe immer noch nicht

//EDIT2
Ich habe jetzt noch Hydrogen installiert dort funktioniert der Ton, alles supi.
Bei Jack und Rosegarden bin ich immer noch gleich weit, dein link zu LinuxUser hat leider nicht geholfen :(

Zitat

"Nur Weicheier benutzen Datensicherungen auf Band: Richtige Männer laden ihren wichtigen Kram einfach auf einen FTP und lassen diesen vom Rest der Welt spiegeln." Usenet 1996

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »nuTux« (24.12.2008, 23:33)


Beiträge: 73

Registrierungsdatum: 28.07.2008

Architektur: 32-Bit PC

  • Nachricht senden

8

25.12.2008, 15:18

Frohe Weihnachten!
Also, offensichtlich gibt's da einen Konflikt zwischen Jack und anderen Anwendungen die Sound benötigen.
hw:0 sollte deine Soundkarte sein, ansonsten ist klar warum du nichts hörst. Hast du dir denn mal die Einstellungen von Jack unter Setup angeschaut, was ist dort bei Interface (Soundkarte) ausgewählt? wenn du rechts auf den Pfeil klickst bekommst du die genauere Bezeichnung. bei mir ist's z.B. im Moment hw:1, aber da ich ein USB Interface benutze wechselt das schonmal.
Sonst, bei 'Realtime' das Häkchen weg. Also gar keine sachen anhaken. und sonst in der rechten Spalte fast alles auf default, eben außer deinem Interface. Dither: None, und duplex brauchst du auch nicht. In der mittleren Spalte Ist glaub ich erstmal nix so wichtiges um überhaupt erstmal Sound zu bekommen..
Schau auch mal hier: http://www.linuxjournal.com/article/8354
Bei mir hat der aber auch schonmal nur wegen des eingeschalteten Realtime-Modus rumgemuckt..
MfG, Johannes