Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »lazarus« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 20.11.2007

  • Nachricht senden

1

15.12.2008, 23:27

youtube-videos erstellen mit makevid.py

hallo zusammen,

vor kurzem bin ich auf einen sehr interessanten bericht auf ubuntuobserver gestoßen, hier wird ein python script vorgestellt das es ermöglicht aus einem .jpg und einer .mp3 ein video zu erstellen. sprich: einfach ein bild und im hintergrund läuft die musik - sieht man häufig auf youtube und konsorten. das ganze will bei mir aber absolut nicht funktionieren und ich bin mittlerweile am ende mit meinem latein, erst mal die beiden links

http://ubuntuobserver.wordpress.com/2008…datei-erstellen
http://peabody.weeman.org/makevid.py

hier meine shell:

Quellcode

1
2
3
4
5
thomas@thomas-desktop:~/Desktop/makevid$ dir
a-gasmask_71-human_game.mp3  gasmask.jpg  makevid.py
thomas@thomas-desktop:~/Desktop/makevid$ makevid.py a-gasmask_71-humangame.mp3 gasmask.jpg 352
bash: makevid.py: command not found
thomas@thomas-desktop:~/Desktop/makevid$


mencoder ist installiert, ebenso sämtliche python applikationen, ebenso wurde makevid.py ausführbar gemacht. alles was ich bekomme ist ein command not found.

ich wäre sehr dankbar wenn ihr mir bei meinem problem weiterhelfen könntet, ich komm da alleine nicht mehr weiter.

herzlichen dank im vorraus ;)

€dit:

UBUNTU
Version 8.04 (hardy)
Kernel Linux 2.6.24-22-rt
Gnome: 2.22.3

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »lazarus« (16.12.2008, 13:41)


  • »Falco2« ist männlich

Beiträge: 378

Registrierungsdatum: 16.09.2008

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: EasyPeasy 1.6 = 10.04 -=- Linux Mint 17.3

  • Nachricht senden

2

15.12.2008, 23:39

./makevid.py gasmask.jpg a-gasmask_71-human_game.mp3 300


1.
./makevid.py (so führt man Dateien aus !)

2.
danach das BILD

3.
danach die MP3

4.
danach die Zeit in Sekunden

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Falco2« (15.12.2008, 23:39)


  • »maettu« ist männlich

Beiträge: 3 299

Registrierungsdatum: 14.09.2005

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

3

15.12.2008, 23:40

dein Problem ist, du musst bei einer Ausführbaren-Datei die immer mit "./datei.sh" starten.
also so sollte es gehen:

Quellcode

1
thomas@thomas-desktop:~/Desktop/makevid$ ./makevid.py a-gasmask_71-humangame.mp3 gasmask.jpg 352

  • »Falco2« ist männlich

Beiträge: 378

Registrierungsdatum: 16.09.2008

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: EasyPeasy 1.6 = 10.04 -=- Linux Mint 17.3

  • Nachricht senden

4

15.12.2008, 23:48

interessant wäre ja noch das Script zu optimieren

1. Videoname = MP3 Name
2. Sekunden nicht vorgeben, sondern aus der MP3 entnehmen

hat da einer Ahnung ? 8)

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 104

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

5

15.12.2008, 23:49

@maettu,
laut Beispiel in der makevid.py muss zuerst das Bild, und dann die Audiodatei angegeben werden ;)

Greetz
wowi

  • »lazarus« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 20.11.2007

  • Nachricht senden

6

15.12.2008, 23:52

das hat sweit anscheind geklappt, herzlichsten dankschonmal

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
thomas@thomas-desktop:~/Desktop/makevid$ ./makevid.py humangame.mp3 gasmask.jpg 352
Starting mencoder
MEncoder 2:1.0~rc2-0ubuntu13 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) XP 3200+ (Family: 6, Model: 10, Stepping: 0)
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
success: format: 16  data: 0x0 - 0x0
MF file format detected.
[mf] search expr: humangame.mp3*
[mf] number of files: 1 (4)
[demux_mf] file type was not set! trying 'type=mp3'...
[demux_mf] unknown input file type.
============ Sorry, this file format is not recognized/supported =============
=== If this file is an AVI, ASF or MPEG stream, please contact the author! ===
Cannot open demuxer.

Exiting...
Video is complete, output written to output.avi
thomas@thomas-desktop:~/Desktop/makevid$


allerdings finde ich jetzt nirgendwo die output.avi?

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 104

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

7

15.12.2008, 23:56

Hi lazarus,

siehe meinen vorigen Post :D
Du musst das Bild und die Audiodatei in der Reihenfolge vertauschen! Also

Quellcode

1
./makevid.py gasmask.jpg humangame.mp3 352
sollte dann klappen :thumbsup:

Greetz
wowi

  • »lazarus« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 20.11.2007

  • Nachricht senden

8

15.12.2008, 23:57

@maettu,
laut Beispiel in der makevid.py muss zuerst das Bild, und dann die Audiodatei angegeben werden ;)

Greetz
wowi
dito das ist es!

  • »Falco2« ist männlich

Beiträge: 378

Registrierungsdatum: 16.09.2008

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: EasyPeasy 1.6 = 10.04 -=- Linux Mint 17.3

  • Nachricht senden

9

16.12.2008, 00:00

also wer lesen kann ist klar im Vorteil (habe ich mir sagen lassen ! ^^

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 104

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

10

16.12.2008, 00:00

Hi lazarus,

dann sei so nett und setze bitte in Deinem ersten Post noch ein [gelöst], dann sind wir alle zufrieden ;)

Greetz
wowi

  • »Falco2« ist männlich

Beiträge: 378

Registrierungsdatum: 16.09.2008

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: EasyPeasy 1.6 = 10.04 -=- Linux Mint 17.3

  • Nachricht senden

11

16.12.2008, 00:02

Hi lazarus,

dann sei so nett und setze bitte in Deinem ersten Post noch ein [gelöst], dann sind wir alle zufrieden ;)

Greetz
wowi


und was ist mit meiner Optimierung ? :whistling:

wowi

Ubuntu-Forum-Team

  • »wowi« ist männlich

Beiträge: 4 104

Registrierungsdatum: 03.05.2007

Derivat: Xubuntu

Architektur: 64-Bit PC

Desktop: XFCE

  • Nachricht senden

12

16.12.2008, 00:10

Hi Falco2,

die Optimierung hat mit der ursprünglichen Frage nichts zu tun. Das nennt sich übrigens neudeutsch Threadnapping, was Du gemacht hast und laut Forenregeln nicht erwünscht ist :D
Eröffne bitte dazu einen eigenen Thread!

Greetz
wowi

  • »Falco2« ist männlich

Beiträge: 378

Registrierungsdatum: 16.09.2008

Derivat: Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: EasyPeasy 1.6 = 10.04 -=- Linux Mint 17.3

  • Nachricht senden

13

16.12.2008, 00:17

na hoffentlich werde ich mal nicht verhaftet ? :rolleyes:

Threadnapping ? Nach so was mußte ja erstmal googeln :love:

  • »lazarus« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 20.11.2007

  • Nachricht senden

14

16.12.2008, 13:40

nochmals danke an alle für die super nette hilfe ;)