Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »kle-ben« ist männlich
  • »kle-ben« ist der Autor dieses Themas

Beiträge: 31

Registrierungsdatum: 28.04.2006

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

1

22.09.2008, 19:55

Mehrere Netzwerkkarten gleichzeitig nutzen.

Hi,

Ich hab in meinem Mainboard 2 Netzwerkkarten.

Zitat

*-network
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
logical name: eth0
version: 02
serial: 00:1f:d0:23:26:15
size: 100MB/s
capacity: 1GB/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.2LK duplex=full ip=192.168.178.20 latency=0 link=yes module=r8169 multicast=yes port=twisted pair speed=100MB/s
*-network
description: Ethernet interface
product: RTL8111/8168B PCI Express Gigabit Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:04:00.0
logical name: eth1
version: 02
serial: 00:1f:d0:23:26:25
size: 100MB/s
capacity: 1GB/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.2LK duplex=full ip=10.0.0.1 latency=0 link=yes module=r8169 multicast=yes port=twisted pair speed=100MB/s



Wenn ich allerdings beide an das selbe Netzwerk anschliese kommt der Rechner durcheinander und ich bekomme keinen Zugang mehr.
Ich will den zweiten Zugang eth1 für eine VM nutzen. Mein Host soll also weiterhin über eth0 Adapter mit dem Netzwerk kommunizieren
und meine VM soll über den eth1 Adapter an das Netz angebunden werden. Ich wollte nun erstmal testen ob das mit den beiden IPs klappt
die mein Rechner zugewiesen bekommt. VM ist also noch nciht aufgesetzt. Aber er scheint wohl damit schon durcheinander zu kommen.
Kann ich das irgendwo festlegen über welchern Adapter mein System gehen soll? Oder wie müsste ich den eth 2 Adapter evtl. umkonfigurieren
damit mein System nicht darauf zugreift.


Gruß Benny.
Theorie ist Wissen, das nicht funktioniert.
Praxis ist, wenn alles funktioniert und man weiß nicht warum

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »kle-ben« (22.09.2008, 23:58)


Beiträge: 6 679

Registrierungsdatum: 04.06.2005

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Arch Linux

  • Nachricht senden

2

22.09.2008, 20:19

Hallo,

ich weiss nicht ob das geht in einer vm (und dann noch in einem Netzwerksegment) aber die Einstellungen müssten doch was dazu hergeben.

m.f.g.
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

3

22.09.2008, 21:11

Hallo,

bitte nutze für das Posten von Quellcode und Datei-Auszügen künftig die Code-Tags (#-Zeichen über dem Textfenster). Gleiches gilt auch für Zitate (Sprechblase). Das erhöht die Lesbar- und Übersichtlichkeit des Threads und somit auch die Chancen, dass dir geholfen wird ;)

Danke.
~ Two hours of trial and error can save ten minutes of RTFM ~

  • »kle-ben« ist männlich
  • »kle-ben« ist der Autor dieses Themas

Beiträge: 31

Registrierungsdatum: 28.04.2006

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

4

23.09.2008, 00:03

ich weiss nicht ob das geht in einer vm (und dann noch in einem Netzwerksegment) aber die Einstellungen müssten doch was dazu hergeben.
Es soll nicht in einer VM laufen sondern auf dem host System.
Theorie ist Wissen, das nicht funktioniert.
Praxis ist, wenn alles funktioniert und man weiß nicht warum

5

23.09.2008, 00:30

Hi,
Ich wollte nun erstmal testen ob das mit den beiden IPs klappt die mein Rechner zugewiesen bekommt.
Über dhcp? Hast Du die Möglichkeit statische Adressen zu vergeben?
Poste bitte mal deine /etc/network/interfaces, sowie die Ausgabe von 'ifconfig -a' und 'ip route'

  • »kle-ben« ist männlich
  • »kle-ben« ist der Autor dieses Themas

Beiträge: 31

Registrierungsdatum: 28.04.2006

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

6

23.09.2008, 20:29

Ich kann leider keine statischen IPs über dhcp vergeben wobei meine Fritzbox eigenltich
automatisch immer die selbe IP zuordnet.

EDIT : So ich hab ncoh mal das statisch konfigurierte eth1 auf auto geschalten.
und die befehle noch mal ausgeführt.

/etc/network/interfaces

Zitat

auto lo
iface lo inet loopback

ifconfig -a

Zitat

eth0 Link encap:Ethernet Hardware Adresse 00:1f:d0:23:26:15
inet Adresse:192.168.178.20 Bcast:192.168.178.255 Maske:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
RX packets:27564 errors:0 dropped:468637911 overruns:0 frame:0
TX packets:25405 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:6932093 (6.6 MB) TX bytes:4286752 (4.0 MB)
Interrupt:219 Basisadresse:0x8000

eth1 Link encap:Ethernet Hardware Adresse 00:1f:d0:23:26:25
inet Adresse:192.168.178.19 Bcast:192.168.178.255 Maske:255.255.255.0
inet6-Adresse: fe80::21f:d0ff:fe23:2625/64 Gültigkeitsbereich:Verbindung
UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
RX packets:3803 errors:0 dropped:1524554454 overruns:0 frame:0
TX packets:701 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:564808 (551.5 KB) TX bytes:116066 (113.3 KB)
Interrupt:218 Basisadresse:0x4000

lo Link encap:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metrik:1
RX packets:25198 errors:0 dropped:0 overruns:0 frame:0
TX packets:25198 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:1259900 (1.2 MB) TX bytes:1259900 (1.2 MB)
ip route

Zitat

192.168.178.0/24 dev eth1 proto kernel scope link src 192.168.178.19
192.168.178.0/24 dev eth0 proto kernel scope link src 192.168.178.20
default via 192.168.178.1 dev eth0
default via 192.168.178.1 dev eth1
Und auch mal den von route:

Zitat

Kernel-IP-Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
192.168.178.0 * 255.255.255.0 U 0 0 0 eth1
192.168.178.0 * 255.255.255.0 U 0 0 0 eth0
default fritz.box 0.0.0.0 UG 0 0 0 eth0
default fritz.box 0.0.0.0 UG 0 0 0 eth1
Ich kann nun den eth1 eintrag löschen mit

route del default eth1

Dann scheint es zu funktionieren.
Zumindest kann ich mit
ping 192.168.178.1 -I eth1
meine Fritzbox pingen.
Kann ich das irgendwo eintragen das das automatisch gemacht wird?


Benny
Theorie ist Wissen, das nicht funktioniert.
Praxis ist, wenn alles funktioniert und man weiß nicht warum

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »kle-ben« (23.09.2008, 21:56)


Beiträge: 829

Registrierungsdatum: 02.08.2008

Architektur: 32-Bit PC

Andere Betriebssysteme: ArchLinux Overlord

  • Nachricht senden

7

23.09.2008, 20:41

Hallo, 2 Netzwerkinterfaces im selben Netz ist immer sehr problematisch. Woher soll denn der Rechner wissen, welches Interface er bei Verbindungen nehmen soll?? Beide kommen ja an dasselbe Gateway, weil es im selben Netz ist. Er kann auch nicht von den Hops unterscheiden. Das ist so, als würdest Du 2 gleichlange Wege zum selben Ziel haben.
Mal schauen, ob man da was zu finden kann. Im Moment würde ich es erstmal als nice-to-have ablegen und die VM über dasselbe Interface wie den Host gehen lassen.
Keine Ahnung, ob Du eth1 für den Host ausblenden kannst. Vor allem, was passiert, wenn die VM sich dann ihre IP nimmt/holt...interessant :)

Zitat

"We all know Linux is great...it does infinite loops in 5 seconds."
(Linus Torvalds about the superiority of Linux on the Amsterdam Linux Symposium)

8

23.09.2008, 22:09

Hi,
Klar ist, daß es ein ziemliches Chaos verursacht, wenn beide Schittstellen im selben Netz sind und den gleichen default GW haben.
Die einfachste Abhilfe wäre, das Netz zu teilen (subnetting). Für sowas gibt's sinnvolle Anwendungen, nur frag ich mich ob es für Deinen Zweck den Aufwand wert ist... Am Ende läuft ja alles wieder in der Fritzbox zusammen. Dein einziger Vorteil wäre zu wissen durch welches Kabel welches Byte tropft :D
Deine Idee, der einen Schnittstelle den Gateway wegzunehmen, wird Dir später die VM etwas übel nehmen... ;(
Irgendwie komm ich nicht dahinter, was genau Deine Beweggründe sind.

  • »kle-ben« ist männlich
  • »kle-ben« ist der Autor dieses Themas

Beiträge: 31

Registrierungsdatum: 28.04.2006

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

9

23.09.2008, 22:35

Ich will ein Host System das über eth0 ins Netzwerk geht und ein Virtuelle Maschine die über eth1 ins Netzwerk geht.
Eth1 ist nach dem ausschalten der default Route ja noch weiterhin verfügbar. ( Ping geht. )
Also sollte ich auch dann meine Virtuelle Maschine damit verbinden können. Ist leider noch nicht aufgesetzt.

Unter /etc/network / liegen diese ordner mit scripten

if-down.d
if-post-down.d
if-pre-up.d
if-up.d


Werden die scripte unter if-up.d aufgerufen sobald ein Gerät im Netzwerk registiret wurde?
Weil dann könnte ich da evtl. ein script hinterlegen was die defaultroute ausschaltet.

Zitat

Deine Idee, der einen Schnittstelle den Gateway wegzunehmen, wird Dir später die VM etwas übel nehmen...
Kann ich das Gateway dann nicht unt ereinem anderen Namen als default eintragen?
Theorie ist Wissen, das nicht funktioniert.
Praxis ist, wenn alles funktioniert und man weiß nicht warum

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »kle-ben« (23.09.2008, 22:38)


10

23.09.2008, 22:36

Ich finde das Ganze ebenfalls ein wenig unsinnig.

Hättest du mehrere Netze bei dir zuhause, würde das Sinn ergeben, aber so eher nicht. :)

Grüße, euer
Ovim-Obscurum ;)

11

23.09.2008, 23:06

ein Host System das über eth0 ins Netzwerk geht und ein Virtuelle Maschine [...]
Das hab ich im ersten posting gelesen und verstanden. Ich weiß nur nicht welchen Zweck das hat?

Eth1 ist nach dem ausschalten der default Route ja noch weiterhin verfügbar. ( Ping geht. )
Nur weil sie kein Gateway hat, geht sie noch nicht verloren. Erst wenn Du sie ausschaltest. Und: ping geht... von wo wohin? Innerhalb der Netzwerks braucht sie kein Gateway, und erreichbar ist sie von da auch.

Werden die scripte unter if-up.d aufgerufen sobald ein Gerät im Netzwerk registiret wurde?
Wenn eine Schnittstelle aktiviert wird. zB mit ifup oder ifconfig <ip> up.

Weil dann könnte ich da evtl. ein script hinterlegen was die defaultroute ausschaltet.
Natürlich kann man da herumspielen, der normale Weg wäre allerdings, erst gar kein Gateway in die Config einzutragen. Mit DHCP wird das aber nix werden, und ein script-gesteuertes entfernen des GW hält maximal bis zum nächsten lease-update.

Wenn Du irgendwas bestimmtes erreichen willst, und das mit den getrennten Schnittstellen Deine Idee dazu war, dann verrate uns doch einfach was Du haben möchtest. Vielleicht verstehen wir dann den Sinn und kennen eine entsprechende Lösung. Aber so dreht sich das im Kreise.

  • »kle-ben« ist männlich
  • »kle-ben« ist der Autor dieses Themas

Beiträge: 31

Registrierungsdatum: 28.04.2006

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

12

24.09.2008, 08:08

Vielleicht verstehen wir dann den Sinn und kennen eine entsprechende Lösung.
Naja es geht mit einfach nur darum das die VM über die andere Karte ins Netzwerk geht.
In der VM Solle ein Server laufen und wenn er über ein eigenes Netzwerkinterface angebunden ist
wäre das einfach sauberer. Z.B wenn man den Traffic loggt etc. .Wenn man schon 2 Interfaces
hat muss man die doch auch irgendwie nutzen können. Mehr Sinn steckt nicht dahinter.


Benny
Theorie ist Wissen, das nicht funktioniert.
Praxis ist, wenn alles funktioniert und man weiß nicht warum

13

24.09.2008, 10:01

Hallo,

auf Grund fehlender Hardware kann ich das Ganze zwar nicht praktisch nachvollziehen, allerdings gibts in VirtualBox die Möglichkeit, in den Netzwerkeinstellungen auszuwählen, dass er das Hostinterface nutzen soll (klar :) ). Dabei kann man dann auch auswählen, welches Hostinterface er genau nehmen soll.
~ Two hours of trial and error can save ten minutes of RTFM ~

14

24.09.2008, 13:34

Hi,
In der VM Solle ein Server laufen
Das macht natürlich schon Sinn, auch wenn sich das traffic-logging über eine per NAT angebundene VM auch realisieren ließe. Aber wenn Du die 2. Schnittstelle sonst nicht benötigst...
Wie gesagt, DHCP müsste zumindest für diese Schnittstelle ausgeschaltet sein. Stattdessen wird über /etc/network/interfaces eine statische IP vergeben, und kein Gateway eingetragen. Der Server antwortet sowieso über die Schnittstelle von der die Anfrage kam.
Die Fritzbox muß natürlich statische IPs erlauben, und entsprechendes portforwarding muß aktiviert sein.
Ein anderer Weg wäre, diese Schnittstelle auf der Fritzbox in die DMZ zu stellen, dafür wäre aber dann wieder DHCP nötig und Du könntest wieder nur diese eine ohne Netzwerk-Chaos verwenden. Wäre mir aber zu unsicher.

  • »kle-ben« ist männlich
  • »kle-ben« ist der Autor dieses Themas

Beiträge: 31

Registrierungsdatum: 28.04.2006

Derivat: Ubuntu

Architektur: 64-Bit PC

  • Nachricht senden

15

24.09.2008, 19:57

Also ich hab jetzt mal mit VMWare eine Maschine eingerichtet der ich das eth1 Interface zugeordnet hab.
Hab sie mit bridged routing konfiguriert. Sie liegt jetzt direkt in meinem Netz und bekommt eine eigene
IP Adresse vom Router zugewiesen. Mein eth1 hab ich auf meinem host nun mal statisch in ein anderes
Subnetz gelgt. Somit komme von meinem Host immer über eth0 ins Netz und meine VM bezieht sich über
den eth1 Adapter eine Eigene IP Adresse.
Theorie ist Wissen, das nicht funktioniert.
Praxis ist, wenn alles funktioniert und man weiß nicht warum