Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

hogy

User

  • »hogy« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 17.09.2008

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

18.09.2008, 20:24

Kein Internet seit Proxyverbindung

Hallo zusammen. habe folgendes Problem:
Ich habe heute heute in der Schule mein Laptop Ubuntu 8.0.4 per Kabel ans Netzwerk gehägt, in den Einstellungen/Netzwerk-Proxy die Daten zum Proxy eingegeben. Hat alles wunderbar funktioniert. Als ich am Abend zuhause über das Wlan ins intetnet wollte, verweigerte mit der PC die verbindung. Habe die Proxyeinstellung natürlich wider auf direkt umgestellt. Auch den Router konnte ich über den Firefox erreichen (ja da hab ich die einstellungen auch schon überprüft) Schon versucht: - über Kabel verbunden kein resultat - Ich kann den router anpingen alles andere nicht - Statische IP vergeben bringt auch nix (Standartmäsig DHCP des Router) - PC erhält eine IP, Subnetzmaske und Standartgateway ohne probleme
kann mir jemand helfen?

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
lspci   | grep -i net
06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
06:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

lsusb
Bus 005 Device 004: ID 3538:0055 Power Quotient International Co., Ltd 
Bus 005 Device 003: ID 1058:1100 Western Digital Technologies, Inc. 
Bus 005 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 001: ID 0000:0000  
Bus 002 Device 001: ID 0000:0000  
Bus 001 Device 004: ID 046d:c01e Logitech, Inc. MX518 Optical Mouse
Bus 001 Device 001: ID 0000:0000  

/etc/hosts
127.0.0.1   	localhost
127.0.1.1   	hogy-laptop

# The following lines are desirable for IPv6 capable hosts
::1 	ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


resolv.conf

### BEGIN INFO
#
# Modified_by:  NetworkManager
# Process:  	/usr/bin/NetworkManager
# Process_id:   4656
#
### END INFO



nameserver 192.168.1.1

interfaces


##loopback
auto lo
iface lo inet loopback

##LAN
auto eth0
iface eth0 inet dhcp

##WLAN
auto eth1


ifconfig
eth0  	Link encap:Ethernet  Hardware Adresse 00:16:d3:40:a2:35  
      	UP BROADCAST MULTICAST  MTU:1500  Metrik:1
      	RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      	TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      	Kollisionen:0 Sendewarteschlangenlänge:1000 
      	RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
      	Interrupt:22 Basisadresse:0x3000 

eth1  	Link encap:Ethernet  Hardware Adresse 00:16:6f:9d:08:86  
      	inet Adresse:192.168.1.38  Bcast:192.168.1.255  Maske:255.255.255.0
      	inet6-Adresse: fe80::216:6fff:fe9d:886/64 Gültigkeitsbereich:Verbindung
      	UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
      	RX packets:450 errors:1 dropped:1 overruns:0 frame:0
      	TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
      	Kollisionen:0 Sendewarteschlangenlänge:1000 
      	RX bytes:33825 (33.0 KB)  TX bytes:13785 (13.4 KB)
      	Interrupt:17 Basisadresse:0xc000 Speicher:b0100000-b0100fff 

lo    	Link encap:Lokale Schleife  
      	inet Adresse:127.0.0.1  Maske:255.0.0.0
      	inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
      	UP LOOPBACK RUNNING  MTU:16436  Metrik:1
      	RX packets:6096 errors:0 dropped:0 overruns:0 frame:0
      	TX packets:6096 errors:0 dropped:0 overruns:0 carrier:0
      	Kollisionen:0 Sendewarteschlangenlänge:0 
      	RX bytes:388680 (379.5 KB)  TX bytes:388680 (379.5 KB)

 route -n
Kernel-IP-Routentabelle
Ziel        	Router      	Genmask     	Flags Metric Ref	Use Iface
192.168.1.0 	0.0.0.0     	255.255.255.0   U 	0  	0    	0 vmnet1
192.168.1.0 	0.0.0.0     	255.255.255.0   U 	0  	0    	0 eth1
192.168.202.0   0.0.0.0     	255.255.255.0   U 	0  	0    	0 vmnet8
169.254.0.0 	0.0.0.0     	255.255.0.0 	U 	1000   0    	0 eth1




iwconfig
eth1  	IEEE 802.11g  ESSID:"Vaz/Berchtold"  
      	Mode:Managed  Frequency:2.462 GHz  Access Point: 00:14:C1:28:67:C8   
      	Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
      	Retry limit:7   RTS thr:off   Fragment thr:off
      	Encryption key:7082-D81A-C599-B503-D118-C7D4-9C0C-0CBD-04A9-8D59-A97A-E219-BF50-5889-8C27-EC02   Security mode:open
      	Power Management:off
      	Link Quality=91/100  Signal level=-38 dBm  Noise level=-87 dBm
      	Rx invalid nwid:0  Rx invalid crypt:1  Rx invalid frag:0
      	Tx excessive retries:0  Invalid misc:0   Missed beacon:1

würde es vielleicht etwas bringen ihn nochmals an den proxy zu hängen?

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »hogy« (18.09.2008, 20:24)


Beiträge: 829

Registrierungsdatum: 02.08.2008

Architektur: 32-Bit PC

Andere Betriebssysteme: ArchLinux Overlord

  • Nachricht senden

2

18.09.2008, 20:29

Was sagt denn ein

Quellcode

1
echo $http_proxy
Gibt er Dir da was aus?
Dann mal einen

Quellcode

1
unset http_proxy

Zitat

"We all know Linux is great...it does infinite loops in 5 seconds."
(Linus Torvalds about the superiority of Linux on the Amsterdam Linux Symposium)

3

18.09.2008, 20:50

Hi,
Offenbar ist von der Schule noch was in der routing-Tabelle zurückgeblieben:
Kernel-IP-Routentabelle Ziel Router Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 vmnet1
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1

Wenn Du das Kabel momentan nicht brauchst, geht's am schnellsten so:

Quellcode

1
2
sudo ifconfig eth0 down
sudo route add default gw 192.168.1.0

Oder auch per Network-Manager die eth0 ausschalten.
CU

hogy

User

  • »hogy« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 17.09.2008

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

4

19.09.2008, 08:39

Was sagt denn ein

Quellcode

1
echo $http_proxy
Gibt er Dir da was aus?
Dann mal einen

Quellcode

1
unset http_proxy


echo $http_proxy
nichts ausser einer neuen linie
unset http_proxy
ebenfalls nur eine neue linie



Hi,
Offenbar ist von der Schule noch was in der routing-Tabelle zurückgeblieben:


Kernel-IP-Routentabelle Ziel Router Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 vmnet1
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1

Wenn Du das Kabel momentan nicht brauchst, geht's am schnellsten so:

Quellcode

1
2
sudo ifconfig eth0 down 
sudo route add default gw 192.168.1.0

Oder auch per Network-Manager die eth0 ausschalten.
CU




das heisst in meinem fall 192.168.1.1? da der router auf dieser IP ist? oder trotzdem .0?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hogy« (19.09.2008, 08:39)


Beiträge: 6 679

Registrierungsdatum: 04.06.2005

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Arch Linux

  • Nachricht senden

5

19.09.2008, 11:42

Hallo,

nun die .0 darf es auf keinen Fall sein. Da die .0 und die .255 nicht als Client IP benutzbar sind.

die .0 klassifiziert das gesamte Netz
die .255 die Broadcast Adresse

m.f.g.
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

hogy

User

  • »hogy« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 17.09.2008

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

6

19.09.2008, 11:45

also doch .1? sprich ip des router?

bigredeyes

unregistriert

7

19.09.2008, 12:16

ja, nimm die 1. also ip vom router.
hast du vielleicht den proxy im firefox eingetragen?
klappt ein

Quellcode

1
wget http://www.ubuntu-forum.de
?

bigredeyes

hogy

User

  • »hogy« ist der Autor dieses Themas

Beiträge: 4

Registrierungsdatum: 17.09.2008

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

8

19.09.2008, 13:04


hast du vielleicht den proxy im firefox eingetragen?
ganz sicher nicht;)

9

19.09.2008, 17:21

Und was ist jetzt mit der anderen Geschichte, die bigredeyes vorschlug?

Bei route -n wird kein Gateway angezeigt. Afaik sollte da das Flag "UG" gesetzt sein.

Sollte so aussehen:

Quellcode

1
2
3
4
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface

0.0.0.0       192.168.1.1   0.0.0.0            UG    0      0        0      eth1