Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »scratch« ist männlich
  • »scratch« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 06.07.2008

Derivat: Kubuntu

Architektur: 32-Bit PC

Desktop: KDE3

  • Nachricht senden

1

06.07.2008, 20:36

[erledigt] upgrade 6.06 -> 8.04 dpkg returned error code

Hallo habe einen Upgrage von 6.06 -> 8.04 versucht. Leider war alternate CD defekt, so dass upgrade nicht geklappt hat (leider kein md5sum gemacht!). Konsole funktioniert, jedoch kein WM.
Habe veschiedene Problembehandlungen versucht,
apt-get update
apt get upgrade
apt-get install x-server
apt-get install Xorg
dpkg -reconfigure xserver-xorg
weil ich dachte es wäre ein Xserver Peoblem
bin aber nicht viel weiter gekommen.

Bei apt-get install -f erhalte ich folgende (gekürzte Ausgabe, weil ich keine ahnung habe, wie ich den Text in der shell kopieren kann oder in welchem log File er steckt):
"unpacking python-sip4
dpkg error processing (mit Pfadangabe alternate CD)
trying to overwrite /usr/lib/python2.4 etc.
dpkg-deb:subprocess paste killed by signal (Broken pipe)"
und
"unpacking python-qt3
dpkg error processing (mit Pfadangabe alternate CD)
trying to overwrite /usr/lib/python-qt3 etc.
dpkg-deb:subprocess paste killed by signal (Broken pipe)"
errors were en?? whole processing
/cdrom/pool/main/s/sip4-qt3/python-sip4_4.7.3-1ubuntu2_i386.deb
/cdrom/pool/main/p/python-qt3/python-qt3_3.17.4-1ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ich habe das Gefühl, dass hier irgendwelche Upgrades nicht so wollen, wie sie sollen ?(
Hat einer 'ne Idee, wie ich das Problem lösen kann?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »scratch« (20.07.2008, 23:04)


2

06.07.2008, 20:43

Ohje, warum macht man sowas? Ein Upgrade, auch noch von 6.06 auf 8.04 - das kann nicht funktionieren.
Schau dich mal im Forum um, da findest du ständig solche Probleme. Upgrades taugen leider gar nichts unter Ubuntu, das ist zumindest meine persönliche Meinung. ;(

Hatte das selbe auch mal von Breezy auf Dapper. Da ging nichts mehr..

Sorry, aber ich sehe da, nach dem, was du selbst schon probiert hast, keinen anderen Weg mehr, als neu zu installieren.. :wacko:

Grüße, euer
Ovim-Obscurum ;)

J-B

User

Beiträge: 381

Registrierungsdatum: 25.05.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

3

06.07.2008, 21:19

http://www.ubuntu.com/getubuntu/upgrading

-> Upgrade from 6.06 LTS to 8.04 LTS

Hast du das so mal probiert?

Bei mir funktionieren die Updates immer prächtig!
Laptop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo T7500 2,20 GHz RAM: 3072 MB Festplatte: 160 GB Modell: Dell XPS M1330

Desktop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo 6550 2,33 GHz RAM: 4096 MB Festplatte: 80 GB

4

06.07.2008, 21:22

Natürlich ausprobiert, hat bei mir noch nie funktioniert.

Grüße, euer
Ovim-Obscurum ;)

J-B

User

Beiträge: 381

Registrierungsdatum: 25.05.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

5

06.07.2008, 21:35

Natürlich ausprobiert, hat bei mir noch nie funktioniert.
Da nicht du den Thread eröffnet hast, war der Beitrag von eben nicht an dich gedacht. Das bei dir die Upgrades nicht klappen hast du schon oft genug geschrieben :)
Laptop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo T7500 2,20 GHz RAM: 3072 MB Festplatte: 160 GB Modell: Dell XPS M1330

Desktop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo 6550 2,33 GHz RAM: 4096 MB Festplatte: 80 GB

  • »scratch« ist männlich
  • »scratch« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 06.07.2008

Derivat: Kubuntu

Architektur: 32-Bit PC

Desktop: KDE3

  • Nachricht senden

6

06.07.2008, 21:55

Danke für die Antworten.
@J-B: ja, habe ich probiert. Das Problem wird aber die fehlerhafte CD gewesen sein.
@Ovim-Osbscurum: du baus mich vielleicht auf, genau das wollte ich ja mit dem upgrade vermeiden.
Habe inzwischen noch ein "deselect install" versucht, hat aber auch nichts genutzt.
Hier noch ein Auszug aus dpkg.log, vielleicht hilft das ja jemanden.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
2008-07-06 21:15:38 startup packages configure
2008-07-06 21:15:38 configure xfonts-scalable 1:1.0.0-6 1:1.0.0-6
2008-07-06 21:15:38 status half-configured xfonts-scalable 1:1.0.0-6
2008-07-06 21:20:01 startup archives unpack
2008-07-06 21:20:01 install python-sip4 <none> 4.7.3-1ubuntu2
2008-07-06 21:20:01 status half-installed python-sip4 4.7.3-1ubuntu2
2008-07-06 21:20:01 status not-installed python-sip4 <none>
2008-07-06 21:20:01 upgrade python-qt3 3.15.1-0ubuntu3 3.17.4-1ubuntu4
2008-07-06 21:20:01 status half-configured python-qt3 3.15.1-0ubuntu3
2008-07-06 21:20:01 status unpacked python-qt3 3.15.1-0ubuntu3
2008-07-06 21:20:01 status half-installed python-qt3 3.15.1-0ubuntu3
2008-07-06 21:20:01 status unpacked python-qt3 3.15.1-0ubuntu3
2008-07-06 21:20:01 status installed python-qt3 3.15.1-0ubuntu3

7

06.07.2008, 22:03

Oftmals hängts an zwei Faktoren, wenn ein Update schief geht:

Entweder versucht man das Update zu früh (Beta-Stadium) oder hat vorher das entsprechende *ubuntu-desktop-Paket entfernt (sprich eines der Pakete aus dem Meta-Paket). Aber auch andere Sachen können da eine Rolle spielen:

In der Regel kann man das ausprobieren, sollte aber Vorkehrungen treffen, wenn es nich erfolgreich ist -> Wiki-Artikel

So richtig passt das aber alles in die Ecke: Hättest du mal lieber!

Wenn ich deine Fehlermeldung richtig interpretiere, dann hast du dein CD-ROM noch als Paketquelle eingestellt - nimm das mal raus.
~ Two hours of trial and error can save ten minutes of RTFM ~

  • »scratch« ist männlich
  • »scratch« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 06.07.2008

Derivat: Kubuntu

Architektur: 32-Bit PC

Desktop: KDE3

  • Nachricht senden

8

06.07.2008, 23:36

Hallo zero 77
danke für den Tip
ich habe die CD-Rom aus der Source list auskommentiert.
Resultat war, dass es anscheinend irgendwelche Probleme mit dem firefox Paket gibt???
Problematik vielleicht, dass ich Firefox 2.0 händisch beim 6.06 installiert habe und die Updates vom 1.5015 immer verworfen habe (dito Thunderbird)

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
2008-07-06 22:40:05 startup packages remove
diverse Meldungen wie unten (hab's mal ein wenig verkürzt
2008-07-06 22:40:45 status half-installed khelpcenter 4:3.5.2-0ubuntu27.4
2008-07-06 22:40:51 status config-files language-support-en 1:6.06+20060529
2008-07-06 22:40:51 status config-files language-support-en 1:6.06+20060529
2008-07-06 22:40:51 status installed thunderbird-locale-en-gb 1:2.0.0.0+1-0ubuntu1
2008-07-06 22:40:51 remove thunderbird-locale-en-gb 1:2.0.0.0+1-0ubuntu1 1:2.0.0.0+1-0ubuntu1
2008-07-06 22:40:51 status half-configured thunderbird-locale-en-gb 1:2.0.0.0+1-0ubuntu1
2008-07-06 22:40:51 status half-installed thunderbird-locale-en-gb 1:2.0.0.0+1-0ubuntu1
2008-07-06 22:40:51 status config-files thunderbird-locale-en-gb 1:2.0.0.0+1-0ubuntu1
2008-07-06 22:40:51 status config-files thunderbird-locale-en-gb 1:2.0.0.0+1-0ubuntu1
2008-07-06 22:40:51 status config-files thunderbird-locale-en-gb 1:2.0.0.0+1-0ubuntu1
2008-07-06 22:40:51 status not-installed thunderbird-locale-en-gb <none>
2008-07-06 22:40:51 status unpacked openoffice.org-help-en-us 1:2.4.1-1ubuntu2
2008-07-06 22:40:51 remove openoffice.org-help-en-us 1:2.4.1-1ubuntu2 1:2.4.1-1ubuntu2
2008-07-06 22:40:51 status half-installed openoffice.org-help-en-us 1:2.4.1-1ubuntu2
2008-07-06 22:40:51 status config-files openoffice.org-help-en-us 1:2.4.1-1ubuntu2
2008-07-06 22:40:51 status config-files openoffice.org-help-en-us 1:2.4.1-1ubuntu2
2008-07-06 22:40:51 status config-files openoffice.org-help-en-us 1:2.4.1-1ubuntu2
2008-07-06 22:40:51 status not-installed openoffice.org-help-en-us <none>
2008-07-06 22:40:51 status unpacked openoffice.org-l10n-en-gb 1:2.4.1-1ubuntu2
2008-07-06 22:40:51 remove openoffice.org-l10n-en-gb 1:2.4.1-1ubuntu2 1:2.4.1-1ubuntu2
2008-07-06 22:40:51 status half-installed openoffice.org-l10n-en-gb 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 status config-files openoffice.org-l10n-en-gb 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 status config-files openoffice.org-l10n-en-gb 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 status config-files openoffice.org-l10n-en-gb 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 status not-installed openoffice.org-l10n-en-gb <none>
2008-07-06 22:40:52 status unpacked openoffice.org-l10n-en-za 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 remove openoffice.org-l10n-en-za 1:2.4.1-1ubuntu2 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 status half-installed openoffice.org-l10n-en-za 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 status config-files openoffice.org-l10n-en-za 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 status config-files openoffice.org-l10n-en-za 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 status config-files openoffice.org-l10n-en-za 1:2.4.1-1ubuntu2
2008-07-06 22:40:52 status not-installed openoffice.org-l10n-en-za <none>
2008-07-06 22:40:52 status installed amarok-xine 2:1.4.3-0ubuntu8~dapper1
2008-07-06 22:40:52 remove amarok-xine 2:1.4.3-0ubuntu8~dapper1 2:1.4.3-0ubuntu8~dapper1
2008-07-06 22:40:52 status half-configured amarok-xine 2:1.4.3-0ubuntu8~dapper1
2008-07-06 22:40:52 status half-installed amarok-xine 2:1.4.3-0ubuntu8~dapper1
2008-07-06 22:40:52 status config-files amarok-xine 2:1.4.3-0ubuntu8~dapper1
2008-07-06 22:40:52 status config-files amarok-xine 2:1.4.3-0ubuntu8~dapper1
2008-07-06 22:40:52 status config-files amarok-xine 2:1.4.3-0ubuntu8~dapper1
2008-07-06 22:40:52 status not-installed amarok-xine <none>
2008-07-06 22:40:52 status installed libkcal2b 4:3.5.2-0ubuntu6
2008-07-06 22:40:52 remove libkcal2b 4:3.5.2-0ubuntu6 4:3.5.2-0ubuntu6
2008-07-06 22:40:52 status half-configured libkcal2b 4:3.5.2-0ubuntu6
2008-07-06 22:40:52 status half-installed libkcal2b 4:3.5.2-0ubuntu6
2008-07-06 22:40:52 status config-files libkcal2b 4:3.5.2-0ubuntu6
2008-07-06 22:40:52 status config-files libkcal2b 4:3.5.2-0ubuntu6
2008-07-06 22:40:52 status installed libktnef1 4:3.5.2-0ubuntu6
2008-07-06 22:40:52 remove libktnef1 4:3.5.2-0ubuntu6 4:3.5.2-0ubuntu6
2008-07-06 22:40:52 status half-configured libktnef1 4:3.5.2-0ubuntu6
2008-07-06 22:40:52 status half-installed libktnef1 4:3.5.2-0ubuntu6
2008-07-06 22:40:53 status config-files libktnef1 4:3.5.2-0ubuntu6
2008-07-06 22:40:53 status config-files libktnef1 4:3.5.2-0ubuntu6
2008-07-06 22:40:53 status installed kaffeine-xine 0.7.1-1.3ubuntu10
2008-07-06 22:40:53 remove kaffeine-xine 0.7.1-1.3ubuntu10 0.7.1-1.3ubuntu10
2008-07-06 22:40:53 status half-configured kaffeine-xine 0.7.1-1.3ubuntu10
2008-07-06 22:40:53 status half-installed kaffeine-xine 0.7.1-1.3ubuntu10
2008-07-06 22:40:53 status config-files kaffeine-xine 0.7.1-1.3ubuntu10
2008-07-06 22:40:53 status config-files kaffeine-xine 0.7.1-1.3ubuntu10
2008-07-06 22:40:53 status config-files kaffeine-xine 0.7.1-1.3ubuntu10
2008-07-06 22:40:53 status not-installed kaffeine-xine <none>
2008-07-06 22:40:53 status unpacked kdelibs4c2a 4:3.5.9-0ubuntu7.1
2008-07-06 22:40:53 remove kdelibs4c2a 4:3.5.9-0ubuntu7.1 4:3.5.9-0ubuntu7.1
2008-07-06 22:40:53 status half-installed kdelibs4c2a 4:3.5.9-0ubuntu7.1
2008-07-06 22:40:53 status config-files kdelibs4c2a 4:3.5.9-0ubuntu7.1
2008-07-06 22:40:53 status config-files kdelibs4c2a 4:3.5.9-0ubuntu7.1
2008-07-06 22:40:53 trigproc libc6 2.7-10ubuntu3 2.7-10ubuntu3
2008-07-06 22:40:53 status half-configured libc6 2.7-10ubuntu3
2008-07-06 22:40:54 status installed libc6 2.7-10ubuntu3
2008-07-06 22:40:54 startup archives unpack
2008-07-06 22:40:54 upgrade firefox 1.5.dfsg+1.5.0.12-0ubuntu0.6.06.1 1.5.dfsg+1.5.0.15~prepatch080614c-0ubuntu1
2008-07-06 22:40:54 status half-configured firefox 1.5.dfsg+1.5.0.12-0ubuntu0.6.06.1
2008-07-06 22:40:54 status unpacked firefox 1.5.dfsg+1.5.0.12-0ubuntu0.6.06.1
2008-07-06 22:40:54 status half-installed firefox 1.5.dfsg+1.5.0.12-0ubuntu0.6.06.1
2008-07-06 22:40:55 status unpacked firefox 1.5.dfsg+1.5.0.12-0ubuntu0.6.06.1
2008-07-06 22:40:55 status installed firefox 1.5.dfsg+1.5.0.12-0ubuntu0.6.06.1
2008-07-06 22:40:55 install libsasl2-modules-sql <none> 2.1.19.dfsg1-0.1ubuntu2
2008-07-06 22:40:55 status half-installed libsasl2-modules-sql 2.1.19.dfsg1-0.1ubuntu2
2008-07-06 22:40:55 status unpacked libsasl2-modules-sql 2.1.19.dfsg1-0.1ubuntu2
2008-07-06 22:40:55 status unpacked libsasl2-modules-sql 2.1.19.dfsg1-0.1ubuntu2


Das ist die aktuelle dpkg.log von diesem Versuch. Vielleicht hilft das ja.
Gruss Thomas

  • »skummy« ist männlich

Beiträge: 677

Registrierungsdatum: 08.07.2007

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

9

07.07.2008, 10:00

Die Konsolenausgaben von 'sudo apt-get install -f' wären interessanter.
Gruß,
Sandro

Intel Core 2 Duo E4400 2.0 GHZ @ 2,5 GHZ | ASUS P5N-E SLI nForce650i SLI | Geforce 7900GT@530MHZ/750MHZ | 2 GB Aeneon PC800 | be quiet Straight Power BQT E5-450W | Linux Know-How: http://www.skummy.de

  • »scratch« ist männlich
  • »scratch« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 06.07.2008

Derivat: Kubuntu

Architektur: 32-Bit PC

Desktop: KDE3

  • Nachricht senden

10

11.07.2008, 22:26

Hallo und sorry für den Unterbruch. War 3 Tage beruflich aus dem Rennen.
Wie bekomme ich die Konsolenausgabe in den Griff? alles abschreiben oder gibt es einen Trick oder einen "Konsolen.log" wo ich die Ausgabe kopieren kann? Wie kann ich in der Konsole wieder nach oben blättern. Bin da doch noch in den Kinderschuhen :S . Gruss Thomas

J-B

User

Beiträge: 381

Registrierungsdatum: 25.05.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

11

11.07.2008, 22:48

Quellcode

1
sudo apt-get install -f > log.txt


Damit wird die Ausgabe davon in die Datei log.txt gesichert. Diese kannst du uns dann zur Verfügung stellen.
Laptop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo T7500 2,20 GHz RAM: 3072 MB Festplatte: 160 GB Modell: Dell XPS M1330

Desktop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo 6550 2,33 GHz RAM: 4096 MB Festplatte: 80 GB

  • »scratch« ist männlich
  • »scratch« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 06.07.2008

Derivat: Kubuntu

Architektur: 32-Bit PC

Desktop: KDE3

  • Nachricht senden

12

12.07.2008, 14:27

Danke für den Tip J-B. Hier also die Konsolenmeldungen

Quellcode

1
2
3
4
5
6
7
Reading package lists...
Building dependency tree...
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up xfonts-scalable (1:1.0.0-6) ...

Was jedoch da nicht drin steht ist folgender Nachsatz:

Quellcode

1
2
3
4
dpkg: error processing xfonts-scalable (--configure):
sup process post-installation script returned error exit status (2)
Errors were encountered while processing: xfonts-scalable
E: Sub-process /usr/bin/dpkg returned an error code

Und hier noch zur Vervollständigung die sources.list, die identisch ist mit der sources.list.distUpgrade

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
deb-src http://de.archive.ubuntu.com/ubuntu/ dapper main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://de.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ dapper-updates main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://archive.ubuntu.com/ubuntu/ dapper universe main restricted
deb-src http://de.archive.ubuntu.com/ubuntu/ dapper universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://de.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe

deb http://archive.ubuntu.com/ubuntu/ dapper universe multiverse
deb cdrom:[Kubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/ hardy main restricted
deb cdrom:[Kubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/ hardy main restricted

Komischerweise wird die CD jetzt nicht mehr verlangt bei apt-get install -f
Hilft dies weiter?
Gruss Thomas

J-B

User

Beiträge: 381

Registrierungsdatum: 25.05.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

13

12.07.2008, 16:52

Hast du Internet? Oder willst du ein Update via CD machen?
Laptop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo T7500 2,20 GHz RAM: 3072 MB Festplatte: 160 GB Modell: Dell XPS M1330

Desktop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo 6550 2,33 GHz RAM: 4096 MB Festplatte: 80 GB

  • »scratch« ist männlich
  • »scratch« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 06.07.2008

Derivat: Kubuntu

Architektur: 32-Bit PC

Desktop: KDE3

  • Nachricht senden

14

12.07.2008, 17:50

Spielt keine Rolle, habe auch den funktionierenden Internet anschluss
Gruss

J-B

User

Beiträge: 381

Registrierungsdatum: 25.05.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

15

12.07.2008, 18:07

Mach mal folgendes:

Quellcode

1
sudo aptitude purge xfonts-scalable


Danach entfernst du die CD Einträge

Quellcode

1
2
deb cdrom:[Kubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/ hardy main restricted
deb cdrom:[Kubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/ hardy main restricted


Danach

Quellcode

1
2
sudo aptitude update
sudo aptitude install xfonts-scalable


Nachdem bitte testen, ob ein

Quellcode

1
sudo aptitude update && sudo aptitude upgrade


fehlerfrei ist.

Danach machen wir weiter ...
Laptop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo T7500 2,20 GHz RAM: 3072 MB Festplatte: 160 GB Modell: Dell XPS M1330

Desktop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo 6550 2,33 GHz RAM: 4096 MB Festplatte: 80 GB

  • »scratch« ist männlich
  • »scratch« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 06.07.2008

Derivat: Kubuntu

Architektur: 32-Bit PC

Desktop: KDE3

  • Nachricht senden

16

12.07.2008, 22:21

Tja, ist wohl ein Problem. Also nach
"aptitude purge xfonts-scalable" erhalte ich

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
The following packages have been kept back
bind9-host dnsutils firefox libbind9-0 libdns21 libisc11 libisccc0 libisccfg1 liblwres 9
The following packages will be removed
xfonts-scalables{p}
...
Removing xfonts-scalables...
usage error: unrecognized option
usage: updat-fonts-dir DIRECTORY...
...
dpkg: error processing xfonts-scalables (--purge): subprocess post-removed script returned error status 2
Errors were encountered while processing:
xfonts-scalable
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install: Trying to recover

"aptitude update" läuft ohne Fehlermeldung
"aptitude install xfonts-scalable" bringt folgendes

Quellcode

1
2
3
4
5
6
The following packages have been kept back
bind9-host dnsutils firefox libbind9-0 libdns21 libisc11 libisccc0 libisccfg1 liblwres 9
Writing extended state information...Error!
E: I wasn't to locate file for xfonts-scalable package
This might mean to manually fix this package
E: Couldn't lock list directory...are you root?

root bin ich, weil ich im recovery mode aufgestartet habe.
Jetzt bin ich gleich schlau wie vorher, du aber hoffentlich schlauer
Gruss Thomas

J-B

User

Beiträge: 381

Registrierungsdatum: 25.05.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

17

12.07.2008, 22:30

Mal ein

Quellcode

1
aptitude reinstall xfonts-scalables


Probiert?
Laptop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo T7500 2,20 GHz RAM: 3072 MB Festplatte: 160 GB Modell: Dell XPS M1330

Desktop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo 6550 2,33 GHz RAM: 4096 MB Festplatte: 80 GB

  • »scratch« ist männlich
  • »scratch« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 06.07.2008

Derivat: Kubuntu

Architektur: 32-Bit PC

Desktop: KDE3

  • Nachricht senden

18

12.07.2008, 23:15

"aptitude reinstall xfonts-scalable" bringt:

Quellcode

1
2
3
4
5
6
7
8
The following packages have been kept back
bind9-host dnsutils firefox libbind9-0 libdns21 libisc11 libisccc0 libisccfg1 liblwres 9
The following packages will be reinstalled
xfonts-scalable
0 packages upgraded, 0newly installed, 0 to remove, and 9 not upgraded
E: I wasn't able to locate file for xfonts-scalable package
This might mean to manually fix this package
E: Couldn't lock list directory...are you root?

Gruss Thomas :S

J-B

User

Beiträge: 381

Registrierungsdatum: 25.05.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

19

13.07.2008, 00:10

Zitat

E: Couldn't lock list directory...are you root?
Sagt schon einiges, oder?

Probier es mit sudo!
Laptop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo T7500 2,20 GHz RAM: 3072 MB Festplatte: 160 GB Modell: Dell XPS M1330

Desktop:
OS: Ubuntu Intrepid Ibex 8.10 32bit Kernel: 2.6.27 Prozessor: Intel Core 2 Duo 6550 2,33 GHz RAM: 4096 MB Festplatte: 80 GB

20

13.07.2008, 00:19

Hallo,

wenn du bisher apt-get genutzt hast, dann solltest du das auch weiterhin benutzen und nicht mit aptitude mixen.
Hintergrund
~ Two hours of trial and error can save ten minutes of RTFM ~