Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Needa

User

  • »Needa« ist männlich
  • »Needa« ist der Autor dieses Themas

Beiträge: 11

Registrierungsdatum: 07.12.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

05.05.2008, 11:08

Automatisch mounten ntfs-3g

Moin,

habe ein Problem mit meinem Ubuntu. Habe schon seit Version 7.04 nichts mehr mit Ubuntu gemacht und jetzt bei 8.04 gibt's das ntfs-3g auch noch integriert: GEIL!
Wollte mir jetzt meine Daten-Partition beim Start automatisch mounten lassen und habe mir dazu auch den Wiki-Eintrag durchgelesen und mich dann gleich ran gemacht und die /etc/fstab folgendermaßen editiert:

Quellcode

1
2
3
# Eigene Mountpunkte
# /dev/sda6
/dev/sda6   	/media/Datenbank    	ntfs-3g defaults,locale=de_DE.UTF-8 0 0,umask=000 0 0


Hab auch schon versucht per UUID zu mounten, allerdings mountet er die Partition beim Systemstart nie.
Wenn ich per Mausklick mounten möchte, also Orte->Datenbank (so heißt die Partition), dann kommt folgende Fehlermeldung:

Zitat


Unable to mount the volume 'Datenbank'

[mntent]: Zeile 14 in fstab ist fehlerhaft
mount: konnte /media/Datenbank in fstab oder mtab nicht finden


Hoffe ihr könnt helfen.
Danke im Voraus,

Needa

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Needa« (05.05.2008, 11:45)


Buba

User

  • »Buba« ist männlich

Beiträge: 1 947

Registrierungsdatum: 13.04.2006

Derivat: Kubuntu

Architektur: 32-Bit PC

Desktop: KDE4

  • Nachricht senden

2

05.05.2008, 11:11

Und was steht in dieser Zeile 14 ?

Und warum sagst du NTFS-3g das nicht einfach so:
1.

Quellcode

1
sudo apt-get install ntfs-config

2.

Quellcode

1
sudo ntfs-config

Und hier dann sagen, dass alles automatisch gemountet werden soll.

3

05.05.2008, 11:11

Quellcode

1
locale=de_DE.UTF-8 0 0


Das erscheint mir schleierhaft! Die zwei Nullen am Ende ergeben Sinn, aber zwischendrin? Ne, vermute mal, da liegt der Fehler. Mach doch mal die zwei Nullen weg und speicher das Ganze. :)

Grüße, euer
Ovim-Obscurum ;)

Needa

User

  • »Needa« ist männlich
  • »Needa« ist der Autor dieses Themas

Beiträge: 11

Registrierungsdatum: 07.12.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

4

05.05.2008, 11:35

Moin,

danke schon mal für die schnellen Antworten!

Zitat von »Buba«

Und was steht in dieser Zeile 14 ?


Zeile 14 ist die Zeile, in der ich die Partition mounten möchte. Wäre im Quote Zeile 3. Möchte das ganze eigentlich per fstab händisch regeln, einfach des Lerneffekts wegen. Falls es nicht anders geht werd ich deine Methode verwenden.

Zitat von »Ovim-Obscurum«

Das erscheint mir schleierhaft! Die zwei Nullen am Ende ergeben Sinn, aber zwischendrin? Ne, vermute mal, da liegt der Fehler. Mach doch mal die zwei Nullen weg und speicher das Ganze. :)


Die zwei Nullen sind ja für die Rechte, oder? Hab die überflüssigen entfernt und hinten am umask dran gelassen. Sieht jetzt so aus:

Quellcode

1
/dev/sda6   	/media/Datenbank    	ntfs-3g defaults,locale=de_DE.UTF-8,umask=000 0 0


Allerdings mountet er immer noch nicht, meldet jetzt

Zitat

mount: nur root kann /dev/sda6 auf /media/Datenbank einhängen
.
Werd mich nochmal ran setzen, bin für jede Hilfe dankbar.

5

05.05.2008, 11:39

Hallo,

gut, dann ist das jetzt ja "nur" noch ein Rechteproblem. Lag zwischen dem Editieren der Datei und deinem letzten Versuch ein Reboot? Sonsts geht nämlich nicht, aber probiere mal das aus:

Quellcode

1
sudo mount -a


Dann sollte es gehen, wenn nicht, dann eben ein Reboot und es sollte gehen! :)

Grüße, euer
Ovim-Obscurum ;)

Needa

User

  • »Needa« ist männlich
  • »Needa« ist der Autor dieses Themas

Beiträge: 11

Registrierungsdatum: 07.12.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

6

05.05.2008, 11:45

Funktioniert einwandfrei. Danke!

7

05.05.2008, 11:48

Keine Ursache, dazu sind wir doch da. Viel Spaß weiterhin mit Ubuntu und dem Forum. :)

Grüße, euer
Ovim-Obscurum ;)

  • »Oli_P_aus_E« ist männlich

Beiträge: 289

Registrierungsdatum: 07.05.2007

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

8

13.11.2008, 20:21

Und was steht in dieser Zeile 14 ?

Und warum sagst du NTFS-3g das nicht einfach so:
1.

Quellcode

1
sudo apt-get install ntfs-config

2.

Quellcode

1
sudo ntfs-config

Und hier dann sagen, dass alles automatisch gemountet werden soll.

Ist zwar schon ein älterer Beitrag, aber sehr nützlich... Genau das hatte ich gesucht :) Vielen Dank für den Tip :thumbup:
Gruss,
Olle