Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

20.04.2008, 19:03

[gelöst] (Windows)freigaben in Nautilus automatisch auflisten

Hallo Leute,

gestern habe ich auf meinem Notebook den RC von Ubuntu 8.04 Hardy Heron mit Gnome Desktop installiert. Jetzt möchte ich gerne auf die Freigaben eins Rechners mit Windows Vista zugreifen. Das funktioniert soweit auch super. Die verfügbaren Freigaben werden allerdings nicht automatisch im Nautilus angezeigt. Wenn ich Orte -> Netzwerk -> <Servername> aufrufe, bleibt das Fenster leer. Wenn ich nun den Namen einer Freigabe an die Adresszeile anhänge, werde ich nach dem Passwort gefragt und kann drauf zugreifen.

Wenn ich in der Konsole

Quellcode

1
smbclient --list <servername>
aufrufe, werde ich nach dem Passwort gefragt und anschließend sämtliche Freigaben aufgelistet.

Was muss ich machen, damit Nautilus mich vor dem Zugriff auf eine bestimmte Freigabe nach dem Passwort fragt, um anschließend die verfügbaren Freigaben anzuzeigen?

Vielen Dank für eure Hilfe,
xelaris

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »xelaris« (22.04.2008, 19:19)


  • »nO_okY« ist männlich

Beiträge: 319

Registrierungsdatum: 17.01.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

Andere Betriebssysteme: Debian

  • Nachricht senden

2

21.04.2008, 10:46

Mahlzeit,

das Problem erscheint logisch. Denn wenn du noch kein Passwort eingegeben hast zeigt Nautilus (bzw. GVFS) die Freigaben an, die du benutzen darfst. Eine Lösung dafür wäre mir nicht bekannt, aber du könntest folgendes versuchen:

1. Auf der Windows Maschine das "Gast" bzw. "Guest"-Konto deaktivieren. Dies sollte (ungetestet) eigentlich ergeben, das du beim Aufruf in Nautilus direkt nach einem Passwort gefragt wirst.

2. Du könntest das Passwort speichern wenn du eine Freigabe direkt angesprochen hast. (auch ungetestet) Dies ist zwar unsicher, sollte aber ergeben das er es jedesmal die Verbindung mit der richtigen Authentifizierung startet.

bis neulich.

nO_okY
Unix is sexy
who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; mount; sleep

"Mind what you have learned. Save you it can." - Master Yoda

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »nO_okY« (21.04.2008, 10:53)


localhope

uıɹoʇɐɹǝpoɯ-ex

  • »localhope« ist weiblich

Beiträge: 1 330

Registrierungsdatum: 13.06.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

Andere Betriebssysteme: Gentoo 2008

  • Nachricht senden

3

21.04.2008, 10:49

Nun, bei mir funktioniert das einwandfrei. Habe auf meinen Desktop die Server als Icon liegen (IP), werde dann nach Account und PW gefragt, gebe diese ein, anschließend erscheinen alle Dateien. In Nautilus. Ich verwende wie gesagt die IP des Servers.
Admin-Ausrede # 4465: secretary plugged hairdryer into UPS

  • »nO_okY« ist männlich

Beiträge: 319

Registrierungsdatum: 17.01.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

Andere Betriebssysteme: Debian

  • Nachricht senden

4

21.04.2008, 10:52

Mahlzeit,

ich vermute aber einfach mal das die Version der Windows Maschine seinerseits keine "Server" im nahmen beinhaltet sondern eher "Home" oder "Professional", womit die Konfiguration von vorn herein ein wenig anders aussieht. ;)

bis neulich.

nO_okY
Unix is sexy
who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; mount; sleep

"Mind what you have learned. Save you it can." - Master Yoda

5

21.04.2008, 11:59

Hallo,
das Problem erscheint logisch. Denn wenn du noch kein Passwort eingegeben hast zeigt Nautilus (bzw. GVFS) die Freigaben an, die du benutzen darfst.
Ja, genau. Deshalb müsste Nautilus mich direkt nach den Zugangsdaten fragen.
1. Auf der Windows Maschine das "Gast" bzw. "Guest"-Konto deaktivieren. Dies sollte (ungetestet) eigentlich ergeben, das du beim Aufruf in Nautilus direkt nach einem Passwort gefragt wirst.
Das ist eigentlich während meiner Versuche die ganze Zeit deaktiviert gewesen, Habe es nur mal vorübergehend aktiviert.
2. Du könntest das Passwort speichern wenn du eine Freigabe direkt angesprochen hast. (auch ungetestet) Dies ist zwar unsicher, sollte aber ergeben das er es jedesmal die Verbindung mit der richtigen Authentifizierung startet.
Das habe ich jetzt versucht. Jetzt werde ich auch nicht mehr nach dem Passwort gefragt, wenn ich direkt auf eine Freigabe zugreife, aber aufgelistet werden sie immer noch nicht.
Nun, bei mir funktioniert das einwandfrei. Habe auf meinen Desktop die Server als Icon liegen (IP), werde dann nach Account und PW gefragt, gebe diese ein, anschließend erscheinen alle Dateien. In Nautilus. Ich verwende wie gesagt die IP des Servers.
Habe es auch mal so probiert und im Nautilus die IP eingeben "smb://192.168.178.20/"
Leider ohne Erfolg. Auch dann werde ich nicht nach den Zugangsdaten gefragt. Erst nachdem ich den Namen einer Freigabe da anhänge, muss ich die Daten eingeben und der Inhalt dieser Freigabe wird angezeigt. Welche Ubuntu Version benutzt du? Vielleicht liegt es ja auch daran, dass es eben noch ein RC ist. Ich sollte es vielleicht mal mit einer älteren Ubuntu Version probieren.
ich vermute aber einfach mal das die Version der Windows Maschine seinerseits keine "Server" im nahmen beinhaltet sondern eher "Home" oder "Professional", womit die Konfiguration von vorn herein ein wenig anders aussieht.
Ich verstehe nicht ganz was du meinst, aber der Windows Rechner hat kein "Server" im Namen. Das <servername> war nur als Platzhalter für den Rechernamen gedacht. Und auf dem Rechner läuft ein Vista in der Business Edition.

Trotzdem erstmal vielen Dank an euch beide.

[Ergänzt am 21.04. um 12:36Uhr]
Jetzt habe ich es mal mit alten alten Rechner unter Ubuntu 7.10 probiert und siehe da, es funktioniert so wie gewünscht. Unter "Orte -> Netzwerk" auf das Symbol für den den Vista Rechner klicken und in dem dann eingeblendeten Fenster die Zugangsdaten eingeben. Anschließend werden sämtliche Freigaben angezeigt. Also liegt es wohl tatsächlich an Ubuntu.
Hat vielleicht noch jemand den RC von 8.04 Hardy Heron installiert, greift damit auf Freigaben unter Windows Vista zu und kann kann dieses Problem bestätigen oder läuft es bei euch unter dieser Konstellation?

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »xelaris« (21.04.2008, 12:37)


localhope

uıɹoʇɐɹǝpoɯ-ex

  • »localhope« ist weiblich

Beiträge: 1 330

Registrierungsdatum: 13.06.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

Andere Betriebssysteme: Gentoo 2008

  • Nachricht senden

6

21.04.2008, 12:40

Ja, ich nutze hier auch 7.10. Daher erklärt sich das wohl so.
Admin-Ausrede # 4465: secretary plugged hairdryer into UPS

  • »nO_okY« ist männlich

Beiträge: 319

Registrierungsdatum: 17.01.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

Andere Betriebssysteme: Debian

  • Nachricht senden

7

22.04.2008, 10:09

Mahlzeit.

Das mit dem Server ist so gemeint, das "Windows Server 2003" z.B. von Haus aus eine andere Zugriffskonfiguration hat. Aber das ist nebensächlich.

Da ich gerade erst erfahren habe das du Hardy benutzt, kann dies auch noch ein Bug in GVFS sein, das seit Gnome 2.22 benutzt wird und GnomeVFS abgelöst hat.

Zitat

Ja, genau. Deshalb müsste Nautilus mich direkt nach den Zugangsdaten fragen.
Eben nicht, solange das Gastkonto aktiviert ist, was es ja wie du sagst nicht war. Da es mit "smbclient --list <servername>" funktioniert, wird es vermutlich eher ein Bug in GVFS ist.
Hier steht das alles http://library.gnome.org/misc/release-no…/#sect:gvfs-gio

Bis neulich.

nO_okY
Unix is sexy
who | grep -i blonde | date; cd ~; unzip; touch; strip; finger; mount; gasp; yes; uptime; mount; sleep

"Mind what you have learned. Save you it can." - Master Yoda

8

22.04.2008, 11:45

Moin,

danke für den Hinweis. Dadurch bin ich auf folgende Seiten gestoßen. Es scheint sich tatsächlich um einen Bug zu handeln.

http://bugzilla.gnome.org/show_bug.cgi?id=522494
https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/207072

Über den zweiten Link ist auch dieser Beitrag mit einem Patch erreichbar, den ich aber noch nicht getestet habe.

Ich habe zwar noch nicht so ganz begriffen wo der Bug sich befindet (nautilus, gvfs,...), aber anscheinend arbeiten ja schon ein paar Leute dran.

Durch den ersten Link bin ich auf gnome-commander gestoßen, der aber anscheinend nicht zum offiziellen Gnome-Projekt gehört. Bei dem funktioniert der Zugriff auf die Windowsfreigaben wie gewünscht.

Bin mal optimistisch, dass der Fehler demnächst behoben wird, schließlich sind es ja auch noch ganze zwei Tage bis zur Release :).

Im Nachhinein wäre ein Beitrag in Bereich "Unstable Ubuntu - Hardy Heron" wohl passender gewesen.

localhope

uıɹoʇɐɹǝpoɯ-ex

  • »localhope« ist weiblich

Beiträge: 1 330

Registrierungsdatum: 13.06.2006

Derivat: Ubuntu

Architektur: 32-Bit PC

Andere Betriebssysteme: Gentoo 2008

  • Nachricht senden

9

22.04.2008, 11:47

Richtig.
Na dann ist das Thema wohl halbwegs [gelöst]. Ich verschiebs btw mal in Hardy Unstable.
Admin-Ausrede # 4465: secretary plugged hairdryer into UPS