Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

mdd

User

  • »mdd« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 20.03.2008

Derivat: Ubuntu

  • Nachricht senden

1

20.03.2008, 16:14

SMB - Freenas mounten

hallo. erstmal lob für das forum... viele sachen konnte ich mit eurer hilfe schon lösen. jetzt habe ich aber ein problem bei dem ich nicht weiterkomme.

wenn ich ein smb verzeichnis mounte so wie es hier beschrieben ist:

http://wiki.ubuntuusers.de/Samba_Client

also mit


sudo mount -t smbfs -o //freenas/NAS /media/nas


macht er das im terminal zwar. wenn ich dann aber auf den ordner zugreifen will bekomme ich immer folgende fehlermeldung : the folder contents could not be displayed sorry couldn t display all contents of "nas". wenn ich mir aber die eigenschaften von dem ordner nas im media ordner anzeigen lasse sind diese auch richtig (180 GB gesamtspeicher 25 GB freier Speicher.)


wenn ich auf den freenas server (smb freigabe) mit dem gnome panel über smb://freenas/nas zugreife geht auch alles. ich sehe die dateien und kann sie auch abspielen (filme) oder anhöhren (mp3) allerdings nur über den standartplayer und nicht über vlc (den kann ich komischerweise nur nehmen wenn die filme direkt auf meiner festplatte sind). ich würde also die Freenas smb freigabe fest in das system einbinden. unter windows kann ich auf die smb freigabe ganz normal zugreifen weil ich sie als netzlaufwerk eingebunden habe. was mache ich falsch?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »mdd« (20.03.2008, 16:17)


chrootdev

Ubuntu-Forum-Team

  • »chrootdev« ist männlich

Beiträge: 2 221

Registrierungsdatum: 04.03.2008

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Debian Testing

  • Nachricht senden

2

20.03.2008, 16:28

Bist du sicher das du auch die richtigen rechte hast?
"Do or do not. There is no try." (Yoda) || Thread auf gelöst/erledigt setzen

mdd

User

  • »mdd« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 20.03.2008

Derivat: Ubuntu

  • Nachricht senden

3

20.03.2008, 16:30

habe nur einen benutzer angelegt der sollte ja automatisch root rechte haben oder?

chrootdev

Ubuntu-Forum-Team

  • »chrootdev« ist männlich

Beiträge: 2 221

Registrierungsdatum: 04.03.2008

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Debian Testing

  • Nachricht senden

4

20.03.2008, 16:44

Geh in der konsole in das verzeichnis /media und gib folgendes in der konsole ein:

Quellcode

1
ls -l


und poste was er schreibt!
"Do or do not. There is no try." (Yoda) || Thread auf gelöst/erledigt setzen

mdd

User

  • »mdd« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 20.03.2008

Derivat: Ubuntu

  • Nachricht senden

6

20.03.2008, 16:53

lrwxrwxrwx 1 root root 6 2008-03-20 09:02 cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2008-03-20 09:02 cdrom0
drwxr-xr-x 1 root root 4096 2008-03-20 15:36 nas
root@localhost:/media# cd /nas
bash: cd: /nas: No such file or directory
root@localhost:/media#

Beiträge: 6 677

Registrierungsdatum: 04.06.2005

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Arch Linux

  • Nachricht senden

7

20.03.2008, 16:56

Hallo,

drwxr-xr-x 1 root root 4096 2008-03-20 15:36 nas

und schreiben willste nicht?

habe nur einen benutzer angelegt der sollte ja automatisch root rechte haben oder?

Wohl nicht, überlege mal.

Falls du etwas mehr Infos dazu suchst schaue auf meiner Homepage vorbei unter Links und Linux und Tipps und Tricks.

http://linuxtal.de


m.f.g.
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

mdd

User

  • »mdd« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 20.03.2008

Derivat: Ubuntu

  • Nachricht senden

8

20.03.2008, 17:00

Hallo,

drwxr-xr-x 1 root root 4096 2008-03-20 15:36 nas

und schreiben willste nicht?

habe nur einen benutzer angelegt der sollte ja automatisch root rechte haben oder?

wohl nicht überlege mal.


m.f.g.
Carl-Heinz
ich wäre schon froh wenn ich dateien unter dem mountpunkt angezeigt bekommen würde. wie gesagt wenn ich mich durchklicke (über gnome panel oder unter netzwerk) bekomme ich die dateien komischerweise angezeigt.

chrootdev

Ubuntu-Forum-Team

  • »chrootdev« ist männlich

Beiträge: 2 221

Registrierungsdatum: 04.03.2008

Derivat: Kein Ubuntu-Derivat

Architektur: 64-Bit PC

Desktop: KDE4

Andere Betriebssysteme: Debian Testing

  • Nachricht senden

9

20.03.2008, 17:06

Du hast zwei möglichkeiten, entweder du verpasst dem ordner "nas" mit chmod den wert 777 (nicht zu empfehlen) oder du schaust ob dein benutzer in der gruppe root ist, und gibst dem ordner "nas" mit chmod 775 oder 770 damit du auch schreiben kannst!
"Do or do not. There is no try." (Yoda) || Thread auf gelöst/erledigt setzen

Beiträge: 6 677

Registrierungsdatum: 04.06.2005

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Arch Linux

  • Nachricht senden

10

20.03.2008, 17:08

Hallo,

dann gebe doch bitte den normalen Benutzern auch Schreibrechte auf das Verzeichnis.

Du musst mit Benutzerrechten auf dieses Verezeichnis schreibend zugreifen können
nicht als Root.

m.f.g.
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

mdd

User

  • »mdd« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 20.03.2008

Derivat: Ubuntu

  • Nachricht senden

11

20.03.2008, 17:14

Zitat

root@localhost:/media# sudo chmod 777 -c -R /media/nas
mode of `/media/nas' changed to 0777 (rwxrwxrwx)
root@localhost:/media# ls -l
total 8
lrwxrwxrwx 1 root root 6 2008-03-20 09:02 cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2008-03-20 09:02 cdrom0
drwxr-xr-x 1 root root 4096 2008-03-20 15:36 nas
root@localhost:/media#
ich hoffe mal ich habe es jetzt richtig geändert. sehe nas aber immer noch nicht :-(

Beiträge: 6 677

Registrierungsdatum: 04.06.2005

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Arch Linux

  • Nachricht senden

12

20.03.2008, 20:33

Hallo,

ich wäre schon froh wenn ich dateien unter dem mountpunkt angezeigt bekommen würde. wie gesagt wenn ich mich durchklicke
(über gnome panel oder unter netzwerk) bekomme ich die dateien komischerweise angezeigt.


Wenn du die angezeigt bekommst müssen diese ja auch irgendwo gemountet sein, oder?

drwxr-xr-x 1 root root 4096 2008-03-20 15:36 nas


Da hat sich aber nix verändert, kannst immer nur lesend auf die Verzeichnisse zugreifen.

Würde mal ganz von vorne anfangen, Ping geht wohl, oder?

Anschießend mittels nmblookup prüfen ob die shares angezeigt werden.

Was hast du exportiert auf dem NAS und welche User extistieren da.

Bzw. um was für einen NAS Server handelt es sich eigentlich?

m.f.g.
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

mdd

User

  • »mdd« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 20.03.2008

Derivat: Ubuntu

  • Nachricht senden

13

21.03.2008, 08:33

estmal danke für die hilfe.

also folgendes. ich habe einen alten rechner mit freenas ausgestattet (auf FreeBSD 6 basierendes Betriebssystem) da ist eine festplate die mit smb freigegeben ist so das ich sie unter z.B. Windows dauerhaft als netzlaufwerk eingebunden wird.

jetzt habe ich hier auf ne ps3, die auch an das netzwerk angeschlossen ist, ubuntu installiert. dann vlc und einige codec paks installiert.

wenn ich jetzt unter ubuntu im netzwerk suche finde ich auch den freenas server und kann auch auf ihn zugreifen. wenn ich allerdings einen film abspielen will geht das nur mt dem standartplayer - aus performance gründe würde ich aber lieber vlc nehmen. VLC an sich funktioniert auch aber nur mit filmen die man auf die ps3 kopiert.

Mir wurde gesagt ich muss die freenas festplatte fest in ubuntu einbinden (wie bei windows als netzkaufwerk) um sie voll nutzen zu können.

also habe ich das mit

Zitat



sudo mount -t smbfs //freenas/NAS /media/nas

gemacht. (smbclient habe ich vorher installiert)

wenn ich jetzt auf media/nas gehe braucht er ewig lang und zeigt mir dann obrige fehlermeldung. wenn ich mir aber die eigenschaften von media/nas anzeigen lasse dann zeigt er mir die richtigen werte (180GB gesamt größe 25 GB frei)

Sorry wenn ich mich ein bischen doof anstelle aber ich bin linux neuling....

Beiträge: 6 677

Registrierungsdatum: 04.06.2005

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Arch Linux

  • Nachricht senden

14

21.03.2008, 12:38

Hallo,

das ist nornmal dass du keine Videos abspielen kannst wenn du das nicht über die fstab
gemountet hast.

Du musst also dein NAS über die fstab mounten dann geht es auch.

Falls du es festgestellt haben solltest geht auch kein mp3. :D

Also in die fstab eintragen und ein

mount -a

und es müsste gehen. Das ist ein altbekannter Bug.

m.f.g.
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

mdd

User

  • »mdd« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 20.03.2008

Derivat: Ubuntu

  • Nachricht senden

15

22.03.2008, 08:47

so habe Freenas jetzt in die fstab eingetragen. es mountet die jetzt auch gleich automatisch und sie wird mir bei start direkt angezeigt. wenn ich dann drauf klicke

Zitat

the folder contents could not be displayed sorry couldn t display all contents of "nas"
die schreibrechte von dem ordner /media/nas habe ich auch in 777 geändert. sobald ich freenas aber mounte gibt er wieder die alten Rechte. ?(

Beiträge: 6 677

Registrierungsdatum: 04.06.2005

Derivat: Kein Ubuntu-Derivat

Version: gar kein Ubuntu

Architektur: 64-Bit PC

Desktop: anderer Desktop

Andere Betriebssysteme: Arch Linux

  • Nachricht senden

16

22.03.2008, 20:12

Hallo,

mal ne Frage, geht es von WIndows aus einwandfrei?

Nicht dass es an der NAS konfiguration liegt, dann könnten wir noch lange suchen.

m.f..g
Carl-Heinz
###--- Gott sei Dank, ich bin weg vom Fenster ---###


Hilfen:
- Mir eine Nachricht senden - - Meine Homepage - - Linux-Beginnerforum -

mdd

User

  • »mdd« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 20.03.2008

Derivat: Ubuntu

  • Nachricht senden

17

24.03.2008, 09:26

jep von windows auf läuft es ohne probleme.



hat ubuntu ein problem mit zu großen verzeichnis namen oder zu vielen ordner bzw. unterordnern?

Beiträge: 1

Registrierungsdatum: 28.10.2008

Architektur: 64-Bit PC

Desktop: KDE3

  • Nachricht senden

18

28.10.2008, 09:22

drwxr-xr-x 1 root root 4096 2008-03-20 15:36 nas


Hi ,

Dein Problem liegt darin, dass Du dein nas beim Mounten nicht für den User eingerichtet hast.
Deine Ausgabe soll so aussehen: drwxr-xr-x 1 MyUser MyUser 4096 2008-03-20 15:36 nas

So könnte dein mount aussehen:

Quellcode

1
 mount -t cifs -o username=xxxx,password=yyyyy,gid=users,uid=MyUser //server/share /mountpoin

oder in fstab-Datei:
//Server/share /Mountpoint cifs username=xxxx,password=yyyyy,uid=MyUser,gid=users 0 0

(username, password sind die Zugangsdaten auf dem entfernten Rechner)

Du kannst natürlich statt cifs, smbfs oder nfs benutzen.

:)