Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Arrpork« ist männlich
  • »Arrpork« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 03.02.2007

  • Nachricht senden

1

24.10.2007, 21:13

Ubuntu 7.10 universe paketfehler

Hallo,

sobald ich nach der Installation die Softwarequelle "universe" auswähle, also den
Knopf: "Von der Gemeinschaft betreute Open-Source-Software (universe) im Tool
"Software-Quellen" drücke, bekomme ich nach dem Aktualisieren der Sources folgende Fehlermeldung:

http://de.archive.ubuntu.com/ubuntu/dist…6/Packages.bz2: Unterprozess bzip2 ist mit einem Fehlercode zurückgekehrt (2)

Leider benötige ich jedoch Pakete aus dem "universe" Bereich. Hat jemand eine Idee wie ich das Problem beseitigen kann ?


Gruß Arrpork

  • »b.q.wemer« ist männlich

Beiträge: 539

Registrierungsdatum: 17.11.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Andere Betriebssysteme: Fedora

  • Nachricht senden

2

25.10.2007, 08:17

Hi,

versuch mal ein

sudo apt-get -f install

Wenn das nicht hilft, bitte die sources.list posten. Vielleicht hat sich ja ein Fehler eingeschlichen.

mfG

  • »Arrpork« ist männlich
  • »Arrpork« ist der Autor dieses Themas

Beiträge: 13

Registrierungsdatum: 03.02.2007

  • Nachricht senden

3

27.10.2007, 07:25

Ich habe mir jetzt extra nochmal die Ubuntu DVD aufgespielt. Aber die Probleme bleiben. Ich bekomme beim Updaten der Quellen nicht alle Dateien, er bleibt immer wieder zwischendrin stehen. Da kann ich versch. Server auswählen, soviel ich will. Nur wenn ich nur die Updates in den Quellen angebe funktioniert alles. Wenn ich irgendeine zusätzliche Source angebe habe ich wie beschrieben die Probleme.

Meine sources.list:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071017)]/ gutsy main restricted
# See [URL]http://help.ubuntu.com/community/UpgradeNotes[/URL] for how to upgrade to
# newer versions of the distribution.


## Major bug fix updates produced after the final release of the
## distribution.
deb [URL]http://archive.ubuntu.com/ubuntu/[/URL] gutsy-updates main restricted universe multiverse
deb-src [URL]http://archive.ubuntu.com/ubuntu/[/URL] gutsy-updates main restricted universe multiverse #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# Line commented out by installer because it failed to verify:
# deb [URL]http://de.archive.ubuntu.com/ubuntu/[/URL] gutsy universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb [URL]http://de.archive.ubuntu.com/ubuntu/[/URL] gutsy-backports main restricted universe multiverse
# deb-src [URL]http://de.archive.ubuntu.com/ubuntu/[/URL] gutsy-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb [URL]http://archive.canonical.com/ubuntu[/URL] gutsy partner
# deb-src [URL]http://archive.canonical.com/ubuntu[/URL] gutsy partner

deb [URL]http://archive.ubuntu.com/ubuntu/[/URL] gutsy universe main restricted multiverse
deb-src [URL]http://archive.ubuntu.com/ubuntu/[/URL] gutsy universe main multiverse restricted #Added by software-properties
deb [URL]http://archive.ubuntu.com/ubuntu/[/URL] gutsy-security main restricted universe multiverse
deb-src [URL]http://archive.ubuntu.com/ubuntu/[/URL] gutsy-security main restricted universe multiverse #Added by software-properties


Vielleicht hat noch jemand eine Idee.

Wenn ich mit aptitude update das update der sources durchführe, erhalte ich folgende Fehlermeldung

Quellcode

1
2
3
4
5
6
7
8
9
10
Treffer http://archive.ubuntu.com gutsy/restricted Translation-de               
99% [3 Translation-de bzip2 0] [Warte auf Kopfzeilen (header)]          61B/s 0s
bzip2: Data integrity error when decompressing.
        Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.


Update 1: Wie kann ich denn diesen Fehler beheben ?
Sind die Sources in Ordnung ?

Update2: Ich habe jetzt von der Ubuntu Live Desktop CD gebootet und nicht gleich installiert. Dann habe ich unter der Live-CD die Sources für multiverse und universe durch Klicken auf die Sources hinzugefügt. Aber auch hier funktieren die Sources nicht. Sogar ein nicht installiertes Ubuntu auf englisch hat das Problem. Kann es sein, dass dies bei niemanden funktioniert ?

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »Arrpork« (28.10.2007, 22:33)