Sie sind nicht angemeldet.

wid

User

  • »wid« ist männlich
  • »wid« ist der Autor dieses Themas

Beiträge: 132

Registrierungsdatum: 10.07.2005

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

1

26.06.2007, 11:39

scanner epson perfection 1670 läuft nicht unter Feisty

Scanner epson perfection 1670 lief vor Feisty mit entsprechende firmware-eintragungen und Freischaltungen

in /etc/sane.d/snapscan.conf und
/etc/sane.d/epson.conf einwandfrei

Seit Feisty Fawn läuft ein scan ok beim 2. Scan steigt der Scanner aus ,
und man muss mit Strom aus und Neustart XSane sich den nächsten Scan neu "erkämpfen".

1. englische Beiträge beschreiben diesen Fehler auch . Leider ist nirgends eine Lösung erkennbar !

2. Lässt sich die alte Version irgendwie auf einfache Weise wieder rekonstruieren ?

Bin für jede Hilfe dankbar
Ade

uli2

User

  • »uli2« ist männlich

Beiträge: 174

Registrierungsdatum: 27.03.2006

  • Nachricht senden

2

27.06.2007, 20:26

Die alte Version hilft dir nicht. Das Problem liegt am Kernel (USB_SUSPEND). Eine Lösung für Feisty wird es wohl nicht geben. Ich habe mir einen Befehl scannen eingerichtet mit folgendem Inhalt:

#!/bin/sh
scanbuttond -r 1000000
xsane

Damit kann ich von vereinzelten Störungen abgesehen komfortabel scannen. Nach Ende muss man mit killall scanbuttond die Scanner-Aktivierung beenden.

Gruß
Uli

wid

User

  • »wid« ist männlich
  • »wid« ist der Autor dieses Themas

Beiträge: 132

Registrierungsdatum: 10.07.2005

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

3

28.06.2007, 10:28

Danke für Deine Antwort.

Jedoch , wenn ich als user (vorher chmod +x) das Programm mit Scannen starte
öffnet sich x-sane-Scanprogramm und der Fehler tritt beim 2. scannen wie gehabt auf.

Oder handhabst Du es anders?

Ich verwende Gnome. Beim Entfernen von x-sane-Programm würde ubuntu-desktop auch entfernt !

Gibt es die Möglichkeit auf Kommando-Zeile zu scannen?

Ev. wäre es doch vielleicht möglich über wine das xp - Scann-Programm zu starten?

Wie siehst Du diese Möglichkeiten-ich bin theoretisch dazu nicht in der Lage und
erwarte gerne Vorschläge,ehe ich den Scanner entsorgen muss.

mfg
Ade

uli2

User

  • »uli2« ist männlich

Beiträge: 174

Registrierungsdatum: 27.03.2006

  • Nachricht senden

4

28.06.2007, 22:11

Dann bist du wohl noch übler von diesem Bug betroffen. Ich scanne mit diesem Befehl auch etliche Male hintereinander als User ohne Probleme. Ich scanne relativ oft und war mit dieser Lösung zufrieden, bis ich auch zum ersten Mal derartige Geräusche aus dem Scanner hörte, dass ich erst mal den Stecker gezogen habe.
Ich muss zugeben, dass ich den Weg über wine nie probiert habe, ich kann mir aber nicht vorstellen, dass das funktioniert. Dir hilft wahrscheinlich nur die Lösung, die ich auch schon mal mit Erfolg verwendet habe, nämlich einen neuen Kernel kompilieren und dabei USB_SUSPEND deaktivieren. Zur Not geht auch die Variante mit scanimage, aber das Ganze hat dann schon eine Art Steinzeittouch! Näheres findest du unter https://bugs.launchpad.net/ubuntu/+sourc…ends/+bug/85488.
Leider geht das Gemurkse auch unter Gutsy lustig weiter. Wann gibt man bei Ubuntu endlich das offensichtlich nicht ausgereifte USB_SUSPEND auf?

Gruß
Uli

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »uli2« (28.06.2007, 22:12)


wid

User

  • »wid« ist männlich
  • »wid« ist der Autor dieses Themas

Beiträge: 132

Registrierungsdatum: 10.07.2005

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

5

21.10.2007, 11:53

Achtung!

Unter Ubuntu 7.10 läuft alles wieder zufriedenstellend.

Ok

Gruss
Ade

Erl

User

  • »Erl« ist männlich

Beiträge: 464

Registrierungsdatum: 03.11.2006

Architektur: 64-Bit PC

Andere Betriebssysteme: UbuntuGnome, Crunchbang

  • Nachricht senden

6

26.12.2007, 22:42

Also ich bekomme den perfection1670 nicht zum laufen.
Habe "sane" und "sane-util"installiert.
Im Anhang ein Bild: Oben die Fehlermeldung von Xscan(sucht den Scanner gibt die Fehlermeldung und bricht ab) und unten das Ergebnis von "scanimage -L"

Was mache ich falsch ?

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Erl« (26.12.2007, 22:44)


wid

User

  • »wid« ist männlich
  • »wid« ist der Autor dieses Themas

Beiträge: 132

Registrierungsdatum: 10.07.2005

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

7

27.12.2007, 12:01

Voraussetzung:
1. gedit /etc/sane.d/snapscan.conf
dort eintragen:
firmware /home/wid/Downloads/esfw30.bin

d.h.. in meinem home - Verzeichnis unter Downloads esfw30bin heruntergeladen.

2. gedit /etc/sane.d/epson.conf
dort:
epson.conf (ist ohne #!) und
firmware /home/wid/Downloads/esfw30.bin

so klappt es wunderbar!

Gruß
Ade

Erl

User

  • »Erl« ist männlich

Beiträge: 464

Registrierungsdatum: 03.11.2006

Architektur: 64-Bit PC

Andere Betriebssysteme: UbuntuGnome, Crunchbang

  • Nachricht senden

8

27.12.2007, 16:50

keine Änderung...

Quellcode

1
2
3
4
5
uwe@uwe-laptop:~$ scanimage -l
[snapscan] Cannot open firmware file /usr/share/sane/snapscan/your-firmwarefile.bin.
[snapscan] Edit the firmware file entry in snapscan.conf.
scanimage: open of device snapscan:libusb:004:004 failed: Invalid argument
uwe@uwe-laptop:~$


Die beiden Dateien als Anhang!

HILFE

wid

User

  • »wid« ist männlich
  • »wid« ist der Autor dieses Themas

Beiträge: 132

Registrierungsdatum: 10.07.2005

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

9

27.12.2007, 17:39

Bei Dir steht in epsonconf
firmware /usr/share/sane/snapscan/your-firmwarefile.bin

entferne das und schreibe dafür

firmware /usr/share/sane/snapscan/esfw30.bin

wenn Du tatsächlich in /usr/share/sane/snapscan/
das heruntergeladene esfw30.bin stehen hast

Gruß
Ade

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wid« (27.12.2007, 17:45)


Erl

User

  • »Erl« ist männlich

Beiträge: 464

Registrierungsdatum: 03.11.2006

Architektur: 64-Bit PC

Andere Betriebssysteme: UbuntuGnome, Crunchbang

  • Nachricht senden

10

27.12.2007, 18:17

OHHH MANNN ....... !!!!
Das die Zeile oben schon stand hatte ich übersehen und weiter unten händisch eingegeben !

Wer lesen kann ist klar im Vorteil !


Danke dir ....... er scannt !



P.S.: Jetzt würde ich gerne auf gelöst stellen =)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Erl« (27.12.2007, 18:18)