Sie sind nicht angemeldet.

  • »Jan_B87« ist männlich
  • »Jan_B87« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 04.06.2006

  • Nachricht senden

1

04.06.2006, 12:40

mausstick unter X deaktivieren

ich hab ein dell latitude c610. die tastautur besitzt wie die Thinkpad Notebooks solch ein mausstick (keine ahnung wie das richtig heißt)
dummerweise hat das bei mir ein eigenleben entwickelt, wahrscheinlich ist da staub auf den kontakten und der cursor schießt immer über den ganzen desktop. weil ich sowieso nur das touchpad oder eine usbmaus benutze, wollte ich das ding aus der konfiguration des xservers nehmen. aber das steht nicht als einzelnes inputdevice drin... läuft das direkt über die tastatur? wie deaktiviere ich nun den mausstick?




ich hänge mal noch die konfigurtionsdatei an. ich hab auch etwas rumexperimentiert und imputdevices auskommentiert, habs aber nicht geschafft, den mausstick zu deaktivieren. ich hab meine tastatur auch mal auseinandergenommen und alles sauber gemacht - es hat nicht geholfen. der cursor macht noch immer was er will und rennt über den ganzen desktop. wäre nett, wenn mir jemand helfen könnte, denn so kann man echt nicht arbeiten... versucht mal so etwas anzuklicken :)



# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility M6 LY [Radeon Mobility 9000]"
Driver "ati"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies, Inc. Radeon Mobility M6 LY [Radeon Mobility 9000]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Jan_B87« (19.06.2006, 16:00)


  • »Jan_B87« ist männlich
  • »Jan_B87« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 04.06.2006

  • Nachricht senden

2

13.06.2006, 16:00

hey redet mit mir!
wo liegt das problem? habt ihr verstanden, was ich meine (was ich mausstick nenne ist doch klar, oder?)
das kann doch kein unlösbares problem sein! woran scheitert es jetzt?
braucht ihr mehr informationen?

  • »ggremlin« ist männlich

Beiträge: 2 622

Registrierungsdatum: 01.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Andere Betriebssysteme: debian lenny, arch linux,

  • Nachricht senden

3

13.06.2006, 16:25

Hiho,

wenn keiner antwortet kann es offensichtlich daran liegen dass bisher noch niemand dieses Problem hatte.


gruss dirk
AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ 2x512 KB,Sockel AM2 EE 65 W
MSI Mainboard K9N Neo-F Sockel AM2
NVIDA 8500GT,256MB PCI_Express
4096 MB DDR2 Corsair Twin2X CL

  • »webbutterfly« ist weiblich

Beiträge: 472

Registrierungsdatum: 21.07.2005

Derivat: Ubuntu

Architektur: 32-Bit PC

  • Nachricht senden

4

13.06.2006, 16:38

Zitat

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

...nu, da liegt es ja...
kommentier das mal aus...

Marion

Ubuntu Österreich



  • »Jan_B87« ist männlich
  • »Jan_B87« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 04.06.2006

  • Nachricht senden

5

13.06.2006, 19:50

danke für die antworten... ich hab die zeilen auskommentiert und ich hab ja auch so schon rumexperimentiert und die schlechte nachricht ist, es hat nicht funktioniert. der mausstick ist immer noch aktiv und der cursor macht noch immer was er will. aber irgendwo muß der mausstick ja konfiguriert sein! ich hatte vorher gentoo drauf und da funktionioerte der stick nicht. am besten ich installiere nochmal gentoo parallel und kopiere die xorg.conf datei.

es kann sich ja eigentlich nur in der konfiguration der tastatur befinden:

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

aber das ist doch ganz normal, oder?

  • »Jan_B87« ist männlich
  • »Jan_B87« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 04.06.2006

  • Nachricht senden

6

16.06.2006, 11:07

so ich habe langsam das gefühl, dass es gar nicht an der xorg.conf liegt!
kann es sein, dass irgendein hotplug service den mausstick einhängt? ich bin kein experte, also helft mir bitte - wo kann eine maus noch im system konfiguriert werden? gibt es keinen befehl, der mir ein paar informationen über die konfiguration ausspuckt?

hier nochmal ein bild vom übeltäter



eine neue tastatur kaufen, kommt wohl eher nicht in frage, denn diewollen um die 60€ und da kann ich mir ja fast den laptop neu kaufen :)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Jan_B87« (16.06.2006, 11:22)


  • »Jan_B87« ist männlich
  • »Jan_B87« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 04.06.2006

  • Nachricht senden

7

19.06.2006, 14:47

experte gesucht!

ich möchte ja nicht unnötig nerven, aber gibt es hier denn keinen experten mit einer grandiosen idee? ich brauche meinen laptop, kann aber mit dem ding so nicht arbeiten, zumindest nicht mit einer grafischen oberfläche. ich bin also für jeden hilfreichen vorschlag dankbar! ich geb euch für die lösung auch ein bier aus ;)

  • »ggremlin« ist männlich

Beiträge: 2 622

Registrierungsdatum: 01.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Andere Betriebssysteme: debian lenny, arch linux,

  • Nachricht senden

8

19.06.2006, 15:35

Hiho,

so wie das aussieht ist das ein IBM Laptop?

Den habe ich auch und da keinerlei Probleme.
Das ist keine extra Mouse.

Probiere es mal mit knoppix,
wenn es da funktioniert würde ich dann bei knoppix
in die etc/X11/xf86 config schauen was der in der section Mouse eingetragen hat.

Das kopieren und in Deine ubuntu xorg.conf eintragen und probieren.


gruss dirk
AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ 2x512 KB,Sockel AM2 EE 65 W
MSI Mainboard K9N Neo-F Sockel AM2
NVIDA 8500GT,256MB PCI_Express
4096 MB DDR2 Corsair Twin2X CL

  • »Jan_B87« ist männlich
  • »Jan_B87« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 04.06.2006

  • Nachricht senden

9

19.06.2006, 16:02

nein, es ist ein dell latitude c 610. und der mausstick funktioniert ja auch, aber wie ich oben schon geschrieben hatte, stimmt da was mit den kontakten nicht, oder schmutz.... was weiß ich, auf jedenfall macht der cursor was er möchte und rennt über den gesamten desktop

ich will den mausstick deaktivieren!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Jan_B87« (19.06.2006, 16:02)


  • »ggremlin« ist männlich

Beiträge: 2 622

Registrierungsdatum: 01.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Andere Betriebssysteme: debian lenny, arch linux,

  • Nachricht senden

10

19.06.2006, 16:06

Zitat

ich will den mausstick deaktivieren!


Achsoooo.....

Okay, dann geh zu der xorg.conf und suche die section mit der mouse,
den Abschnitt einfach kommentieren,
das heisst eine Raute (#) vor jeder betreffenden zeile setzen.
Speichern und damit dürfte es deaktiv sein.


gruss dirk
AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ 2x512 KB,Sockel AM2 EE 65 W
MSI Mainboard K9N Neo-F Sockel AM2
NVIDA 8500GT,256MB PCI_Express
4096 MB DDR2 Corsair Twin2X CL

  • »Jan_B87« ist männlich
  • »Jan_B87« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 04.06.2006

  • Nachricht senden

11

20.06.2006, 09:12

ohne dir zu nah treten zu wollen, aber machst du dir eigentlich die mühe zu lesen, oder gibst du nur deinen senf dazu? die inputdevice auszukommentieren habe ich schon versucht... es liegt nicht an der xorg.conf. bei meinem gentoo funktioniert der mausstick nicht und die xorg.conf sieht gleich aus... es muß sich wohl um einen hotplug service handeln.
sonst noch jemand eine idee?

  • »ggremlin« ist männlich

Beiträge: 2 622

Registrierungsdatum: 01.08.2005

Derivat: Ubuntu

Architektur: 64-Bit PC

Andere Betriebssysteme: debian lenny, arch linux,

  • Nachricht senden

12

20.06.2006, 10:18

Hiho,

doch ich habe es gelesen, aber ich habe es mal bei mir probiert.
Habe auf meinem Laptop auch einen Mauststick.

Habe kommentiert,
neugestartet und schwupps war der deaktiviert.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection


Kommentiere doch diese beiden Sektionen,
dann wie webbutter schon sagte diese
Wacom Tablet PC Zeilen ebenso.

Bei mir funktioniert das deaktivieren prächtig.

Irgendwas machst Du falsch.


Aber gut, dann musst Du schauen welcher Treiber dafür verantwortlich ist.
Den herausnehmen dann müsste es auch gehen.


gruss dirk
AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ 2x512 KB,Sockel AM2 EE 65 W
MSI Mainboard K9N Neo-F Sockel AM2
NVIDA 8500GT,256MB PCI_Express
4096 MB DDR2 Corsair Twin2X CL

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »ggremlin« (20.06.2006, 10:19)


  • »Jan_B87« ist männlich
  • »Jan_B87« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 04.06.2006

  • Nachricht senden

13

20.06.2006, 17:32

danke, aber ich hab alles auskommentiert und es funktioniert noch immer - einfach nicht tot zu bekommen, dieser mausstick. ich weiß nicht, ob mir das angst machen soll, aber mein laptop lässt sich nichts mehr von der xorg.conf sagen.
wie bekomme ich den treiber raus und wo ist der abgelegt, damit ich ihn rauslöschen kann. hat jemand eine idee, wie ich notfalls rausbekomme, welche kontakte ich bei der tastatur durchtrennen muß, damit ich ihn "deaktiviere" (ich bekomme dich noch klein!)

  • »Jan_B87« ist männlich
  • »Jan_B87« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 04.06.2006

  • Nachricht senden

14

23.06.2006, 19:30

so sieht meine xorg.conf jetzt aus. bei den punkten habe ich gekürzt. warum funktioniert das ding immernoch? sind tastaturen standardisiert? kann ich jede laptop tastatur als ersatz nehmen, oder muß es eine für dieses modell sein? kennt jemand eine günstige möglichkeit, wie ich an eine rankomme, oder hat noch jemand einen spontanen gedanken?


Section "Files"
............................
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
..................................
EndSection

# Section "InputDevice"
# Identifier "Configured Mouse"
# Driver "mouse"
# Option "CorePointer"
# Option "Device" "/dev/input/mice"
# Option "Protocol" "ExplorerPS/2"
# Option "ZAxisMapping" "4 5"
# Option "Emulate3Buttons" "true"
# EndSection

# Section "InputDevice"
# Identifier "Synaptics Touchpad"
# Driver "synaptics"
# Option "SendCoreEvents" "true"
# Option "Device" "/dev/psaux"
# Option "Protocol" "auto-dev"
# Option "HorizScrollDelta" "0"
# EndSection

# Section "InputDevice"
# Driver "wacom"
# Identifier "stylus"
# Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
# Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# EndSection

# Section "InputDevice"
# Driver "wacom"
# Identifier "eraser"
# Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# EndSection

# Section "InputDevice"
# Driver "wacom"
# Identifier "cursor"
# Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
# EndSection

Section "Device"
Identifier "ATI Technologies, Inc. Radeon Mobility M6 LY [Radeon Mobility 9000]"
Driver "ati"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
.......................
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
# InputDevice "Configured Mouse"
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
# InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection